summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/yocto-cfg-fragments.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-kernel/linux/yocto-cfg-fragments.bb b/recipes-kernel/linux/yocto-cfg-fragments.bb
new file mode 100644
index 00000000..c8a42267
--- /dev/null
+++ b/recipes-kernel/linux/yocto-cfg-fragments.bb
@@ -0,0 +1,35 @@
1HOMEPAGE = "https://git.yoctoproject.org/cgit/cgit.cgi/yocto-kernel-cache/"
2SUMMARY = "Kernel configuration fragments"
3DESCRIPTION = "Typically used as part of a kernel clone, this is the standalone \
4fragment repository. Making it available to other fragment management schemes \
5"
6SECTION = "devel"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
10
11do_configure[noexec] = "1"
12do_compile[noexec] = "1"
13INHIBIT_DEFAULT_DEPS = "1"
14
15PV = "v5.10+git${SRCREV}"
16SRCREV = "7fab6536c164fd743f17c52bc56a65867e30903a"
17SRC_URI = "\
18 git://git.yoctoproject.org/yocto-kernel-cache;branch=yocto-5.10 \
19 "
20
21S = "${WORKDIR}/git"
22
23do_install() {
24 install -d ${D}${base_prefix}/kcfg
25
26 # copy the configuration fragments over to the native deploy
27 cp -r ${S}/* ${D}${base_prefix}/kcfg
28 # scripts bring in a bash dependency we don't want
29 rm -rf ${D}${base_prefix}/kcfg/scripts
30}
31
32FILES_${PN} += "kcfg/"
33SYSROOT_DIRS += "${base_prefix}/kcfg"
34BBCLASSEXTEND = "native nativesdk"
35