diff options
-rw-r--r-- | recipes-containers/skopeo/files/0001-makefile-add-GOBUILDFLAGS-to-go-build-call.patch | 19 | ||||
-rw-r--r-- | recipes-containers/skopeo/skopeo_git.bb | 13 |
2 files changed, 18 insertions, 14 deletions
diff --git a/recipes-containers/skopeo/files/0001-makefile-add-GOBUILDFLAGS-to-go-build-call.patch b/recipes-containers/skopeo/files/0001-makefile-add-GOBUILDFLAGS-to-go-build-call.patch index 8051dfba..c362b6a2 100644 --- a/recipes-containers/skopeo/files/0001-makefile-add-GOBUILDFLAGS-to-go-build-call.patch +++ b/recipes-containers/skopeo/files/0001-makefile-add-GOBUILDFLAGS-to-go-build-call.patch | |||
@@ -13,19 +13,16 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
13 | src/import/Makefile | 2 +- | 13 | src/import/Makefile | 2 +- |
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 14 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/src/import/Makefile b/src/import/Makefile | 16 | Index: git/src/import/Makefile |
17 | index 58ed8d3a..990edd1d 100644 | 17 | =================================================================== |
18 | --- a/src/import/Makefile | 18 | --- git.orig/src/import/Makefile |
19 | +++ b/src/import/Makefile | 19 | +++ git/src/import/Makefile |
20 | @@ -136,7 +136,7 @@ binary: cmd/skopeo | 20 | @@ -126,7 +126,7 @@ |
21 | # Build w/o using containers | 21 | # Build w/o using containers |
22 | .PHONY: bin/skopeo | 22 | .PHONY: bin/skopeo |
23 | bin/skopeo: | 23 | bin/skopeo: |
24 | - $(GO) build $(MOD_VENDOR) ${GO_DYN_FLAGS} ${SKOPEO_LDFLAGS} -gcflags "$(GOGCFLAGS)" -tags "$(BUILDTAGS)" -o $@ ./cmd/skopeo | 24 | - $(GO) build ${GO_DYN_FLAGS} ${SKOPEO_LDFLAGS} -gcflags "$(GOGCFLAGS)" -tags "$(BUILDTAGS)" -o $@ ./cmd/skopeo |
25 | + $(GO) build $(GOBUILDFLAGS) $(MOD_VENDOR) ${GO_DYN_FLAGS} ${SKOPEO_LDFLAGS} -gcflags "$(GOGCFLAGS)" -tags "$(BUILDTAGS)" -o $@ ./cmd/skopeo | 25 | + $(GO) build $(GOBUILDFLAGS) ${GO_DYN_FLAGS} ${SKOPEO_LDFLAGS} -gcflags "$(GOGCFLAGS)" -tags "$(BUILDTAGS)" -o $@ ./cmd/skopeo |
26 | bin/skopeo.%: | 26 | bin/skopeo.%: |
27 | GOOS=$(word 2,$(subst ., ,$@)) GOARCH=$(word 3,$(subst ., ,$@)) $(GO) build $(MOD_VENDOR) ${SKOPEO_LDFLAGS} -tags "containers_image_openpgp $(BUILDTAGS)" -o $@ ./cmd/skopeo | 27 | GOOS=$(word 2,$(subst ., ,$@)) GOARCH=$(word 3,$(subst ., ,$@)) $(GO) build ${SKOPEO_LDFLAGS} -tags "containers_image_openpgp $(BUILDTAGS)" -o $@ ./cmd/skopeo |
28 | local-cross: bin/skopeo.darwin.amd64 bin/skopeo.linux.arm bin/skopeo.linux.arm64 bin/skopeo.windows.386.exe bin/skopeo.windows.amd64.exe | 28 | local-cross: bin/skopeo.darwin.amd64 bin/skopeo.linux.arm bin/skopeo.linux.arm64 bin/skopeo.windows.386.exe bin/skopeo.windows.amd64.exe |
29 | -- | ||
30 | 2.19.1 | ||
31 | |||
diff --git a/recipes-containers/skopeo/skopeo_git.bb b/recipes-containers/skopeo/skopeo_git.bb index 8146fe1b..b52158d2 100644 --- a/recipes-containers/skopeo/skopeo_git.bb +++ b/recipes-containers/skopeo/skopeo_git.bb | |||
@@ -20,12 +20,12 @@ RDEPENDS:${PN} = " \ | |||
20 | " | 20 | " |
21 | 21 | ||
22 | SRC_URI = " \ | 22 | SRC_URI = " \ |
23 | git://github.com/containers/skopeo;branch=release-1.11;protocol=https \ | 23 | git://github.com/containers/skopeo;branch=main;protocol=https \ |
24 | file://0001-makefile-add-GOBUILDFLAGS-to-go-build-call.patch \ | 24 | file://0001-makefile-add-GOBUILDFLAGS-to-go-build-call.patch \ |
25 | " | 25 | " |
26 | 26 | ||
27 | SRCREV = "d79588e6c1d2ff2053206a650adc1d30af591908" | 27 | SRCREV = "cf5027809ac32847df8570bccb4e425a10ba1591" |
28 | PV = "v1.11.2+git${SRCPV}" | 28 | PV = "v1.12.0+git${SRCPV}" |
29 | GO_IMPORT = "import" | 29 | GO_IMPORT = "import" |
30 | 30 | ||
31 | S = "${WORKDIR}/git" | 31 | S = "${WORKDIR}/git" |
@@ -56,9 +56,16 @@ do_compile() { | |||
56 | # We also need to link in the ipallocator directory as that is not under | 56 | # We also need to link in the ipallocator directory as that is not under |
57 | # a src directory. | 57 | # a src directory. |
58 | ln -sfn . "${S}/src/import/vendor/src" | 58 | ln -sfn . "${S}/src/import/vendor/src" |
59 | |||
60 | # not used in v1.12+, but kept for temporary compatibiity | ||
59 | mkdir -p "${S}/src/import/vendor/src/github.com/projectatomic/skopeo" | 61 | mkdir -p "${S}/src/import/vendor/src/github.com/projectatomic/skopeo" |
60 | ln -sfn "${S}/src/import/skopeo" "${S}/src/import/vendor/src/github.com/projectatomic/skopeo" | 62 | ln -sfn "${S}/src/import/skopeo" "${S}/src/import/vendor/src/github.com/projectatomic/skopeo" |
61 | ln -sfn "${S}/src/import/version" "${S}/src/import/vendor/src/github.com/projectatomic/skopeo/version" | 63 | ln -sfn "${S}/src/import/version" "${S}/src/import/vendor/src/github.com/projectatomic/skopeo/version" |
64 | |||
65 | mkdir -p "${S}/src/import/vendor/src/github.com/containers/skopeo" | ||
66 | mkdir -p "${S}/src/import/vendor/src/github.com/containers/skopeo/cmd/skopeo" | ||
67 | ln -sfn "${S}/src/import/version" "${S}/src/import/vendor/src/github.com/containers/skopeo/version" | ||
68 | ln -sfn "${S}/src/import/cmd/skopeo/inspect" "${S}/src/import/vendor/src/github.com/containers/skopeo/cmd/skopeo/inspect" | ||
62 | export GOPATH="${S}/src/import/vendor" | 69 | export GOPATH="${S}/src/import/vendor" |
63 | 70 | ||
64 | # Pass the needed cflags/ldflags so that cgo | 71 | # Pass the needed cflags/ldflags so that cgo |