diff options
-rw-r--r-- | recipes-containers/k3s/k3s/0001-Finding-host-local-in-usr-libexec.patch | 25 | ||||
-rw-r--r-- | recipes-containers/k3s/k3s_git.bb | 6 |
2 files changed, 14 insertions, 17 deletions
diff --git a/recipes-containers/k3s/k3s/0001-Finding-host-local-in-usr-libexec.patch b/recipes-containers/k3s/k3s/0001-Finding-host-local-in-usr-libexec.patch index 8205d735..524ac2cb 100644 --- a/recipes-containers/k3s/k3s/0001-Finding-host-local-in-usr-libexec.patch +++ b/recipes-containers/k3s/k3s/0001-Finding-host-local-in-usr-libexec.patch | |||
@@ -9,19 +9,16 @@ Signed-off-by: <erikja@axis.com> | |||
9 | pkg/agent/config/config.go | 2 +- | 9 | pkg/agent/config/config.go | 2 +- |
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | 10 | 1 file changed, 1 insertion(+), 1 deletion(-) |
11 | 11 | ||
12 | diff --git a/pkg/agent/config/config.go b/pkg/agent/config/config.go | 12 | Index: import/pkg/agent/config/config.go |
13 | index b4296f360a..6af9dab895 100644 | 13 | =================================================================== |
14 | --- a/pkg/agent/config/config.go | 14 | --- import.orig/pkg/agent/config/config.go |
15 | +++ b/pkg/agent/config/config.go | 15 | +++ import/pkg/agent/config/config.go |
16 | @@ -308,7 +308,7 @@ func get(envInfo *cmds.Agent) (*config.Node, error) { | 16 | @@ -445,7 +445,7 @@ |
17 | return nil, err | ||
18 | } | 17 | } |
19 | 18 | ||
20 | - hostLocal, err := exec.LookPath("host-local") | 19 | if !nodeConfig.NoFlannel { |
21 | + hostLocal, err := exec.LookPath("/usr/libexec/cni/host-local") | 20 | - hostLocal, err := exec.LookPath("host-local") |
22 | if err != nil { | 21 | + hostLocal, err := exec.LookPath("/usr/libexec/cni/host-local") |
23 | return nil, errors.Wrapf(err, "failed to find host-local") | 22 | if err != nil { |
24 | } | 23 | return nil, errors.Wrapf(err, "failed to find host-local") |
25 | -- | 24 | } |
26 | 2.11.0 | ||
27 | |||
diff --git a/recipes-containers/k3s/k3s_git.bb b/recipes-containers/k3s/k3s_git.bb index ea5ed75d..bc992181 100644 --- a/recipes-containers/k3s/k3s_git.bb +++ b/recipes-containers/k3s/k3s_git.bb | |||
@@ -4,7 +4,7 @@ HOMEPAGE = "https://k3s.io/" | |||
4 | LICENSE = "Apache-2.0" | 4 | LICENSE = "Apache-2.0" |
5 | LIC_FILES_CHKSUM = "file://${S}/src/import/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" | 5 | LIC_FILES_CHKSUM = "file://${S}/src/import/LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" |
6 | 6 | ||
7 | SRC_URI = "git://github.com/rancher/k3s.git;branch=release-1.18;name=k3s \ | 7 | SRC_URI = "git://github.com/rancher/k3s.git;branch=release-1.19;name=k3s \ |
8 | file://k3s.service \ | 8 | file://k3s.service \ |
9 | file://k3s-agent.service \ | 9 | file://k3s-agent.service \ |
10 | file://k3s-agent \ | 10 | file://k3s-agent \ |
@@ -13,9 +13,9 @@ SRC_URI = "git://github.com/rancher/k3s.git;branch=release-1.18;name=k3s \ | |||
13 | file://0001-Finding-host-local-in-usr-libexec.patch;patchdir=src/import \ | 13 | file://0001-Finding-host-local-in-usr-libexec.patch;patchdir=src/import \ |
14 | " | 14 | " |
15 | SRC_URI[k3s.md5sum] = "363d3a08dc0b72ba6e6577964f6e94a5" | 15 | SRC_URI[k3s.md5sum] = "363d3a08dc0b72ba6e6577964f6e94a5" |
16 | SRCREV_k3s = "630bebf94b9dce6b8cd3d402644ed023b3af8f90" | 16 | SRCREV_k3s = "970fbc66d384ce15bda6684c8610e65b406154ca" |
17 | 17 | ||
18 | PV = "v1.18.9+git${SRCPV}" | 18 | PV = "v1.19.3+git${SRCPV}" |
19 | 19 | ||
20 | CNI_NETWORKING_FILES ?= "${WORKDIR}/cni-containerd-net.conf" | 20 | CNI_NETWORKING_FILES ?= "${WORKDIR}/cni-containerd-net.conf" |
21 | 21 | ||