summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker/docker_git.bb14
-rw-r--r--recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch57
2 files changed, 18 insertions, 53 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index c1b38dce..acb17709 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -18,11 +18,13 @@ DESCRIPTION = "Linux container runtime \
18 subtle and/or glaring issues. \ 18 subtle and/or glaring issues. \
19 " 19 "
20 20
21SRCREV_docker = "49bf474f9ed7ce7143a59d1964ff7b7fd9b52178" 21SRCREV_docker = "e639a70fbe999d96354a5bcf560231b7b8aa935c"
22SRCREV_libnetwork="0f534354b813003a754606689722fe253101bc4e" 22SRCREV_libnetwork = "26addf43a5d925ff79d262dbbdb5344bc2b6e198"
23SRCREV_cli = "a765218f1988e85b68aa3977f34893ec7b059a60"
23SRC_URI = "\ 24SRC_URI = "\
24 git://github.com/docker/docker.git;nobranch=1;name=docker \ 25 git://github.com/moby/moby.git;nobranch=1;name=docker \
25 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=libnetwork \ 26 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=libnetwork \
27 git://github.com/docker/cli;branch=master;name=cli;destsuffix=cli \
26 file://docker.init \ 28 file://docker.init \
27 file://hi.Dockerfile \ 29 file://hi.Dockerfile \
28 file://context-use-golang.org-x-net-pkg-until-we-move-to-go.patch \ 30 file://context-use-golang.org-x-net-pkg-until-we-move-to-go.patch \
@@ -30,7 +32,7 @@ SRC_URI = "\
30 32
31# Apache-2.0 for docker 33# Apache-2.0 for docker
32LICENSE = "Apache-2.0" 34LICENSE = "Apache-2.0"
33LIC_FILES_CHKSUM = "file://LICENSE;md5=aadc30f9c14d876ded7bedc0afd2d3d7" 35LIC_FILES_CHKSUM = "file://LICENSE;md5=9740d093a080530b5c5c6573df9af45a"
34 36
35S = "${WORKDIR}/git" 37S = "${WORKDIR}/git"
36 38
@@ -86,6 +88,7 @@ do_compile() {
86 88
87 mkdir -p .gopath/src/github.com/docker 89 mkdir -p .gopath/src/github.com/docker
88 ln -sf ../../../../../libnetwork .gopath/src/github.com/docker/libnetwork 90 ln -sf ../../../../../libnetwork .gopath/src/github.com/docker/libnetwork
91 ln -sf ../../../../../cli .gopath/src/github.com/docker/cli
89 92
90 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 93 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
91 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" 94 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
@@ -107,6 +110,9 @@ do_compile() {
107 110
108 # build the proxy 111 # build the proxy
109 go build -o ${S}/docker-proxy github.com/docker/libnetwork/cmd/proxy 112 go build -o ${S}/docker-proxy github.com/docker/libnetwork/cmd/proxy
113
114 # build the cli
115 go build -o ${S}/bundles/latest/dynbinary-client/docker github.com/docker/cli/cmd/docker
110} 116}
111 117
112SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" 118SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
diff --git a/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch b/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch
index 240b7441..c43a7e74 100644
--- a/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch
+++ b/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch
@@ -11,20 +11,16 @@ walwrap.go:4:2: cannot find package "context" in any of:
11 11
12Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> 12Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
13--- 13---
14 client/README.md | 2 +- 14 client/README.md | 2 +-
15 client/client.go | 2 +- 15 client/client.go | 2 +-
16 daemon/info_unix.go | 2 +- 16 daemon/info_unix.go | 2 +-
17 integration-cli/docker_api_attach_test.go | 2 +- 17 integration-cli/docker_api_attach_test.go | 2 +-
18 integration-cli/docker_cli_save_load_unix_test.go | 2 +- 18 integration-cli/docker_cli_save_load_unix_test.go | 2 +-
19 vendor/github.com/docker/swarmkit/manager/logbroker/subscription.go | 2 +- 19 5 files changed, 5 insertions(+), 5 deletions(-)
20 vendor/github.com/docker/swarmkit/manager/state/raft/storage/walwrap.go | 2 +-
21 7 files changed, 7 insertions(+), 7 deletions(-)
22 20
23diff --git a/client/README.md b/client/README.md
24index 059dfb3..9de54aa 100644
25--- a/client/README.md 21--- a/client/README.md
26+++ b/client/README.md 22+++ b/client/README.md
27@@ -8,7 +8,7 @@ For example, to list running containers (the equivalent of `docker ps`): 23@@ -8,7 +8,7 @@ For example, to list running containers
28 package main 24 package main
29 25
30 import ( 26 import (
@@ -33,11 +29,9 @@ index 059dfb3..9de54aa 100644
33 "fmt" 29 "fmt"
34 30
35 "github.com/docker/docker/api/types" 31 "github.com/docker/docker/api/types"
36diff --git a/client/client.go b/client/client.go
37index a9bdab6..95933af 100644
38--- a/client/client.go 32--- a/client/client.go
39+++ b/client/client.go 33+++ b/client/client.go
40@@ -19,7 +19,7 @@ For example, to list running containers (the equivalent of "docker ps"): 34@@ -19,7 +19,7 @@ For example, to list running containers
41 package main 35 package main
42 36
43 import ( 37 import (
@@ -46,8 +40,6 @@ index a9bdab6..95933af 100644
46 "fmt" 40 "fmt"
47 41
48 "github.com/docker/docker/api/types" 42 "github.com/docker/docker/api/types"
49diff --git a/daemon/info_unix.go b/daemon/info_unix.go
50index 9c41c0e..57f8a7b 100644
51--- a/daemon/info_unix.go 43--- a/daemon/info_unix.go
52+++ b/daemon/info_unix.go 44+++ b/daemon/info_unix.go
53@@ -3,7 +3,7 @@ 45@@ -3,7 +3,7 @@
@@ -59,8 +51,6 @@ index 9c41c0e..57f8a7b 100644
59 "os/exec" 51 "os/exec"
60 "strings" 52 "strings"
61 53
62diff --git a/integration-cli/docker_api_attach_test.go b/integration-cli/docker_api_attach_test.go
63index d43bf3a..e5802a7 100644
64--- a/integration-cli/docker_api_attach_test.go 54--- a/integration-cli/docker_api_attach_test.go
65+++ b/integration-cli/docker_api_attach_test.go 55+++ b/integration-cli/docker_api_attach_test.go
66@@ -3,7 +3,7 @@ package main 56@@ -3,7 +3,7 @@ package main
@@ -72,8 +62,6 @@ index d43bf3a..e5802a7 100644
72 "io" 62 "io"
73 "net" 63 "net"
74 "net/http" 64 "net/http"
75diff --git a/integration-cli/docker_cli_save_load_unix_test.go b/integration-cli/docker_cli_save_load_unix_test.go
76index 22445e5..d0afc8c 100644
77--- a/integration-cli/docker_cli_save_load_unix_test.go 65--- a/integration-cli/docker_cli_save_load_unix_test.go
78+++ b/integration-cli/docker_cli_save_load_unix_test.go 66+++ b/integration-cli/docker_cli_save_load_unix_test.go
79@@ -3,7 +3,7 @@ 67@@ -3,7 +3,7 @@
@@ -85,32 +73,3 @@ index 22445e5..d0afc8c 100644
85 "fmt" 73 "fmt"
86 "io/ioutil" 74 "io/ioutil"
87 "os" 75 "os"
88diff --git a/vendor/github.com/docker/swarmkit/manager/logbroker/subscription.go b/vendor/github.com/docker/swarmkit/manager/logbroker/subscription.go
89index 6b3295a..cbfcf7e 100644
90--- a/vendor/github.com/docker/swarmkit/manager/logbroker/subscription.go
91+++ b/vendor/github.com/docker/swarmkit/manager/logbroker/subscription.go
92@@ -1,7 +1,7 @@
93 package logbroker
94
95 import (
96- "context"
97+ "golang.org/x/net/context"
98 "fmt"
99 "strings"
100 "sync"
101diff --git a/vendor/github.com/docker/swarmkit/manager/state/raft/storage/walwrap.go b/vendor/github.com/docker/swarmkit/manager/state/raft/storage/walwrap.go
102index 5a6c71a..efe5921 100644
103--- a/vendor/github.com/docker/swarmkit/manager/state/raft/storage/walwrap.go
104+++ b/vendor/github.com/docker/swarmkit/manager/state/raft/storage/walwrap.go
105@@ -1,7 +1,7 @@
106 package storage
107
108 import (
109- "context"
110+ "golang.org/x/net/context"
111 "io"
112 "io/ioutil"
113 "os"
114--
1152.7.4
116