diff options
-rw-r--r-- | recipes-extended/xen/files/0001-arm32-Avoid-using-solaris-syntax-for-.section-direct.patch | 70 | ||||
-rw-r--r-- | recipes-extended/xen/xen-tools_4.17.bb | 4 | ||||
-rw-r--r-- | recipes-extended/xen/xen_4.17.bb | 5 |
3 files changed, 4 insertions, 75 deletions
diff --git a/recipes-extended/xen/files/0001-arm32-Avoid-using-solaris-syntax-for-.section-direct.patch b/recipes-extended/xen/files/0001-arm32-Avoid-using-solaris-syntax-for-.section-direct.patch deleted file mode 100644 index a4038dda..00000000 --- a/recipes-extended/xen/files/0001-arm32-Avoid-using-solaris-syntax-for-.section-direct.patch +++ /dev/null | |||
@@ -1,70 +0,0 @@ | |||
1 | From dfc490a3740bb7d6889939934afadcb58891fbce Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 1 Aug 2023 10:49:30 -0700 | ||
4 | Subject: [PATCH] arm: Avoid using solaris syntax for .section directive | ||
5 | |||
6 | Assembler from binutils 2.41 will rejects ([1], [2]) the following | ||
7 | syntax | ||
8 | |||
9 | .section "name", #alloc | ||
10 | |||
11 | for any other any target other than ELF SPARC. This means we can't use | ||
12 | it in the Arm code. | ||
13 | |||
14 | So switch to the GNU syntax | ||
15 | |||
16 | .section name [, "flags"[, @type]] | ||
17 | |||
18 | [1] https://sourceware.org/bugzilla/show_bug.cgi?id=11601 | ||
19 | [2] https://sourceware.org/binutils/docs-2.41/as.html#Section | ||
20 | |||
21 | Upstream-Status: Backport [https://github.com/xen-project/xen/commit/dfc490a3740bb7d6889939934afadcb58891fbce] | ||
22 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
23 | Reviewed-by: Michal Orzel <michal.orzel@amd.com> | ||
24 | [jgrall: Reword commit message] | ||
25 | Acked-by: Julien Grall <jgrall@amazon.com> | ||
26 | --- | ||
27 | xen/arch/arm/arm32/proc-v7.S | 6 +++--- | ||
28 | xen/arch/arm/dtb.S | 2 +- | ||
29 | 2 files changed, 4 insertions(+), 4 deletions(-) | ||
30 | |||
31 | diff --git a/xen/arch/arm/arm32/proc-v7.S b/xen/arch/arm/arm32/proc-v7.S | ||
32 | index c90a31d80fc5..6d3d19b87354 100644 | ||
33 | --- a/xen/arch/arm/arm32/proc-v7.S | ||
34 | +++ b/xen/arch/arm/arm32/proc-v7.S | ||
35 | @@ -29,7 +29,7 @@ brahma15mp_init: | ||
36 | mcr CP32(r0, ACTLR) | ||
37 | mov pc, lr | ||
38 | |||
39 | - .section ".proc.info", #alloc | ||
40 | + .section .proc.info, "a" | ||
41 | .type __v7_ca15mp_proc_info, #object | ||
42 | __v7_ca15mp_proc_info: | ||
43 | .long 0x410FC0F0 /* Cortex-A15 */ | ||
44 | @@ -38,7 +38,7 @@ __v7_ca15mp_proc_info: | ||
45 | .long caxx_processor | ||
46 | .size __v7_ca15mp_proc_info, . - __v7_ca15mp_proc_info | ||
47 | |||
48 | - .section ".proc.info", #alloc | ||
49 | + .section .proc.info, "a" | ||
50 | .type __v7_ca7mp_proc_info, #object | ||
51 | __v7_ca7mp_proc_info: | ||
52 | .long 0x410FC070 /* Cortex-A7 */ | ||
53 | @@ -47,7 +47,7 @@ __v7_ca7mp_proc_info: | ||
54 | .long caxx_processor | ||
55 | .size __v7_ca7mp_proc_info, . - __v7_ca7mp_proc_info | ||
56 | |||
57 | - .section ".proc.info", #alloc | ||
58 | + .section .proc.info, "a" | ||
59 | .type __v7_brahma15mp_proc_info, #object | ||
60 | __v7_brahma15mp_proc_info: | ||
61 | .long 0x420F00F0 /* Broadcom Brahma-B15 */ | ||
62 | diff --git a/xen/arch/arm/dtb.S b/xen/arch/arm/dtb.S | ||
63 | index c39f3a095c58..386f83ba649e 100644 | ||
64 | --- a/xen/arch/arm/dtb.S | ||
65 | +++ b/xen/arch/arm/dtb.S | ||
66 | @@ -1,3 +1,3 @@ | ||
67 | - .section .dtb,#alloc | ||
68 | + .section .dtb, "a" | ||
69 | GLOBAL(_sdtb) | ||
70 | .incbin CONFIG_DTB_FILE | ||
diff --git a/recipes-extended/xen/xen-tools_4.17.bb b/recipes-extended/xen/xen-tools_4.17.bb index 83093425..c6a3052c 100644 --- a/recipes-extended/xen/xen-tools_4.17.bb +++ b/recipes-extended/xen/xen-tools_4.17.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | # stable-4.17 status on 5/26/2023 | 1 | # xen 4.17.2 release sha |
2 | SRCREV ?= "47eb94123035a2987dd1e328e9adec6db36e7fb3" | 2 | SRCREV ?= "322a20add00a4687cd46d9183616fa6fecbef81f" |
3 | 3 | ||
4 | XEN_REL ?= "4.17" | 4 | XEN_REL ?= "4.17" |
5 | XEN_BRANCH ?= "stable-${XEN_REL}" | 5 | XEN_BRANCH ?= "stable-${XEN_REL}" |
diff --git a/recipes-extended/xen/xen_4.17.bb b/recipes-extended/xen/xen_4.17.bb index 54da7baf..8fae2c37 100644 --- a/recipes-extended/xen/xen_4.17.bb +++ b/recipes-extended/xen/xen_4.17.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | # stable-4.17 status on 5/26/2023 | 1 | # xen 4.17.2 release sha |
2 | SRCREV ?= "47eb94123035a2987dd1e328e9adec6db36e7fb3" | 2 | SRCREV ?= "322a20add00a4687cd46d9183616fa6fecbef81f" |
3 | 3 | ||
4 | XEN_REL ?= "4.17" | 4 | XEN_REL ?= "4.17" |
5 | XEN_BRANCH ?= "stable-${XEN_REL}" | 5 | XEN_BRANCH ?= "stable-${XEN_REL}" |
@@ -7,7 +7,6 @@ XEN_BRANCH ?= "stable-${XEN_REL}" | |||
7 | SRC_URI = " \ | 7 | SRC_URI = " \ |
8 | git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ | 8 | git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ |
9 | file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ | 9 | file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ |
10 | file://0001-arm32-Avoid-using-solaris-syntax-for-.section-direct.patch \ | ||
11 | " | 10 | " |
12 | 11 | ||
13 | LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9" | 12 | LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9" |