summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index 0d9c6e65..45a40460 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=b355a61a394a504dacde901c958f66
5 5
6SRC_URI = "git://github.com/opencontainers/runtime-tools.git" 6SRC_URI = "git://github.com/opencontainers/runtime-tools.git"
7 7
8SRCREV = "15ec1df3f6607f4223ab3915547c184cf60a30dd" 8SRCREV = "6e7da8148f4de2c9e9c9d3b345576898d4f412cb"
9PV = "0.0.1+git${SRCPV}" 9PV = "0.1.0+git${SRCPV}"
10GO_IMPORT = "import" 10GO_IMPORT = "import"
11 11
12INSANE_SKIP_${PN} += "ldflags" 12INSANE_SKIP_${PN} += "ldflags"
@@ -34,6 +34,8 @@ do_compile() {
34 ln -sf ../../../../generate ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/generate 34 ln -sf ../../../../generate ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/generate
35 ln -sf ../../../../validate ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/validate 35 ln -sf ../../../../validate ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/validate
36 ln -sf ../../../../cmd ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/cmd 36 ln -sf ../../../../cmd ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/cmd
37 ln -sf ../../../../error ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/error
38 ln -sf ../../../../specerror ${S}/src/import/vendor/github.com/opencontainers/runtime-tools/specerror
37 cd ${S}/src/import 39 cd ${S}/src/import
38 40
39 oe_runmake 41 oe_runmake
@@ -43,3 +45,6 @@ do_install() {
43 install -d ${D}/${sbindir} 45 install -d ${D}/${sbindir}
44 install ${S}/src/import/oci-runtime-tool ${D}/${sbindir}/oci-runtime-tool 46 install ${S}/src/import/oci-runtime-tool ${D}/${sbindir}/oci-runtime-tool
45} 47}
48
49deltask compile_ptest_base
50