summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/lxc/files/0001-use-sd_bus_call_method_async-to-replace-the-asyncv-o.patch49
-rw-r--r--recipes-containers/lxc/lxc_git.bb7
2 files changed, 3 insertions, 53 deletions
diff --git a/recipes-containers/lxc/files/0001-use-sd_bus_call_method_async-to-replace-the-asyncv-o.patch b/recipes-containers/lxc/files/0001-use-sd_bus_call_method_async-to-replace-the-asyncv-o.patch
deleted file mode 100644
index ef87a0ce..00000000
--- a/recipes-containers/lxc/files/0001-use-sd_bus_call_method_async-to-replace-the-asyncv-o.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1From b0abedf60b40adf0f2fb3cf9dfee4bc601f7b39f Mon Sep 17 00:00:00 2001
2From: Chen Qi <Qi.Chen@windriver.com>
3Date: Thu, 25 Aug 2022 05:45:53 -0700
4Subject: [PATCH] use sd_bus_call_method_async to replace the asyncv one
5
6The sd_bus_call_method_asyncv's 10th parameter is of type
7va_list and supplying NULL when invoking it causes compilation
8error. Just replace it with the async one.
9
10Upstream-Status: Submitted [https://github.com/lxc/lxc/pull/4187]
11
12Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
13---
14 meson.build | 4 ++--
15 src/lxc/cgroups/cgfsng.c | 2 +-
16 2 files changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/meson.build b/meson.build
19index 21955a050..f8bdcf4e8 100644
20--- a/meson.build
21+++ b/meson.build
22@@ -295,9 +295,9 @@ if not want_sd_bus.disabled()
23 has_sd_bus = false
24 endif
25
26- if not cc.has_function('sd_bus_call_method_asyncv', prefix: '#include <systemd/sd-bus.h>', dependencies: libsystemd)
27+ if not cc.has_function('sd_bus_call_method_async', prefix: '#include <systemd/sd-bus.h>', dependencies: libsystemd)
28 if not sd_bus_optional
29- error('libsystemd misses required sd_bus_call_method_asyncv function')
30+ error('libsystemd misses required sd_bus_call_method_async function')
31 endif
32
33 has_sd_bus = false
34diff --git a/src/lxc/cgroups/cgfsng.c b/src/lxc/cgroups/cgfsng.c
35index 8a3615893..d90e5385e 100644
36--- a/src/lxc/cgroups/cgfsng.c
37+++ b/src/lxc/cgroups/cgfsng.c
38@@ -1232,7 +1232,7 @@ static int unpriv_systemd_create_scope(struct cgroup_ops *ops, struct lxc_conf *
39 if (r < 0)
40 return log_error(SYSTEMD_SCOPE_FAILED, "Failed to connect to user bus: %s", strerror(-r));
41
42- r = sd_bus_call_method_asyncv(bus, NULL, DESTINATION, PATH, INTERFACE, "Subscribe", NULL, NULL, NULL, NULL);
43+ r = sd_bus_call_method_async(bus, NULL, DESTINATION, PATH, INTERFACE, "Subscribe", NULL, NULL, NULL);
44 if (r < 0)
45 return log_error(SYSTEMD_SCOPE_FAILED, "Failed to subscribe to signals: %s", strerror(-r));
46
47--
482.37.1
49
diff --git a/recipes-containers/lxc/lxc_git.bb b/recipes-containers/lxc/lxc_git.bb
index 9cabe054..d695467b 100644
--- a/recipes-containers/lxc/lxc_git.bb
+++ b/recipes-containers/lxc/lxc_git.bb
@@ -36,7 +36,7 @@ RDEPENDS:${PN}-ptest += "file make gmp nettle gnutls bash libgcc"
36 36
37RDEPENDS:${PN}-networking += "iptables" 37RDEPENDS:${PN}-networking += "iptables"
38 38
39SRC_URI = "git://github.com/lxc/lxc.git;branch=master;protocol=https \ 39SRC_URI = "git://github.com/lxc/lxc.git;branch=stable-5.0;protocol=https \
40 file://lxc-1.0.0-disable-udhcp-from-busybox-template.patch \ 40 file://lxc-1.0.0-disable-udhcp-from-busybox-template.patch \
41 file://run-ptest \ 41 file://run-ptest \
42 file://templates-actually-create-DOWNLOAD_TEMP-directory.patch \ 42 file://templates-actually-create-DOWNLOAD_TEMP-directory.patch \
@@ -44,13 +44,12 @@ SRC_URI = "git://github.com/lxc/lxc.git;branch=master;protocol=https \
44 file://templates-use-curl-instead-of-wget.patch \ 44 file://templates-use-curl-instead-of-wget.patch \
45 file://0001-download-don-t-try-compatbility-index.patch \ 45 file://0001-download-don-t-try-compatbility-index.patch \
46 file://tests-our-init-is-not-busybox.patch \ 46 file://tests-our-init-is-not-busybox.patch \
47 file://0001-use-sd_bus_call_method_async-to-replace-the-asyncv-o.patch \
48 file://dnsmasq.conf \ 47 file://dnsmasq.conf \
49 file://lxc-net \ 48 file://lxc-net \
50 " 49 "
51 50
52SRCREV = "133aa416ca2a5996090ec0e697e253646364d274" 51SRCREV = "d571736812b89e195bee69b900fe09115a1e7e00"
53PV = "5.0.1+git${SRCPV}" 52PV = "5.0.2+git${SRCPV}"
54 53
55S = "${WORKDIR}/git" 54S = "${WORKDIR}/git"
56 55