summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/nagios/nagios-plugins_git.bb (renamed from recipes-extended/nagios/nagios-plugins_2.2.1.bb)25
1 files changed, 16 insertions, 9 deletions
diff --git a/recipes-extended/nagios/nagios-plugins_2.2.1.bb b/recipes-extended/nagios/nagios-plugins_git.bb
index 471d4b42..82263def 100644
--- a/recipes-extended/nagios/nagios-plugins_2.2.1.bb
+++ b/recipes-extended/nagios/nagios-plugins_git.bb
@@ -8,15 +8,13 @@ LICENSE = "GPL-3.0-only"
8 8
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10 10
11SRC_URI = "https://www.nagios-plugins.org/download/${BPN}-${PV}.tar.gz \ 11SRCREV = "7c74420158c3e228b3d66d4c781a6abc7a93075a"
12" 12SRC_URI = "git://github.com/nagios-plugins/nagios-plugins.git;protocol=https;branch=master"
13
14SRC_URI[md5sum] = "fb521d5c05897f165b0b1862c1e5cb27"
15SRC_URI[sha256sum] = "647c0ba4583d891c965fc29b77c4ccfeccc21f409fdf259cb8af52cb39c21e18"
16 13
17S = "${WORKDIR}/${BPN}-${PV}" 14PV = "2.4.12+git"
15S = "${WORKDIR}/git"
18 16
19inherit autotools gettext 17inherit autotools gettext pkgconfig autotools-brokensep
20 18
21SKIP_RECIPE[nagios-plugins] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'webserver', '', 'Depends on nagios-core which depends on apache2 from meta-webserver which is not included', d)}" 19SKIP_RECIPE[nagios-plugins] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'webserver', '', 'Depends on nagios-core which depends on apache2 from meta-webserver which is not included', d)}"
22 20
@@ -25,6 +23,12 @@ EXTRA_OECONF += "--with-sysroot=${STAGING_DIR_HOST} \
25 --with-nagios-group=${NAGIOS_GROUP} \ 23 --with-nagios-group=${NAGIOS_GROUP} \
26 --without-apt-get-command \ 24 --without-apt-get-command \
27 --with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin \ 25 --with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin \
26 --with-sudo-command=${bindir}/sudo \
27 --with-ssh-command=${bindir}/ssh \
28 --with-ps-command=${bindir}/ps \
29 --with-ps-format='%*s %s %d %d %d %*s %*s %*s %*s %*s %*s %*s %*s %n%s' \
30 --with-ps-varlist='procstat,&procuid,&procpid,&procppid,&pos,procprog' \
31 --with-ps-cols=6 \
28 ac_cv_path_PERL=${bindir}/perl \ 32 ac_cv_path_PERL=${bindir}/perl \
29" 33"
30 34
@@ -55,8 +59,11 @@ PACKAGECONFIG[snmp] = "\
55 59
56PACKAGECONFIG ??= "ssl gnutls" 60PACKAGECONFIG ??= "ssl gnutls"
57 61
58do_configure() { 62do_configure:prepend() {
59 oe_runconf || die "make failed" 63 # rename these macros to have .m4 suffix so that autoreconf could recognize them
64 for macro in `ls ${S}/autoconf-macros/ax_nagios_get_*`; do
65 mv $macro $macro.m4
66 done
60} 67}
61 68
62do_install:append() { 69do_install:append() {