summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/xen/files/flask-avoid-installing-policy-file-as-boot.patch26
-rw-r--r--recipes-extended/xen/xen_4.3.1.bb24
-rw-r--r--recipes-extended/xen/xen_4.5.0.bb36
3 files changed, 36 insertions, 50 deletions
diff --git a/recipes-extended/xen/files/flask-avoid-installing-policy-file-as-boot.patch b/recipes-extended/xen/files/flask-avoid-installing-policy-file-as-boot.patch
deleted file mode 100644
index d980807d..00000000
--- a/recipes-extended/xen/files/flask-avoid-installing-policy-file-as-boot.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 8bff3edead4318bfebc487f929f833d11922c238 Mon Sep 17 00:00:00 2001
2From: "Vadim A. Misbakh-Soloviov" <mva@mva.name>
3Date: Tue, 30 Jul 2013 16:34:38 +0400
4Subject: [PATCH] flask: avoid installing policy file as '/boot'
5
6Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
7Acked-by: Daniel De Graaf <dgdegra@tycho.nsa.gov>
8---
9 tools/flask/policy/Makefile | 1 +
10 1 file changed, 1 insertion(+)
11
12diff --git a/tools/flask/policy/Makefile b/tools/flask/policy/Makefile
13index e666f3e..df1e8f3 100644
14--- a/tools/flask/policy/Makefile
15+++ b/tools/flask/policy/Makefile
16@@ -103,6 +103,7 @@ POLICY_SECTIONS += $(USERS) $(CONSTRAINTS) $(ISID_DEFS)
17 all: $(POLICY_FILENAME)
18
19 install: $(POLICY_FILENAME)
20+ $(INSTALL_DIR) $(POLICY_LOADPATH)
21 $(INSTALL_DATA) $^ $(POLICY_LOADPATH)
22
23 $(POLICY_FILENAME): policy.conf
24--
251.7.10.4
26
diff --git a/recipes-extended/xen/xen_4.3.1.bb b/recipes-extended/xen/xen_4.3.1.bb
deleted file mode 100644
index 2c9806b6..00000000
--- a/recipes-extended/xen/xen_4.3.1.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1require xen.inc
2
3SRC_URI = " \
4 http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz \
5 file://flask-avoid-installing-policy-file-as-boot.patch \
6 "
7
8SRC_URI[md5sum] = "7616b8704e1ab89c81f011f0e3703bc8"
9SRC_URI[sha256sum] = "3b5b7cc508b1739753585b5c25635471cdcef680e8770a78bf6ef9333d26a9fd"
10
11S = "${WORKDIR}/xen-${PV}"
12
13RDEPENDS_${PN}-base += "\
14 ${PN}-libblktap \
15 ${PN}-flask \
16 "
17
18do_configure_prepend() {
19 # fixup qemu-xen-traditional pciutils check hardcoded to test /usr/include/pci
20 sed -i 's/\/usr\/include\/pci/$(STAGING_INCDIR)\/pci/g' ${S}/tools/qemu-xen-traditional/xen-hooks.mak
21
22 # fixup for qemu to cross compile
23 sed -i 's/configure --d/configure --cross-prefix=${TARGET_PREFIX} --d/g' ${S}/tools/qemu-xen-traditional/xen-setup
24}
diff --git a/recipes-extended/xen/xen_4.5.0.bb b/recipes-extended/xen/xen_4.5.0.bb
new file mode 100644
index 00000000..62d1d87a
--- /dev/null
+++ b/recipes-extended/xen/xen_4.5.0.bb
@@ -0,0 +1,36 @@
1require xen.inc
2
3SRC_URI = " \
4 http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz \
5 "
6
7SRC_URI[md5sum] = "9bac43d2419d05a647064d9253bb03fa"
8SRC_URI[sha256sum] = "5bdb40e2b28d2eeb541bd71a9777f40cbe2ae444b987521d33f099541a006f3b"
9
10S = "${WORKDIR}/xen-${PV}"
11
12# Xen suffixes the libexecdir within its configure scripts, prevent the nested xen/xen/
13libexecdir = "${libdir}"
14
15# These options override detected values from the build.
16EXTRA_OECONF_append += " \
17 --with-initddir=${INIT_D_DIR} \
18 --with-sysconfig-leaf-dir=default \
19 --with-system-qemu=/usr/bin/qemu-system-i386 \
20 --disable-qemu-traditional \
21 --disable-seabios \
22 "
23
24do_configure_prepend() {
25 # fixup AS/CC/CCP/etc variable within StdGNU.mk
26 for i in AS LD CC CPP AR RANLIB NM STRIP OBJCOPY OBJDUMP; do
27 sed -i "s/^\($i\s\s*\).*=/\1?=/" ${S}/config/StdGNU.mk
28 done
29 # fixup environment passing in some makefiles
30 sed -i 's#\(\w*\)=\(\$.\w*.\)#\1="\2"#' ${S}/tools/firmware/Makefile
31}
32
33do_install_append() {
34 # fixup default path to qemu-system-i386
35 sed -i 's#\(test -z "$QEMU_XEN" && QEMU_XEN=\).*$#\1"/usr/bin/qemu-system-i386"#' ${D}/etc/init.d/xencommons
36}