diff options
-rw-r--r-- | recipes-extended/seabios/seabios/python3.patch | 13 | ||||
-rw-r--r-- | recipes-extended/seabios/seabios_1.13.0.bb (renamed from recipes-extended/seabios/seabios_1.11.2.bb) | 13 |
2 files changed, 21 insertions, 5 deletions
diff --git a/recipes-extended/seabios/seabios/python3.patch b/recipes-extended/seabios/seabios/python3.patch new file mode 100644 index 00000000..a2786fd7 --- /dev/null +++ b/recipes-extended/seabios/seabios/python3.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | diff --git a/Makefile b/Makefile | ||
2 | index 516cb38..7f6acaa 100644 | ||
3 | --- a/Makefile | ||
4 | +++ b/Makefile | ||
5 | @@ -22,7 +22,7 @@ LD=$(CROSS_PREFIX)ld | ||
6 | OBJCOPY=$(CROSS_PREFIX)objcopy | ||
7 | OBJDUMP=$(CROSS_PREFIX)objdump | ||
8 | STRIP=$(CROSS_PREFIX)strip | ||
9 | -PYTHON=python | ||
10 | +PYTHON=python3 | ||
11 | CPP=$(CROSS_PREFIX)cpp | ||
12 | IASL:=iasl | ||
13 | LD32BIT_FLAG:=-melf_i386 | ||
diff --git a/recipes-extended/seabios/seabios_1.11.2.bb b/recipes-extended/seabios/seabios_1.13.0.bb index 81eaec96..4cf44201 100644 --- a/recipes-extended/seabios/seabios_1.11.2.bb +++ b/recipes-extended/seabios/seabios_1.13.0.bb | |||
@@ -3,22 +3,25 @@ HOMEPAGE = "http://www.coreboot.org/SeaBIOS" | |||
3 | LICENSE = "LGPLv3" | 3 | LICENSE = "LGPLv3" |
4 | SECTION = "firmware" | 4 | SECTION = "firmware" |
5 | 5 | ||
6 | inherit python3native | ||
7 | |||
6 | SRC_URI = " \ | 8 | SRC_URI = " \ |
7 | https://github.com/qemu/seabios/archive/rel-${PV}.tar.gz \ | 9 | https://www.seabios.org/downloads/seabios-${PV}.tar.gz \ |
8 | file://hostcc.patch \ | 10 | file://hostcc.patch \ |
11 | file://python3.patch \ | ||
9 | " | 12 | " |
10 | S = "${WORKDIR}/${PN}-rel-${PV}" | 13 | S = "${WORKDIR}/${PN}-${PV}" |
11 | 14 | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ | 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
13 | file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \ | 16 | file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \ |
14 | " | 17 | " |
15 | 18 | ||
16 | SRC_URI[md5sum] = "3f78065837dbd8873513a1b7d5276e78" | 19 | SRC_URI[md5sum] = "1dc1725bac1d230bfd6b3204eed4f2f7" |
17 | SRC_URI[sha256sum] = "73e73c8e406d97265782f6c942b3c1d178ed4f4afc9f381b22336c3968291693" | 20 | SRC_URI[sha256sum] = "37673dc2d6308591b15bdb94e5bcc3e99bdb40198d2247733c43f50b55dbe703" |
18 | 21 | ||
19 | FILES_${PN} = "/usr/share/firmware" | 22 | FILES_${PN} = "/usr/share/firmware" |
20 | 23 | ||
21 | DEPENDS = "util-linux-native file-native bison-native flex-native gettext-native acpica-native python-native" | 24 | DEPENDS += "util-linux-native file-native bison-native flex-native gettext-native acpica-native" |
22 | 25 | ||
23 | TUNE_CCARGS = "" | 26 | TUNE_CCARGS = "" |
24 | EXTRA_OEMAKE += "HOSTCC='${BUILD_CC}'" | 27 | EXTRA_OEMAKE += "HOSTCC='${BUILD_CC}'" |