summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/seabios/seabios/python3.patch13
-rw-r--r--recipes-extended/seabios/seabios_1.13.0.bb (renamed from recipes-extended/seabios/seabios_1.11.2.bb)13
2 files changed, 21 insertions, 5 deletions
diff --git a/recipes-extended/seabios/seabios/python3.patch b/recipes-extended/seabios/seabios/python3.patch
new file mode 100644
index 00000000..a2786fd7
--- /dev/null
+++ b/recipes-extended/seabios/seabios/python3.patch
@@ -0,0 +1,13 @@
1diff --git a/Makefile b/Makefile
2index 516cb38..7f6acaa 100644
3--- a/Makefile
4+++ b/Makefile
5@@ -22,7 +22,7 @@ LD=$(CROSS_PREFIX)ld
6 OBJCOPY=$(CROSS_PREFIX)objcopy
7 OBJDUMP=$(CROSS_PREFIX)objdump
8 STRIP=$(CROSS_PREFIX)strip
9-PYTHON=python
10+PYTHON=python3
11 CPP=$(CROSS_PREFIX)cpp
12 IASL:=iasl
13 LD32BIT_FLAG:=-melf_i386
diff --git a/recipes-extended/seabios/seabios_1.11.2.bb b/recipes-extended/seabios/seabios_1.13.0.bb
index 81eaec96..4cf44201 100644
--- a/recipes-extended/seabios/seabios_1.11.2.bb
+++ b/recipes-extended/seabios/seabios_1.13.0.bb
@@ -3,22 +3,25 @@ HOMEPAGE = "http://www.coreboot.org/SeaBIOS"
3LICENSE = "LGPLv3" 3LICENSE = "LGPLv3"
4SECTION = "firmware" 4SECTION = "firmware"
5 5
6inherit python3native
7
6SRC_URI = " \ 8SRC_URI = " \
7 https://github.com/qemu/seabios/archive/rel-${PV}.tar.gz \ 9 https://www.seabios.org/downloads/seabios-${PV}.tar.gz \
8 file://hostcc.patch \ 10 file://hostcc.patch \
11 file://python3.patch \
9 " 12 "
10S = "${WORKDIR}/${PN}-rel-${PV}" 13S = "${WORKDIR}/${PN}-${PV}"
11 14
12LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ 15LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
13 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \ 16 file://COPYING.LESSER;md5=6a6a8e020838b23406c81b19c1d46df6 \
14 " 17 "
15 18
16SRC_URI[md5sum] = "3f78065837dbd8873513a1b7d5276e78" 19SRC_URI[md5sum] = "1dc1725bac1d230bfd6b3204eed4f2f7"
17SRC_URI[sha256sum] = "73e73c8e406d97265782f6c942b3c1d178ed4f4afc9f381b22336c3968291693" 20SRC_URI[sha256sum] = "37673dc2d6308591b15bdb94e5bcc3e99bdb40198d2247733c43f50b55dbe703"
18 21
19FILES_${PN} = "/usr/share/firmware" 22FILES_${PN} = "/usr/share/firmware"
20 23
21DEPENDS = "util-linux-native file-native bison-native flex-native gettext-native acpica-native python-native" 24DEPENDS += "util-linux-native file-native bison-native flex-native gettext-native acpica-native"
22 25
23TUNE_CCARGS = "" 26TUNE_CCARGS = ""
24EXTRA_OEMAKE += "HOSTCC='${BUILD_CC}'" 27EXTRA_OEMAKE += "HOSTCC='${BUILD_CC}'"