diff options
-rw-r--r-- | recipes-containers/lxc/files/cgroups-work-around-issue-in-gcc-7.patch | 34 | ||||
-rw-r--r-- | recipes-containers/lxc/lxc_2.0.8.bb | 1 |
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes-containers/lxc/files/cgroups-work-around-issue-in-gcc-7.patch b/recipes-containers/lxc/files/cgroups-work-around-issue-in-gcc-7.patch new file mode 100644 index 00000000..90740fb3 --- /dev/null +++ b/recipes-containers/lxc/files/cgroups-work-around-issue-in-gcc-7.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 58a2d817a82100d287c60c63315d81445cdba3f9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | ||
3 | Date: Thu, 15 Jun 2017 15:12:08 -0400 | ||
4 | Subject: [PATCH] cgroups: work around issue in gcc 7 | ||
5 | |||
6 | This works around | ||
7 | https://bugzilla.yoctoproject.org/show_bug.cgi?id=11672 | ||
8 | https://gcc.gnu.org/bugzilla/show_bug.cgi?id=78969 | ||
9 | |||
10 | By removing a single cgroup entry. For the majority of usecases this | ||
11 | loss of a single entry should not be an issue and once gcc 7 is fixed | ||
12 | we can revert this. | ||
13 | |||
14 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | ||
15 | --- | ||
16 | src/lxc/cgroups/cgfsng.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/src/lxc/cgroups/cgfsng.c b/src/lxc/cgroups/cgfsng.c | ||
20 | index ebd548b..c520abd 100644 | ||
21 | --- a/src/lxc/cgroups/cgfsng.c | ||
22 | +++ b/src/lxc/cgroups/cgfsng.c | ||
23 | @@ -1373,7 +1373,7 @@ static inline bool cgfsng_create(void *hdata) | ||
24 | offset = cgname + len - 5; | ||
25 | |||
26 | again: | ||
27 | - if (idx == 1000) { | ||
28 | + if (idx == 999) { | ||
29 | ERROR("Too many conflicting cgroup names"); | ||
30 | goto out_free; | ||
31 | } | ||
32 | -- | ||
33 | 2.7.4 | ||
34 | |||
diff --git a/recipes-containers/lxc/lxc_2.0.8.bb b/recipes-containers/lxc/lxc_2.0.8.bb index 80c8da73..3dd9f63f 100644 --- a/recipes-containers/lxc/lxc_2.0.8.bb +++ b/recipes-containers/lxc/lxc_2.0.8.bb | |||
@@ -28,6 +28,7 @@ SRC_URI = "http://linuxcontainers.org/downloads/${BPN}-${PV}.tar.gz \ | |||
28 | file://lxc-fix-B-S.patch \ | 28 | file://lxc-fix-B-S.patch \ |
29 | file://lxc-doc-upgrade-to-use-docbook-3.1-DTD.patch \ | 29 | file://lxc-doc-upgrade-to-use-docbook-3.1-DTD.patch \ |
30 | file://logs-optionally-use-base-filenames-to-report-src-fil.patch \ | 30 | file://logs-optionally-use-base-filenames-to-report-src-fil.patch \ |
31 | file://cgroups-work-around-issue-in-gcc-7.patch \ | ||
31 | " | 32 | " |
32 | 33 | ||
33 | SRC_URI[md5sum] = "7bfd95280522d7936c0979dfea92cdb5" | 34 | SRC_URI[md5sum] = "7bfd95280522d7936c0979dfea92cdb5" |