diff options
6 files changed, 527 insertions, 0 deletions
diff --git a/recipes-extended/upx/libucl/0001-configure.ac-Fix-with-current-autoconf.patch b/recipes-extended/upx/libucl/0001-configure.ac-Fix-with-current-autoconf.patch new file mode 100644 index 00000000..ba84cdd6 --- /dev/null +++ b/recipes-extended/upx/libucl/0001-configure.ac-Fix-with-current-autoconf.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 76e95c0db3f30f0279c54f7c0041c59fa24bf7a6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrei Gherzan <andrei@resin.io> | ||
3 | Date: Fri, 6 May 2016 01:00:14 +0200 | ||
4 | Subject: [PATCH 1/2] configure.ac: Fix with current autoconf | ||
5 | |||
6 | Old versions of autoconf define _AC_SRCPATHS, new (2.60 and later) use _AC_SRCDIRS. | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Andrei Gherzan <andrei@resin.io> | ||
11 | --- | ||
12 | configure.ac | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/configure.ac b/configure.ac | ||
16 | index 16adb1d..0bd1c91 100644 | ||
17 | --- a/configure.ac | ||
18 | +++ b/configure.ac | ||
19 | @@ -48,7 +48,7 @@ AC_CANONICAL_TARGET | ||
20 | AM_MAINTAINER_MODE | ||
21 | |||
22 | if test -z "$ac_abs_top_srcdir"; then | ||
23 | - _AC_SRCPATHS(.) | ||
24 | + _AC_SRCDIRS(.) | ||
25 | fi | ||
26 | if test -r .Conf.settings1; then | ||
27 | . ./.Conf.settings1 | ||
28 | -- | ||
29 | 2.1.4 | ||
30 | |||
diff --git a/recipes-extended/upx/libucl/0002-acinclude.m4-Provide-missing-macros.patch b/recipes-extended/upx/libucl/0002-acinclude.m4-Provide-missing-macros.patch new file mode 100644 index 00000000..16cad534 --- /dev/null +++ b/recipes-extended/upx/libucl/0002-acinclude.m4-Provide-missing-macros.patch | |||
@@ -0,0 +1,383 @@ | |||
1 | From cab9f6b11793149a3f968552be7d351e59e62a92 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrei Gherzan <andrei@resin.io> | ||
3 | Date: Fri, 6 May 2016 01:01:26 +0200 | ||
4 | Subject: [PATCH 2/2] acinclude.m4: Provide missing macros | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Andrei Gherzan <andrei@resin.io> | ||
9 | --- | ||
10 | acinclude.m4 | 361 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ | ||
11 | 1 file changed, 361 insertions(+) | ||
12 | create mode 100644 acinclude.m4 | ||
13 | |||
14 | diff --git a/acinclude.m4 b/acinclude.m4 | ||
15 | new file mode 100644 | ||
16 | index 0000000..f7d6d16 | ||
17 | --- /dev/null | ||
18 | +++ b/acinclude.m4 | ||
19 | @@ -0,0 +1,361 @@ | ||
20 | +# /*********************************************************************** | ||
21 | +# // standard ACC macros | ||
22 | +# ************************************************************************/ | ||
23 | + | ||
24 | +AC_DEFUN([mfx_ACC_CHECK_ENDIAN], [ | ||
25 | +AC_C_BIGENDIAN([AC_DEFINE(ACC_ABI_BIG_ENDIAN,1,[Define to 1 if your machine is big endian.])],[AC_DEFINE(ACC_ABI_LITTLE_ENDIAN,1,[Define to 1 if your machine is little endian.])]) | ||
26 | +])# | ||
27 | + | ||
28 | +AC_DEFUN([mfx_ACC_CHECK_HEADERS], [ | ||
29 | +AC_HEADER_TIME | ||
30 | +AC_CHECK_HEADERS([assert.h ctype.h dirent.h errno.h fcntl.h float.h limits.h malloc.h memory.h setjmp.h signal.h stdarg.h stddef.h stdint.h stdio.h stdlib.h string.h strings.h time.h unistd.h utime.h sys/mman.h sys/resource.h sys/stat.h sys/time.h sys/types.h sys/wait.h]) | ||
31 | +])# | ||
32 | + | ||
33 | +AC_DEFUN([mfx_ACC_CHECK_FUNCS], [ | ||
34 | +AC_CHECK_FUNCS(access alloca atexit atoi atol chmod chown clock_getcpuclockid clock_getres clock_gettime ctime difftime fstat getenv getpagesize getrusage gettimeofday gmtime isatty localtime longjmp lstat memcmp memcpy memmove memset mkdir mktime mmap mprotect munmap qsort raise rmdir setjmp signal snprintf strcasecmp strchr strdup strerror strftime stricmp strncasecmp strnicmp strrchr strstr time umask utime vsnprintf) | ||
35 | +])# | ||
36 | + | ||
37 | + | ||
38 | +AC_DEFUN([mfx_ACC_CHECK_SIZEOF], [ | ||
39 | +AC_CHECK_SIZEOF(short) | ||
40 | +AC_CHECK_SIZEOF(int) | ||
41 | +AC_CHECK_SIZEOF(long) | ||
42 | + | ||
43 | +AC_CHECK_SIZEOF(long long) | ||
44 | +AC_CHECK_SIZEOF(__int16) | ||
45 | +AC_CHECK_SIZEOF(__int32) | ||
46 | +AC_CHECK_SIZEOF(__int64) | ||
47 | + | ||
48 | +AC_CHECK_SIZEOF(void *) | ||
49 | +AC_CHECK_SIZEOF(char *) | ||
50 | +AC_CHECK_SIZEOF(size_t) | ||
51 | +AC_CHECK_SIZEOF(ptrdiff_t) | ||
52 | +])# | ||
53 | + | ||
54 | + | ||
55 | +# /*********************************************************************** | ||
56 | +# // Check for ACC_conformance | ||
57 | +# ************************************************************************/ | ||
58 | + | ||
59 | +AC_DEFUN([mfx_ACC_ACCCHK], [ | ||
60 | +mfx_tmp=$1 | ||
61 | +mfx_save_CPPFLAGS=$CPPFLAGS | ||
62 | +dnl in Makefile.in $(INCLUDES) will be before $(CPPFLAGS), so we mimic this here | ||
63 | +test "X$mfx_tmp" = "X" || CPPFLAGS="$mfx_tmp $CPPFLAGS" | ||
64 | + | ||
65 | +AC_MSG_CHECKING([whether your compiler passes the ACC conformance test]) | ||
66 | + | ||
67 | +AC_LANG_CONFTEST([AC_LANG_PROGRAM( | ||
68 | +[[#define ACC_CONFIG_NO_HEADER 1 | ||
69 | +#include "acc/acc.h" | ||
70 | +#include "acc/acc_incd.h" | ||
71 | +#undef ACCCHK_ASSERT | ||
72 | +#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT_HEADER(expr) | ||
73 | +#include "acc/acc_chk.ch" | ||
74 | +#undef ACCCHK_ASSERT | ||
75 | +static void test_acc_compile_time_assert(void) { | ||
76 | +#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT(expr) | ||
77 | +#include "acc/acc_chk.ch" | ||
78 | +#undef ACCCHK_ASSERT | ||
79 | +} | ||
80 | +#undef NDEBUG | ||
81 | +#include <assert.h> | ||
82 | +static int test_acc_run_time_assert(int r) { | ||
83 | +#define ACCCHK_ASSERT(expr) assert(expr); | ||
84 | +#include "acc/acc_chk.ch" | ||
85 | +#undef ACCCHK_ASSERT | ||
86 | +return r; | ||
87 | +} | ||
88 | +]], [[ | ||
89 | +test_acc_compile_time_assert(); | ||
90 | +if (test_acc_run_time_assert(1) != 1) return 1; | ||
91 | +]] | ||
92 | +)]) | ||
93 | + | ||
94 | +mfx_tmp=FAILED | ||
95 | +_AC_COMPILE_IFELSE([], [mfx_tmp=yes]) | ||
96 | +rm -f conftest.$ac_ext conftest.$ac_objext | ||
97 | + | ||
98 | +CPPFLAGS=$mfx_save_CPPFLAGS | ||
99 | + | ||
100 | +AC_MSG_RESULT([$mfx_tmp]) | ||
101 | +case x$mfx_tmp in | ||
102 | + xpassed | xyes) ;; | ||
103 | + *) | ||
104 | + AC_MSG_NOTICE([]) | ||
105 | + AC_MSG_NOTICE([Your compiler failed the ACC conformance test - for details see ]) | ||
106 | + AC_MSG_NOTICE([`config.log'. Please check that log file and consider sending]) | ||
107 | + AC_MSG_NOTICE([a patch or bug-report to <${PACKAGE_BUGREPORT}>.]) | ||
108 | + AC_MSG_NOTICE([Thanks for your support.]) | ||
109 | + AC_MSG_NOTICE([]) | ||
110 | + AC_MSG_ERROR([ACC conformance test failed. Stop.]) | ||
111 | +dnl AS_EXIT | ||
112 | + ;; | ||
113 | +esac | ||
114 | +])# mfx_ACC_ACCCHK | ||
115 | + | ||
116 | + | ||
117 | +# /*********************************************************************** | ||
118 | +# // Check for ACC_conformance | ||
119 | +# ************************************************************************/ | ||
120 | + | ||
121 | +AC_DEFUN([mfx_MINIACC_ACCCHK], [ | ||
122 | +mfx_tmp=$1 | ||
123 | +mfx_save_CPPFLAGS=$CPPFLAGS | ||
124 | +dnl in Makefile.in $(INCLUDES) will be before $(CPPFLAGS), so we mimic this here | ||
125 | +test "X$mfx_tmp" = "X" || CPPFLAGS="$mfx_tmp $CPPFLAGS" | ||
126 | + | ||
127 | +AC_MSG_CHECKING([whether your compiler passes the ACC conformance test]) | ||
128 | + | ||
129 | +AC_LANG_CONFTEST([AC_LANG_PROGRAM( | ||
130 | +[[#define ACC_CONFIG_NO_HEADER 1 | ||
131 | +#define ACC_WANT_ACC_INCD_H 1 | ||
132 | +#include $2 | ||
133 | + | ||
134 | +#define ACC_WANT_ACC_CHK_CH 1 | ||
135 | +#undef ACCCHK_ASSERT | ||
136 | +#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT_HEADER(expr) | ||
137 | +#include $2 | ||
138 | + | ||
139 | +#define ACC_WANT_ACC_CHK_CH 1 | ||
140 | +#undef ACCCHK_ASSERT | ||
141 | +#define ACCCHK_ASSERT(expr) ACC_COMPILE_TIME_ASSERT(expr) | ||
142 | +static void test_acc_compile_time_assert(void) { | ||
143 | +#include $2 | ||
144 | +} | ||
145 | + | ||
146 | +#undef NDEBUG | ||
147 | +#include <assert.h> | ||
148 | +#define ACC_WANT_ACC_CHK_CH 1 | ||
149 | +#undef ACCCHK_ASSERT | ||
150 | +#define ACCCHK_ASSERT(expr) assert(expr); | ||
151 | +static int test_acc_run_time_assert(int r) { | ||
152 | +#include $2 | ||
153 | +return r; | ||
154 | +} | ||
155 | +]], [[ | ||
156 | +test_acc_compile_time_assert(); | ||
157 | +if (test_acc_run_time_assert(1) != 1) return 1; | ||
158 | +]] | ||
159 | +)]) | ||
160 | + | ||
161 | +mfx_tmp=FAILED | ||
162 | +_AC_COMPILE_IFELSE([], [mfx_tmp=yes]) | ||
163 | +rm -f conftest.$ac_ext conftest.$ac_objext | ||
164 | + | ||
165 | +CPPFLAGS=$mfx_save_CPPFLAGS | ||
166 | + | ||
167 | +AC_MSG_RESULT([$mfx_tmp]) | ||
168 | +case x$mfx_tmp in | ||
169 | + xpassed | xyes) ;; | ||
170 | + *) | ||
171 | + AC_MSG_NOTICE([]) | ||
172 | + AC_MSG_NOTICE([Your compiler failed the ACC conformance test - for details see ]) | ||
173 | + AC_MSG_NOTICE([`config.log'. Please check that log file and consider sending]) | ||
174 | + AC_MSG_NOTICE([a patch or bug-report to <${PACKAGE_BUGREPORT}>.]) | ||
175 | + AC_MSG_NOTICE([Thanks for your support.]) | ||
176 | + AC_MSG_NOTICE([]) | ||
177 | + AC_MSG_ERROR([ACC conformance test failed. Stop.]) | ||
178 | +dnl AS_EXIT | ||
179 | + ;; | ||
180 | +esac | ||
181 | +])# mfx_MINIACC_ACCCHK | ||
182 | + | ||
183 | + | ||
184 | + | ||
185 | +# serial 1 | ||
186 | + | ||
187 | +AC_DEFUN([mfx_PROG_CPPFLAGS], [ | ||
188 | +AC_MSG_CHECKING([whether the C preprocessor needs special flags]) | ||
189 | + | ||
190 | +AC_LANG_CONFTEST([AC_LANG_PROGRAM( | ||
191 | +[[#include <limits.h> | ||
192 | +#if (32767 >= 4294967295ul) || (65535u >= 4294967295ul) | ||
193 | +# include "your C preprocessor is broken 1" | ||
194 | +#elif (0xffffu == 0xfffffffful) | ||
195 | +# include "your C preprocessor is broken 2" | ||
196 | +#elif (32767 >= ULONG_MAX) || (65535u >= ULONG_MAX) | ||
197 | +# include "your C preprocessor is broken 3" | ||
198 | +#endif | ||
199 | +]], [[ ]] | ||
200 | +)]) | ||
201 | + | ||
202 | +mfx_save_CPPFLAGS=$CPPFLAGS | ||
203 | +mfx_tmp=ERROR | ||
204 | +for mfx_arg in "" -no-cpp-precomp | ||
205 | +do | ||
206 | + CPPFLAGS="$mfx_arg $mfx_save_CPPFLAGS" | ||
207 | + _AC_COMPILE_IFELSE([], | ||
208 | +[mfx_tmp=$mfx_arg | ||
209 | +break]) | ||
210 | +done | ||
211 | +CPPFLAGS=$mfx_save_CPPFLAGS | ||
212 | +rm -f conftest.$ac_ext conftest.$ac_objext | ||
213 | +case x$mfx_tmp in | ||
214 | + x) | ||
215 | + AC_MSG_RESULT([none needed]) ;; | ||
216 | + xERROR) | ||
217 | + AC_MSG_RESULT([ERROR]) | ||
218 | + AC_MSG_ERROR([your C preprocessor is broken - for details see config.log]) | ||
219 | + ;; | ||
220 | + *) | ||
221 | + AC_MSG_RESULT([$mfx_tmp]) | ||
222 | + CPPFLAGS="$mfx_tmp $CPPFLAGS" | ||
223 | + ;; | ||
224 | +esac | ||
225 | +])# mfx_PROG_CPPFLAGS | ||
226 | + | ||
227 | +# serial 3 | ||
228 | + | ||
229 | +AC_DEFUN([mfx_CHECK_HEADER_SANE_LIMITS_H], [ | ||
230 | +AC_CACHE_CHECK([whether limits.h is sane], | ||
231 | +mfx_cv_header_sane_limits_h, | ||
232 | +[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <limits.h> | ||
233 | +#if (32767 >= 4294967295ul) || (65535u >= 4294967295ul) | ||
234 | +# if defined(__APPLE__) && defined(__GNUC__) | ||
235 | +# error "your preprocessor is broken - use compiler option -no-cpp-precomp" | ||
236 | +# else | ||
237 | +# include "your preprocessor is broken" | ||
238 | +# endif | ||
239 | +#endif | ||
240 | +#define MFX_0xffff 0xffff | ||
241 | +#define MFX_0xffffffffL 4294967295ul | ||
242 | +#if !defined(CHAR_BIT) || (CHAR_BIT != 8) | ||
243 | +# include "error CHAR_BIT" | ||
244 | +#endif | ||
245 | +#if !defined(UCHAR_MAX) | ||
246 | +# include "error UCHAR_MAX 1" | ||
247 | +#endif | ||
248 | +#if !defined(USHRT_MAX) | ||
249 | +# include "error USHRT_MAX 1" | ||
250 | +#endif | ||
251 | +#if !defined(UINT_MAX) | ||
252 | +# include "error UINT_MAX 1" | ||
253 | +#endif | ||
254 | +#if !defined(ULONG_MAX) | ||
255 | +# include "error ULONG_MAX 1" | ||
256 | +#endif | ||
257 | +#if !defined(SHRT_MAX) | ||
258 | +# include "error SHRT_MAX 1" | ||
259 | +#endif | ||
260 | +#if !defined(INT_MAX) | ||
261 | +# include "error INT_MAX 1" | ||
262 | +#endif | ||
263 | +#if !defined(LONG_MAX) | ||
264 | +# include "error LONG_MAX 1" | ||
265 | +#endif | ||
266 | +#if (UCHAR_MAX < 1) | ||
267 | +# include "error UCHAR_MAX 2" | ||
268 | +#endif | ||
269 | +#if (USHRT_MAX < 1) | ||
270 | +# include "error USHRT_MAX 2" | ||
271 | +#endif | ||
272 | +#if (UINT_MAX < 1) | ||
273 | +# include "error UINT_MAX 2" | ||
274 | +#endif | ||
275 | +#if (ULONG_MAX < 1) | ||
276 | +# include "error ULONG_MAX 2" | ||
277 | +#endif | ||
278 | +#if (UCHAR_MAX < 0xff) | ||
279 | +# include "error UCHAR_MAX 3" | ||
280 | +#endif | ||
281 | +#if (USHRT_MAX < MFX_0xffff) | ||
282 | +# include "error USHRT_MAX 3" | ||
283 | +#endif | ||
284 | +#if (UINT_MAX < MFX_0xffff) | ||
285 | +# include "error UINT_MAX 3" | ||
286 | +#endif | ||
287 | +#if (ULONG_MAX < MFX_0xffffffffL) | ||
288 | +# include "error ULONG_MAX 3" | ||
289 | +#endif | ||
290 | +#if (USHRT_MAX > UINT_MAX) | ||
291 | +# include "error USHRT_MAX vs UINT_MAX" | ||
292 | +#endif | ||
293 | +#if (UINT_MAX > ULONG_MAX) | ||
294 | +# include "error UINT_MAX vs ULONG_MAX" | ||
295 | +#endif | ||
296 | +]], [[ | ||
297 | +#if (USHRT_MAX == MFX_0xffff) | ||
298 | +{ typedef char a_short2a[1 - 2 * !(sizeof(short) == 2)]; } | ||
299 | +#elif (USHRT_MAX >= MFX_0xffff) | ||
300 | +{ typedef char a_short2b[1 - 2 * !(sizeof(short) > 2)]; } | ||
301 | +#endif | ||
302 | +#if (UINT_MAX == MFX_0xffff) | ||
303 | +{ typedef char a_int2a[1 - 2 * !(sizeof(int) == 2)]; } | ||
304 | +#elif (UINT_MAX >= MFX_0xffff) | ||
305 | +{ typedef char a_int2b[1 - 2 * !(sizeof(int) > 2)]; } | ||
306 | +#endif | ||
307 | +#if (ULONG_MAX == MFX_0xffff) | ||
308 | +{ typedef char a_long2a[1 - 2 * !(sizeof(long) == 2)]; } | ||
309 | +#elif (ULONG_MAX >= MFX_0xffff) | ||
310 | +{ typedef char a_long2b[1 - 2 * !(sizeof(long) > 2)]; } | ||
311 | +#endif | ||
312 | +#if !defined(_CRAY1) /* CRAY PVP systems */ | ||
313 | +#if (USHRT_MAX == MFX_0xffffffffL) | ||
314 | +{ typedef char a_short4a[1 - 2 * !(sizeof(short) == 4)]; } | ||
315 | +#elif (USHRT_MAX >= MFX_0xffffffffL) | ||
316 | +{ typedef char a_short4b[1 - 2 * !(sizeof(short) > 4)]; } | ||
317 | +#endif | ||
318 | +#endif /* _CRAY1 */ | ||
319 | +#if (UINT_MAX == MFX_0xffffffffL) | ||
320 | +{ typedef char a_int4a[1 - 2 * !(sizeof(int) == 4)]; } | ||
321 | +#elif (UINT_MAX >= MFX_0xffffffffL) | ||
322 | +{ typedef char a_int4b[1 - 2 * !(sizeof(int) > 4)]; } | ||
323 | +#endif | ||
324 | +#if (ULONG_MAX == MFX_0xffffffffL) | ||
325 | +{ typedef char a_long4a[1 - 2 * !(sizeof(long) == 4)]; } | ||
326 | +#elif (ULONG_MAX >= MFX_0xffffffffL) | ||
327 | +{ typedef char a_long4b[1 - 2 * !(sizeof(long) > 4)]; } | ||
328 | +#endif | ||
329 | +]])], | ||
330 | +[mfx_cv_header_sane_limits_h=yes], | ||
331 | +[mfx_cv_header_sane_limits_h=no])]) | ||
332 | +]) | ||
333 | + | ||
334 | +# /*********************************************************************** | ||
335 | +# // standard | ||
336 | +# ************************************************************************/ | ||
337 | + | ||
338 | +AC_DEFUN([mfx_LZO_CHECK_ENDIAN], [ | ||
339 | +AC_C_BIGENDIAN([AC_DEFINE(LZO_ABI_BIG_ENDIAN,1,[Define to 1 if your machine is big endian.])],[AC_DEFINE(LZO_ABI_LITTLE_ENDIAN,1,[Define to 1 if your machine is little endian.])]) | ||
340 | +])# | ||
341 | + | ||
342 | + | ||
343 | +# /*********************************************************************** | ||
344 | +# // | ||
345 | +# ************************************************************************/ | ||
346 | + | ||
347 | +dnl more types which are not yet covered by ACC | ||
348 | + | ||
349 | +AC_DEFUN([mfx_CHECK_SIZEOF], [ | ||
350 | +AC_CHECK_SIZEOF(__int32) | ||
351 | +AC_CHECK_SIZEOF(intmax_t) | ||
352 | +AC_CHECK_SIZEOF(uintmax_t) | ||
353 | +AC_CHECK_SIZEOF(intptr_t) | ||
354 | +AC_CHECK_SIZEOF(uintptr_t) | ||
355 | + | ||
356 | +AC_CHECK_SIZEOF(float) | ||
357 | +AC_CHECK_SIZEOF(double) | ||
358 | +AC_CHECK_SIZEOF(long double) | ||
359 | + | ||
360 | +AC_CHECK_SIZEOF(dev_t) | ||
361 | +AC_CHECK_SIZEOF(fpos_t) | ||
362 | +AC_CHECK_SIZEOF(mode_t) | ||
363 | +AC_CHECK_SIZEOF(off_t) | ||
364 | +AC_CHECK_SIZEOF(ssize_t) | ||
365 | +AC_CHECK_SIZEOF(time_t) | ||
366 | +])# | ||
367 | + | ||
368 | + | ||
369 | + | ||
370 | +AC_DEFUN([mfx_CHECK_LIB_WINMM], [ | ||
371 | +if test "X$GCC" = Xyes; then | ||
372 | +case $host_os in | ||
373 | +cygwin* | mingw* | pw32*) | ||
374 | + test "X$LIBS" != "X" && LIBS="$LIBS " | ||
375 | + LIBS="${LIBS}-lwinmm" ;; | ||
376 | +*) | ||
377 | + ;; | ||
378 | +esac | ||
379 | +fi | ||
380 | +])# | ||
381 | -- | ||
382 | 2.1.4 | ||
383 | |||
diff --git a/recipes-extended/upx/libucl/Reproducible-build.patch b/recipes-extended/upx/libucl/Reproducible-build.patch new file mode 100644 index 00000000..8398fe02 --- /dev/null +++ b/recipes-extended/upx/libucl/Reproducible-build.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From: Robert Luberda <robert@debian.org> | ||
2 | Date: Sun, 31 May 2015 13:09:15 +0200 | ||
3 | Subject: 03 Reproducible build | ||
4 | |||
5 | Introduced BUILD_DATETIME pre-processor variable to | ||
6 | be used instead of __DATE__ __TIME__ to make build | ||
7 | reproducible. | ||
8 | --- | ||
9 | src/ucl_util.c | 4 ++++ | ||
10 | 1 file changed, 4 insertions(+) | ||
11 | |||
12 | diff --git a/src/ucl_util.c b/src/ucl_util.c | ||
13 | index 7e49a2a..58aa0ea 100644 | ||
14 | --- a/src/ucl_util.c | ||
15 | +++ b/src/ucl_util.c | ||
16 | @@ -55,7 +55,11 @@ static const char __ucl_copyright[] = | ||
17 | "<markus@oberhumer.com>\n" | ||
18 | "http://www.oberhumer.com $\n\n" | ||
19 | "$Id: UCL version: v" UCL_VERSION_STRING ", " UCL_VERSION_DATE " $\n" | ||
20 | +#if defined (BUILD_DATETIME) | ||
21 | + "$Built: " BUILD_DATETIME " $\n" | ||
22 | +#else | ||
23 | "$Built: " __DATE__ " " __TIME__ " $\n" | ||
24 | +#endif | ||
25 | "$Info: " ACC_INFO_OS | ||
26 | #if defined(ACC_INFO_OS_POSIX) | ||
27 | "/" ACC_INFO_OS_POSIX | ||
diff --git a/recipes-extended/upx/libucl/use-static-assert.patch b/recipes-extended/upx/libucl/use-static-assert.patch new file mode 100644 index 00000000..bdf49003 --- /dev/null +++ b/recipes-extended/upx/libucl/use-static-assert.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From: Robert Luberda <robert@debian.org> | ||
2 | Date: Sat, 2 Jul 2016 22:23:20 +0200 | ||
3 | Subject: Switch to _Static_assert | ||
4 | |||
5 | Use _Static_assert for compile-time assertion to fix | ||
6 | build failures with gcc-6 (closes: #811707) | ||
7 | --- | ||
8 | acc/acc_defs.h | 6 ++++++ | ||
9 | 1 file changed, 6 insertions(+) | ||
10 | |||
11 | diff --git a/acc/acc_defs.h b/acc/acc_defs.h | ||
12 | index 866b7bd..5ee3761 100644 | ||
13 | --- a/acc/acc_defs.h | ||
14 | +++ b/acc/acc_defs.h | ||
15 | @@ -87,6 +87,9 @@ | ||
16 | |||
17 | /* This can be put into a header file but may get ignored by some compilers. */ | ||
18 | #if !defined(ACC_COMPILE_TIME_ASSERT_HEADER) | ||
19 | +# define ACC_COMPILE_TIME_ASSERT_HEADER(e) _Static_assert(e, #e); | ||
20 | +#endif | ||
21 | +#if !defined(ACC_COMPILE_TIME_ASSERT_HEADER) | ||
22 | # if (ACC_CC_AZTECC || ACC_CC_ZORTECHC) | ||
23 | # define ACC_COMPILE_TIME_ASSERT_HEADER(e) extern int __acc_cta[1-!(e)]; | ||
24 | # elif (ACC_CC_DMC || ACC_CC_SYMANTECC) | ||
25 | @@ -100,6 +103,9 @@ | ||
26 | |||
27 | /* This must appear within a function body. */ | ||
28 | #if !defined(ACC_COMPILE_TIME_ASSERT) | ||
29 | +# define ACC_COMPILE_TIME_ASSERT(e) _Static_assert(e, #e); | ||
30 | +#endif | ||
31 | +#if !defined(ACC_COMPILE_TIME_ASSERT) | ||
32 | # if (ACC_CC_AZTECC) | ||
33 | # define ACC_COMPILE_TIME_ASSERT(e) {typedef int __acc_cta_t[1-!(e)];} | ||
34 | # elif (ACC_CC_DMC || ACC_CC_PACIFICC || ACC_CC_SYMANTECC || ACC_CC_ZORTECHC) | ||
diff --git a/recipes-extended/upx/libucl_1.03.bb b/recipes-extended/upx/libucl_1.03.bb new file mode 100644 index 00000000..b611a968 --- /dev/null +++ b/recipes-extended/upx/libucl_1.03.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | HOMEPAGE = "http://www.oberhumer.com/opensource/ucl/" | ||
2 | SUMMARY = "Data compression library" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=dfeaf3dc4beef4f5a7bdbc35b197f39e" | ||
5 | |||
6 | SRC_URI = "http://www.oberhumer.com/opensource/ucl/download/ucl-1.03.tar.gz \ | ||
7 | file://0001-configure.ac-Fix-with-current-autoconf.patch \ | ||
8 | file://0002-acinclude.m4-Provide-missing-macros.patch \ | ||
9 | file://use-static-assert.patch \ | ||
10 | file://Reproducible-build.patch" | ||
11 | |||
12 | SRC_URI[md5sum] = "852bd691d8abc75b52053465846fba34" | ||
13 | SRC_URI[sha256sum] = "b865299ffd45d73412293369c9754b07637680e5c826915f097577cd27350348" | ||
14 | |||
15 | S = "${WORKDIR}/ucl-${PV}" | ||
16 | |||
17 | inherit autotools lib_package | ||
18 | |||
19 | BBCLASSEXTEND = "native" | ||
20 | |||
diff --git a/recipes-extended/upx/upx_git.bb b/recipes-extended/upx/upx_git.bb new file mode 100644 index 00000000..b77e6589 --- /dev/null +++ b/recipes-extended/upx/upx_git.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | HOMEPAGE = "http://upx.sourceforge.net" | ||
2 | SUMMARY = "Ultimate executable compressor." | ||
3 | |||
4 | SRCREV = "4e1ae22a1a07be5135c68b25ff05058ae8ae48e1" | ||
5 | SRC_URI = "gitsm://github.com/upx/upx;branch=devel" | ||
6 | |||
7 | LICENSE = "GPLv2" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=353753597aa110e0ded3508408c6374a" | ||
9 | |||
10 | DEPENDS = "zlib libucl xz" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | PV = "3.96+${SRCPV}" | ||
15 | |||
16 | EXTRA_OEMAKE += " \ | ||
17 | UPX_UCLDIR=${STAGING_DIR_TARGET} \ | ||
18 | UPX_LZMADIR=${STAGING_DIR_TARGET} \ | ||
19 | " | ||
20 | |||
21 | # FIXME: The build fails if security flags are enabled | ||
22 | SECURITY_CFLAGS = "" | ||
23 | |||
24 | do_compile() { | ||
25 | oe_runmake -C src all | ||
26 | } | ||
27 | |||
28 | do_install_append() { | ||
29 | install -d ${D}${bindir} | ||
30 | install -m 755 ${B}/src/upx.out ${D}${bindir}/upx | ||
31 | } | ||
32 | |||
33 | BBCLASSEXTEND = "native" | ||