diff options
-rw-r--r-- | recipes-containers/buildah/buildah_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/podman-tui/podman-tui_git.bb | 2 | ||||
-rw-r--r-- | recipes-containers/umoci/umoci_git.bb | 2 |
3 files changed, 6 insertions, 0 deletions
diff --git a/recipes-containers/buildah/buildah_git.bb b/recipes-containers/buildah/buildah_git.bb index 0fcf9813..e29e72ff 100644 --- a/recipes-containers/buildah/buildah_git.bb +++ b/recipes-containers/buildah/buildah_git.bb | |||
@@ -20,6 +20,8 @@ inherit pkgconfig | |||
20 | inherit features_check | 20 | inherit features_check |
21 | REQUIRED_DISTRO_FEATURES = "seccomp ipv6" | 21 | REQUIRED_DISTRO_FEATURES = "seccomp ipv6" |
22 | 22 | ||
23 | COMPATIBLE_HOST = "^(?!mips).*" | ||
24 | |||
23 | GO_IMPORT = "github.com/containers/buildah" | 25 | GO_IMPORT = "github.com/containers/buildah" |
24 | GO_INSTALL = "${GO_IMPORT}" | 26 | GO_INSTALL = "${GO_IMPORT}" |
25 | GO_WORKDIR = "${GO_INSTALL}" | 27 | GO_WORKDIR = "${GO_INSTALL}" |
diff --git a/recipes-containers/podman-tui/podman-tui_git.bb b/recipes-containers/podman-tui/podman-tui_git.bb index 1a40d0ec..0b1924f9 100644 --- a/recipes-containers/podman-tui/podman-tui_git.bb +++ b/recipes-containers/podman-tui/podman-tui_git.bb | |||
@@ -41,6 +41,8 @@ PODMAN_PKG = "github.com/containers/podman-tui" | |||
41 | inherit go goarch | 41 | inherit go goarch |
42 | inherit pkgconfig | 42 | inherit pkgconfig |
43 | 43 | ||
44 | COMPATIBLE_HOST = "^(?!mips).*" | ||
45 | |||
44 | do_configure[noexec] = "1" | 46 | do_configure[noexec] = "1" |
45 | 47 | ||
46 | BUILD_TAGS ?= "exclude_graphdriver_btrfs exclude_graphdriver_devicemapper" | 48 | BUILD_TAGS ?= "exclude_graphdriver_btrfs exclude_graphdriver_devicemapper" |
diff --git a/recipes-containers/umoci/umoci_git.bb b/recipes-containers/umoci/umoci_git.bb index e2116892..2ed0af7d 100644 --- a/recipes-containers/umoci/umoci_git.bb +++ b/recipes-containers/umoci/umoci_git.bb | |||
@@ -17,6 +17,8 @@ GO_IMPORT = "github.com/opencontainers/umoci" | |||
17 | inherit goarch | 17 | inherit goarch |
18 | inherit go | 18 | inherit go |
19 | 19 | ||
20 | COMPATIBLE_HOST = "^(?!mips).*" | ||
21 | |||
20 | # This disables seccomp and apparmor, which are on by default in the | 22 | # This disables seccomp and apparmor, which are on by default in the |
21 | # go package. | 23 | # go package. |
22 | EXTRA_OEMAKE="BUILDTAGS=''" | 24 | EXTRA_OEMAKE="BUILDTAGS=''" |