diff options
-rw-r--r-- | recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch | 10 | ||||
-rw-r--r-- | recipes-containers/runc/runc-opencontainers_git.bb | 4 |
2 files changed, 7 insertions, 7 deletions
diff --git a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch index 163501ae..0090a589 100644 --- a/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch +++ b/recipes-containers/runc/files/0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch | |||
@@ -13,16 +13,16 @@ Index: git/src/import/Makefile | |||
13 | =================================================================== | 13 | =================================================================== |
14 | --- git.orig/src/import/Makefile | 14 | --- git.orig/src/import/Makefile |
15 | +++ git/src/import/Makefile | 15 | +++ git/src/import/Makefile |
16 | @@ -21,7 +21,7 @@ | 16 | @@ -25,7 +25,7 @@ |
17 | endif | 17 | endif |
18 | endif | 18 | endif |
19 | endif | 19 | endif |
20 | -GO_BUILD := $(GO) build -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ | 20 | -GO_BUILD := $(GO) build -trimpath $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ |
21 | +GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ | 21 | +GO_BUILD := $(GO) build $(GOBUILDFLAGS) -trimpath $(MOD_VENDOR) $(GO_BUILDMODE) $(EXTRA_FLAGS) -tags "$(BUILDTAGS)" \ |
22 | -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" | 22 | -ldflags "-X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" |
23 | GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \ | 23 | GO_BUILD_STATIC := CGO_ENABLED=1 $(GO) build -trimpath $(MOD_VENDOR) $(EXTRA_FLAGS) -tags "$(BUILDTAGS) netgo osusergo" \ |
24 | -ldflags "-w -extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" | 24 | -ldflags "-w -extldflags -static -X main.gitCommit=$(COMMIT) -X main.version=$(VERSION) $(EXTRA_LDFLAGS)" |
25 | @@ -38,7 +38,6 @@ | 25 | @@ -42,7 +42,6 @@ |
26 | 26 | ||
27 | static: | 27 | static: |
28 | $(GO_BUILD_STATIC) -o runc . | 28 | $(GO_BUILD_STATIC) -o runc . |
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb index f3ff9a86..a0602a2d 100644 --- a/recipes-containers/runc/runc-opencontainers_git.bb +++ b/recipes-containers/runc/runc-opencontainers_git.bb | |||
@@ -1,10 +1,10 @@ | |||
1 | include runc.inc | 1 | include runc.inc |
2 | 2 | ||
3 | SRCREV = "fce58ab2d5c488bc573d02712db476a6daa9a60c" | 3 | SRCREV = "bfcbc947d5d11327f2680047e2e6e94f4ee93d2a" |
4 | SRC_URI = " \ | 4 | SRC_URI = " \ |
5 | git://github.com/opencontainers/runc;branch=master \ | 5 | git://github.com/opencontainers/runc;branch=master \ |
6 | file://0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch \ | 6 | file://0001-Makefile-respect-GOBUILDFLAGS-for-runc-and-remove-re.patch \ |
7 | " | 7 | " |
8 | RUNC_VERSION = "1.0.0-rc93" | 8 | RUNC_VERSION = "1.0.0-rc95" |
9 | 9 | ||
10 | CVE_PRODUCT = "runc" | 10 | CVE_PRODUCT = "runc" |