diff options
3 files changed, 59 insertions, 45 deletions
diff --git a/recipes-containers/docker-compose/files/0001-docker-compose-support-newer-minor-version-of-reques.patch b/recipes-containers/docker-compose/files/0001-docker-compose-support-newer-minor-version-of-reques.patch deleted file mode 100644 index 48a6f25c..00000000 --- a/recipes-containers/docker-compose/files/0001-docker-compose-support-newer-minor-version-of-reques.patch +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | From b4655b5e7f1e5b87a758dfd7af01a49a40ed148a Mon Sep 17 00:00:00 2001 | ||
2 | From: Li Zhou <li.zhou@windriver.com> | ||
3 | Date: Thu, 10 Oct 2019 15:46:20 +0800 | ||
4 | Subject: [PATCH] docker-compose: support newer minor version of requests | ||
5 | |||
6 | Signed-off-by: Ofek Lev <ofekmeister@gmail.com> | ||
7 | |||
8 | Upstream-Status: Backport | ||
9 | |||
10 | Signed-off-by: Li Zhou <li.zhou@windriver.com> | ||
11 | --- | ||
12 | requirements.txt | 2 +- | ||
13 | setup.py | 2 +- | ||
14 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/requirements.txt b/requirements.txt | ||
17 | index 93a0cce..42bde41 100644 | ||
18 | --- a/requirements.txt | ||
19 | +++ b/requirements.txt | ||
20 | @@ -16,7 +16,7 @@ pypiwin32==219; sys_platform == 'win32' and python_version < '3.6' | ||
21 | pypiwin32==220; sys_platform == 'win32' and python_version >= '3.6' | ||
22 | PySocks==1.6.7 | ||
23 | PyYAML==3.12 | ||
24 | -requests==2.18.4 | ||
25 | +requests==2.19.1 | ||
26 | six==1.10.0 | ||
27 | texttable==0.9.1 | ||
28 | urllib3==1.21.1 | ||
29 | diff --git a/setup.py b/setup.py | ||
30 | index 422ba54..a74ee0f 100644 | ||
31 | --- a/setup.py | ||
32 | +++ b/setup.py | ||
33 | @@ -33,7 +33,7 @@ install_requires = [ | ||
34 | 'cached-property >= 1.2.0, < 2', | ||
35 | 'docopt >= 0.6.1, < 0.7', | ||
36 | 'PyYAML >= 3.10, < 4', | ||
37 | - 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.19', | ||
38 | + 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.20', | ||
39 | 'texttable >= 0.9.0, < 0.10', | ||
40 | 'websocket-client >= 0.32.0, < 1.0', | ||
41 | 'docker >= 3.3.0, < 4.0', | ||
42 | -- | ||
43 | 1.9.1 | ||
44 | |||
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch new file mode 100644 index 00000000..54835ff1 --- /dev/null +++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | |||
@@ -0,0 +1,58 @@ | |||
1 | From 2685716409c560cdf94aee6262ed8c32ad137133 Mon Sep 17 00:00:00 2001 | ||
2 | From: Chen Qi <Qi.Chen@windriver.com> | ||
3 | Date: Fri, 22 Nov 2019 09:24:58 +0800 | ||
4 | Subject: [PATCH] setup.py: remove maximum version requirements | ||
5 | |||
6 | Remove maximum version requirements so that docker-compose will not | ||
7 | require old version recipes. | ||
8 | |||
9 | Upstream-Status: Inappropriate [OE Specific] | ||
10 | |||
11 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> | ||
12 | --- | ||
13 | setup.py | 22 +++++++++++----------- | ||
14 | 1 file changed, 11 insertions(+), 11 deletions(-) | ||
15 | |||
16 | diff --git a/setup.py b/setup.py | ||
17 | index 422ba54..c2b4556 100644 | ||
18 | --- a/setup.py | ||
19 | +++ b/setup.py | ||
20 | @@ -30,16 +30,16 @@ def find_version(*file_paths): | ||
21 | |||
22 | |||
23 | install_requires = [ | ||
24 | - 'cached-property >= 1.2.0, < 2', | ||
25 | - 'docopt >= 0.6.1, < 0.7', | ||
26 | - 'PyYAML >= 3.10, < 4', | ||
27 | - 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.19', | ||
28 | - 'texttable >= 0.9.0, < 0.10', | ||
29 | - 'websocket-client >= 0.32.0, < 1.0', | ||
30 | - 'docker >= 3.3.0, < 4.0', | ||
31 | - 'dockerpty >= 0.4.1, < 0.5', | ||
32 | - 'six >= 1.3.0, < 2', | ||
33 | - 'jsonschema >= 2.5.1, < 3', | ||
34 | + 'cached-property >= 1.2.0', | ||
35 | + 'docopt >= 0.6.1', | ||
36 | + 'PyYAML >= 3.10', | ||
37 | + 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0', | ||
38 | + 'texttable >= 0.9.0', | ||
39 | + 'websocket-client >= 0.32.0', | ||
40 | + 'docker >= 3.3.0', | ||
41 | + 'dockerpty >= 0.4.1', | ||
42 | + 'six >= 1.3.0', | ||
43 | + 'jsonschema >= 2.5.1', | ||
44 | ] | ||
45 | |||
46 | |||
47 | @@ -56,7 +56,7 @@ extras_require = { | ||
48 | ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'], | ||
49 | ':python_version < "3.3"': ['ipaddress >= 1.0.16'], | ||
50 | ':sys_platform == "win32"': ['colorama >= 0.3.9, < 0.4'], | ||
51 | - 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], | ||
52 | + 'socks': ['PySocks >= 1.5.6, != 1.5.7'], | ||
53 | } | ||
54 | |||
55 | |||
56 | -- | ||
57 | 2.17.1 | ||
58 | |||
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.21.2.bb b/recipes-containers/docker-compose/python3-docker-compose_1.21.2.bb index a7f7b1c9..a8950059 100644 --- a/recipes-containers/docker-compose/python3-docker-compose_1.21.2.bb +++ b/recipes-containers/docker-compose/python3-docker-compose_1.21.2.bb | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "https://www.docker.com/" | |||
3 | LICENSE = "Apache-2.0" | 3 | LICENSE = "Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8" |
5 | 5 | ||
6 | SRC_URI += "file://0001-docker-compose-support-newer-minor-version-of-reques.patch" | 6 | SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch" |
7 | 7 | ||
8 | inherit pypi setuptools3 | 8 | inherit pypi setuptools3 |
9 | 9 | ||