diff options
-rw-r--r-- | recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb new file mode 100644 index 00000000..dac2d133 --- /dev/null +++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | HOMEPAGE = "https://github.com/opencontainers/runtime-tools" | ||
2 | SUMMARY = "oci-runtime-tool is a collection of tools for working with the OCI runtime specification" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b355a61a394a504dacde901c958f662c" | ||
5 | DEPENDS = "go-cross" | ||
6 | |||
7 | SRC_URI = "git://github.com/opencontainers/runtime-tools.git" | ||
8 | |||
9 | SRCREV = "038b0c99b82f3c08de31f6b09e693eb24644affd" | ||
10 | PV = "0.0.1+git${SRCPV}" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | inherit go-osarchmap | ||
15 | |||
16 | do_compile() { | ||
17 | export GOARCH="${TARGET_GOARCH}" | ||
18 | |||
19 | export GOPATH="${S}" | ||
20 | |||
21 | # Pass the needed cflags/ldflags so that cgo | ||
22 | # can find the needed headers files and libraries | ||
23 | export CGO_ENABLED="1" | ||
24 | export CFLAGS="" | ||
25 | export LDFLAGS="" | ||
26 | export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" | ||
27 | export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" | ||
28 | |||
29 | oe_runmake | ||
30 | } | ||
31 | |||
32 | do_install() { | ||
33 | install -d ${D}/${sbindir} | ||
34 | install ${S}/oci-runtime-tool ${D}/${sbindir}/oci-runtime-tool | ||
35 | } | ||