summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/riddler/files/0001-build-ensure-that-GOBUILDTAGS-are-respected.patch52
-rw-r--r--recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch53
-rw-r--r--recipes-containers/riddler/riddler_git.bb11
3 files changed, 58 insertions, 58 deletions
diff --git a/recipes-containers/riddler/files/0001-build-ensure-that-GOBUILDTAGS-are-respected.patch b/recipes-containers/riddler/files/0001-build-ensure-that-GOBUILDTAGS-are-respected.patch
new file mode 100644
index 00000000..80a4c35a
--- /dev/null
+++ b/recipes-containers/riddler/files/0001-build-ensure-that-GOBUILDTAGS-are-respected.patch
@@ -0,0 +1,52 @@
1From de09fed4786ba36431e8dcce1972c9e55ee50eaa Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Wed, 15 Jan 2025 19:03:27 +0000
4Subject: [PATCH] build: ensure that GOBUILDTAGS are respected
5
6Upstream-Status: Inappropriate [embedded specific]
7
8Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
9---
10 basic.mk | 8 ++++----
11 1 file changed, 4 insertions(+), 4 deletions(-)
12
13diff --git a/basic.mk b/basic.mk
14index cb9b881..a262b61 100644
15--- a/basic.mk
16+++ b/basic.mk
17@@ -45,12 +45,12 @@ build: prebuild $(NAME) ## Builds a dynamic executable or package.
18
19 $(NAME): $(wildcard *.go) $(wildcard */*.go) VERSION.txt
20 @echo "+ $@"
21- $(GO) build -tags "$(BUILDTAGS)" ${GO_LDFLAGS} -o $(NAME) .
22+ $(GO) build ${GOBUILDFLAGS} -tags "$(BUILDTAGS)" ${GO_LDFLAGS} -o $(NAME) .
23
24 .PHONY: static
25 static: prebuild ## Builds a static executable.
26 @echo "+ $@"
27- CGO_ENABLED=$(CGO_ENABLED) $(GO) build \
28+ CGO_ENABLED=$(CGO_ENABLED) $(GO) build ${GOBUILDFLAGS} \
29 -tags "$(BUILDTAGS) static_build" \
30 ${GO_LDFLAGS_STATIC} -o $(NAME) .
31
32@@ -107,7 +107,7 @@ install: prebuild ## Installs the executable or package.
33
34 define buildpretty
35 mkdir -p $(BUILDDIR)/$(1)/$(2);
36-GOOS=$(1) GOARCH=$(2) CGO_ENABLED=$(CGO_ENABLED) $(GO) build \
37+GOOS=$(1) GOARCH=$(2) CGO_ENABLED=$(CGO_ENABLED) $(GO) build ${GOBUILDFLAGS} \
38 -o $(BUILDDIR)/$(1)/$(2)/$(NAME) \
39 -a -tags "$(BUILDTAGS) static_build netgo" \
40 -installsuffix netgo ${GO_LDFLAGS_STATIC} .;
41@@ -123,7 +123,7 @@ cross: *.go VERSION.txt prebuild ## Builds the cross-compiled binaries, creating
42 define buildrelease
43 GOOS=$(1) GOARCH=$(2) CGO_ENABLED=$(CGO_ENABLED) $(GO) build \
44 -o $(BUILDDIR)/$(NAME)-$(1)-$(2) \
45- -a -tags "$(BUILDTAGS) static_build netgo" \
46+ -a ${GOBUILDFLAGS} -tags "$(BUILDTAGS) static_build netgo" \
47 -installsuffix netgo ${GO_LDFLAGS_STATIC} .;
48 md5sum $(BUILDDIR)/$(NAME)-$(1)-$(2) > $(BUILDDIR)/$(NAME)-$(1)-$(2).md5;
49 sha256sum $(BUILDDIR)/$(NAME)-$(1)-$(2) > $(BUILDDIR)/$(NAME)-$(1)-$(2).sha256;
50--
512.39.2
52
diff --git a/recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch b/recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch
deleted file mode 100644
index 9c6c124c..00000000
--- a/recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch
+++ /dev/null
@@ -1,53 +0,0 @@
1From 8ca4391a5954db168d513ba64c3791f63b044fbf Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 30 Jun 2020 23:58:22 -0400
4Subject: [PATCH] build: use to select cross compiler
5
6Upstream-Status: Inappropriate [embedded specific]
7
8Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
9---
10 git/Makefile | 10 +++++-----
11 1 file changed, 5 insertions(+), 5 deletions(-)
12
13diff --git git/Makefile git/Makefile
14index c6976af..f3c8d17 100644
15--- git/Makefile
16+++ git/Makefile
17@@ -10,11 +10,11 @@ all: clean build static fmt lint test vet
18
19 build:
20 @echo "+ $@"
21- @go build -tags "$(BUILDTAGS) cgo" .
22+ @${GO} build ${GOBUILDFLAGS} -tags "$(BUILDTAGS) cgo" .
23
24 static:
25 @echo "+ $@"
26- CGO_ENABLED=1 go build -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static" -o riddler .
27+ CGO_ENABLED=1 ${GO} build ${GOBUILDFLAGS} -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static" -o riddler .
28
29 fmt:
30 @echo "+ $@"
31@@ -26,11 +26,11 @@ lint:
32
33 test: fmt lint vet
34 @echo "+ $@"
35- @go test -v -tags "$(BUILDTAGS) cgo" $(shell go list ./... | grep -v vendor)
36+ @${GO} test -v -tags "$(BUILDTAGS) cgo" $(shell go list ./... | grep -v vendor)
37
38 vet:
39 @echo "+ $@"
40- @go vet $(shell go list ./... | grep -v vendor)
41+ @${GO} vet $(shell go list ./... | grep -v vendor)
42
43 clean:
44 @echo "+ $@"
45@@ -38,4 +38,4 @@ clean:
46
47 install:
48 @echo "+ $@"
49- @go install -v .
50+ @${GO} install -v .
51--
522.19.1
53
diff --git a/recipes-containers/riddler/riddler_git.bb b/recipes-containers/riddler/riddler_git.bb
index 746becf8..3d6581a1 100644
--- a/recipes-containers/riddler/riddler_git.bb
+++ b/recipes-containers/riddler/riddler_git.bb
@@ -1,16 +1,16 @@
1HOMEPAGE = "https://github.com/jfrazelle/riddler" 1HOMEPAGE = "https://github.com/jfrazelle/riddler"
2SUMMARY = "Convert `docker inspect` to opencontainers (OCI compatible) runc spec." 2SUMMARY = "Convert `docker inspect` to opencontainers (OCI compatible) runc spec."
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=20ce4c6a4f32d6ee4a68e3a7506db3f1" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=7bac31faf84a2d7e88972f562a3ebbe5"
5 5
6SRC_URI = "git://github.com/jfrazelle/riddler;branch=master;protocol=https;destsuffix=git/src/github.com/jessfraz/riddler \ 6SRC_URI = "git://github.com/jfrazelle/riddler;branch=master;protocol=https;destsuffix=git/src/github.com/genuinetools/riddler \
7 file://0001-build-use-to-select-cross-compiler.patch \ 7 file://0001-build-ensure-that-GOBUILDTAGS-are-respected.patch \
8 " 8 "
9 9
10SRCREV = "66698f2a5cb6854a1095673a15dcc253f0e28f93" 10SRCREV = "66698f2a5cb6854a1095673a15dcc253f0e28f93"
11PV = "v0.6.4+git" 11PV = "v0.6.4+git"
12 12
13S = "${WORKDIR}/git/src/github.com/jessfraz/riddler" 13S = "${WORKDIR}/git/src/github.com/genuinetools/riddler"
14GO_IMPORT = "github.com/jessfraz/riddler" 14GO_IMPORT = "github.com/jessfraz/riddler"
15 15
16inherit goarch 16inherit goarch
@@ -27,7 +27,8 @@ EXTRA_OEMAKE="BUILDTAGS=''"
27do_compile() { 27do_compile() {
28 export GOARCH="${TARGET_GOARCH}" 28 export GOARCH="${TARGET_GOARCH}"
29 export GOROOT="${STAGING_LIBDIR}/go" 29 export GOROOT="${STAGING_LIBDIR}/go"
30 export GOPATH="${S}/src/import/vendor:${WORKDIR}/git/" 30 # export GOPATH="${S}/src/import/vendor:${WORKDIR}/git/"
31 export GOPATH="${WORKDIR}/git/"
31 32
32 # Pass the needed cflags/ldflags so that cgo 33 # Pass the needed cflags/ldflags so that cgo
33 # can find the needed headers files and libraries 34 # can find the needed headers files and libraries