diff options
-rw-r--r-- | recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch | 17 | ||||
-rw-r--r-- | recipes-devtools/go/go-build_git.bb | 9 |
2 files changed, 8 insertions, 18 deletions
diff --git a/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch b/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch index 36d45b57..873d7ab4 100644 --- a/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch +++ b/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch | |||
@@ -11,16 +11,16 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
11 | gobuild/Makefile | 4 ++-- | 11 | gobuild/Makefile | 4 ++-- |
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | 12 | 1 file changed, 2 insertions(+), 2 deletions(-) |
13 | 13 | ||
14 | diff --git a/src/import/gobuild/Makefile b/src/import/gobuild/Makefile | 14 | Index: git/src/import/gobuild/Makefile |
15 | index 694d9ce..149d573 100644 | 15 | =================================================================== |
16 | --- a/src/import/gobuild/Makefile | 16 | --- git.orig/src/import/gobuild/Makefile |
17 | +++ b/src/import/gobuild/Makefile | 17 | +++ git/src/import/gobuild/Makefile |
18 | @@ -19,10 +19,10 @@ dep: ${GODEPPATHS} | 18 | @@ -19,10 +19,10 @@ |
19 | 19 | ||
20 | ${GODEPPATHS}: | 20 | ${GODEPPATHS}: |
21 | mkdir -p ${GOSRC} | 21 | mkdir -p ${GOSRC} |
22 | - GOPATH=${GOPATH} go get $(subst ${GOSRC}/,,$@) | 22 | - GOPATH=${GOPATH} go get -d $(subst ${GOSRC}/,,$@) |
23 | + GOPATH=${GOPATH} ${GO} get $(subst ${GOSRC}/,,$@) | 23 | + GOPATH=${GOPATH} ${GO} get -d $(subst ${GOSRC}/,,$@) |
24 | 24 | ||
25 | ${BIN}: ${GODEPPATHS} $(filter %/$@.go, ${MAIN}) | 25 | ${BIN}: ${GODEPPATHS} $(filter %/$@.go, ${MAIN}) |
26 | - GOPATH=${GOPATH} ${ARCH} go build $(filter %/$@.go, ${MAIN}) | 26 | - GOPATH=${GOPATH} ${ARCH} go build $(filter %/$@.go, ${MAIN}) |
@@ -28,6 +28,3 @@ index 694d9ce..149d573 100644 | |||
28 | 28 | ||
29 | clean: | 29 | clean: |
30 | rm -f ${BIN} | 30 | rm -f ${BIN} |
31 | -- | ||
32 | 2.19.1 | ||
33 | |||
diff --git a/recipes-devtools/go/go-build_git.bb b/recipes-devtools/go/go-build_git.bb index 3ac86084..29d75984 100644 --- a/recipes-devtools/go/go-build_git.bb +++ b/recipes-devtools/go/go-build_git.bb | |||
@@ -2,12 +2,10 @@ HOMEPAGE = "https://github.com/lf-edge/runx" | |||
2 | SUMMARY = "console for runx" | 2 | SUMMARY = "console for runx" |
3 | DESCRIPTION = "Xen Runtime for OCI" | 3 | DESCRIPTION = "Xen Runtime for OCI" |
4 | 4 | ||
5 | SRCREV_runx = "da0c75c58ae5232d19b1791c33545db3225e1ea9" | 5 | SRCREV_runx = "f24efd33fb18469e9cfe4d1bfe8e2c90ec8c4e93" |
6 | SRCREV_runc = "e4363b038787addfa12e8b0acf5417d4fba01693" | ||
7 | 6 | ||
8 | SRC_URI = "\ | 7 | SRC_URI = "\ |
9 | git://github.com/lf-edge/runx;nobranch=1;name=runx \ | 8 | git://github.com/lf-edge/runx;nobranch=1;name=runx \ |
10 | git://github.com/opencontainers/runc.git;nobranch=1;destsuffix=runc;name=runc \ | ||
11 | file://0001-build-use-instead-of-go.patch \ | 9 | file://0001-build-use-instead-of-go.patch \ |
12 | " | 10 | " |
13 | SRC_URI[md5sum] = "0d701ac1e2a67d47ce7127432df2c32b" | 11 | SRC_URI[md5sum] = "0d701ac1e2a67d47ce7127432df2c32b" |
@@ -34,9 +32,6 @@ do_compile() { | |||
34 | 32 | ||
35 | export GOARCH="${TARGET_GOARCH}" | 33 | export GOARCH="${TARGET_GOARCH}" |
36 | cd ${S}/src/import/gobuild | 34 | cd ${S}/src/import/gobuild |
37 | mkdir -p go/src/github.com/opencontainers | ||
38 | ln -sf ${WORKDIR}/runc ${S}/src/import/gobuild/go/src/github.com/opencontainers/runc | ||
39 | export GOPATH="${S}/src/import/gobuild/go/src/github.com/opencontainers/runc" | ||
40 | 35 | ||
41 | # Build the target binaries | 36 | # Build the target binaries |
42 | export GOARCH="${TARGET_GOARCH}" | 37 | export GOARCH="${TARGET_GOARCH}" |
@@ -57,8 +52,6 @@ do_install() { | |||
57 | 52 | ||
58 | install -d ${D}${datadir}/runX | 53 | install -d ${D}${datadir}/runX |
59 | install -m 755 ${B}/src/import/gobuild/serial_fd_handler ${D}${datadir}/runX/ | 54 | install -m 755 ${B}/src/import/gobuild/serial_fd_handler ${D}${datadir}/runX/ |
60 | install -m 755 ${B}/src/import/gobuild/recvtty ${D}${datadir}/runX/ | ||
61 | |||
62 | } | 55 | } |
63 | 56 | ||
64 | FILES_${PN} += "${datadir}/runX/*" | 57 | FILES_${PN} += "${datadir}/runX/*" |