summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/busybox/busybox-initrd.bb (renamed from recipes-core/busybox/busybox-initrd_1.36.0.bb)14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-core/busybox/busybox-initrd_1.36.0.bb b/recipes-core/busybox/busybox-initrd.bb
index 6108e9af..513ed135 100644
--- a/recipes-core/busybox/busybox-initrd_1.36.0.bb
+++ b/recipes-core/busybox/busybox-initrd.bb
@@ -1,5 +1,19 @@
1FILESEXTRAPATHS:prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:" 1FILESEXTRAPATHS:prepend := "${THISDIR}/busybox-initrd:${COREBASE}/meta/recipes-core/busybox/busybox:${COREBASE}/meta/recipes-core/busybox/files:"
2 2
3def get_busybox_pv(d):
4 import re
5 corebase = d.getVar('COREBASE')
6 bb_dir = os.path.join(corebase, 'meta', 'recipes-core', 'busybox')
7 if os.path.isdir(bb_dir):
8 re_bb_name = re.compile(r"busybox_([0-9.]*)\.bb")
9 for bb_file in os.listdir(bb_dir):
10 result = re_bb_name.match(bb_file)
11 if result:
12 return result.group(1)
13 bb.fatal("Cannot find busybox recipe in %s" % bb_dir)
14
15PV := "${@get_busybox_pv(d)}"
16
3require recipes-core/busybox/busybox_${PV}.bb 17require recipes-core/busybox/busybox_${PV}.bb
4 18
5SRC_URI += "file://init.cfg \ 19SRC_URI += "file://init.cfg \