summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/yq/yq_git.bb123
1 files changed, 78 insertions, 45 deletions
diff --git a/recipes-devtools/yq/yq_git.bb b/recipes-devtools/yq/yq_git.bb
index 3d0714c7..0e9d36ca 100644
--- a/recipes-devtools/yq/yq_git.bb
+++ b/recipes-devtools/yq/yq_git.bb
@@ -4,48 +4,85 @@ HOMEPAGE = "https://github.com/mikefarah/yq"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=e40a0dcd62f8269b9bff37fe9aa7dcc2" 5LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=e40a0dcd62f8269b9bff37fe9aa7dcc2"
6 6
7SRCREV_yq = "dd6cf3df146f3e2c0f8c765a6ef9e35780ad8cc1" 7SRCREV_yq = "de2f77b49cbd40fd67031ee602245d0acc4ac482"
8SRCREV_color = "daf2830f2741ebb735b21709a520c5f37d642d85"
9SRCREV_lexer = "6cdefc42e112ac71cbe316e1eed264ea62f58e25"
10SRCREV_cobra = "b43be995ebb4bee335a787bd44498b91aef7619c"
11SRCREV_pflag = "2e9d26c8c37aae03e3f9d4e90b7116f5accb7cab"
12SRCREV_logging = "b2cb9fa56473e98db8caba80237377e83fe44db5"
13SRCREV_yaml = "f6f7691b1fdeb513f56608cd2c32c51f8194bf51"
14SRCREV_xerrors = "65e65417b02f28de84b55f16b46a1e789149973a"
15SRCREV_envsubst = "16035fe3571ad42c7796bf554f978bb2df64231b"
16SRCREV_participle = "49f4822ed012d9818c80ca4fcdeb7e2d55c04806"
17SRCREV_utfbom = "6ae8f945ca96f30defc7e8ab12ec5d10cf86ded4"
18SRCREV_orderedmap = "1e43e194ff533a346bab5f9b66b738256f199c8a"
19SRCREV_go-json = "5efc7d07eeeba186df630d9ab4ac78c761938c27"
20SRCREV_copier = "d132b069fe1a77d09e4c260852b389a730bbe9ba"
21SRCREV_properties = "c9a06e8f8f0164e4e16c0d5c4793cbed4ac90264"
22SRCREV_net = "f3363e06e74cdc304618bf31d898b78590103527"
23SRCREV_text = "434eadcdbc3b0256971992e8c70027278364c72c"
24SRCREV_diff = "20ebb0f2a09e612109b224b32f79370409108bcc"
25 8
26SRCREV_FORMAT = "yq_color" 9SRCREV_FORMAT = "yq_color"
27SRC_URI = "git://${GO_IMPORT};name=yq;branch=master;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \ 10SRC_URI = "git://${GO_IMPORT};name=yq;branch=master;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX} \
28 git://github.com/fatih/color;name=color;destsuffix=build/vendor/src/github.com/fatih/color;branch=main;protocol=https \ 11 file://run-ptest"
29 git://github.com/goccy/go-yaml;name=lexer;destsuffix=build/vendor/src/github.com/goccy/go-yaml/;branch=master;protocol=https \ 12
30 git://github.com/spf13/cobra;name=cobra;nobranch=1;destsuffix=build/vendor/src/github.com/spf13/cobra;branch=main;protocol=https \ 13# go.mod dependencies are below:
31 git://github.com/spf13/pflag;name=pflag;destsuffix=build/vendor/src/github.com/spf13/pflag;branch=master;protocol=https \ 14
32 git://github.com/op/go-logging.git;name=logging;destsuffix=build/vendor/src/gopkg.in/op/go-logging.v1;branch=master;protocol=https \ 15SRCREV_net = "8da7ed17cdaf5e1d42aa868f0b0322a207a17dcd"
33 git://github.com/go-yaml/yaml.git;name=yaml;branch=v3;destsuffix=build/vendor/src/gopkg.in/yaml.v3;protocol=https \ 16SRC_URI += "git://go.googlesource.com/net;name=net;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/golang.org/x/net"
34 git://github.com/golang/xerrors;name=xerrors;protocol=https;nobranch=1;destsuffix=build/vendor/src/golang.org/x/xerrors \ 17
35 git://github.com/a8m/envsubst;name=envsubst;destsuffix=build/vendor/src/github.com/a8m/envsubst;branch=master;protocol=https \ 18SRCREV_yaml.v3 = "f6f7691b1fdeb513f56608cd2c32c51f8194bf51"
36 git://github.com/alecthomas/participle;name=participle;destsuffix=build/vendor/src/github.com/alecthomas/participle;branch=master;protocol=https \ 19SRC_URI += "git://github.com/go-yaml/yaml;name=yaml.v3;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/gopkg.in/yaml.v3"
37 git://github.com/dimchansky/utfbom;name=utfbom;destsuffix=build/vendor/src/github.com/dimchansky/utfbom;branch=master;protocol=https \ 20
38 git://github.com/elliotchance/orderedmap;name=orderedmap;destsuffix=build/vendor/src/github.com/elliotchance/orderedmap;branch=master;protocol=https \ 21SRCREV_sys = "d4ac05dc8c4c953ec29cae3df56c0833f4010763"
39 git://github.com/goccy/go-json;name=go-json;destsuffix=build/vendor/src/github.com/goccy/go-json;branch=master;protocol=https \ 22SRC_URI += "git://github.com/golang/sys;name=sys;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/golang.org/x/sys"
40 git://github.com/jinzhu/copier;name=copier;destsuffix=build/vendor/src/github.com/jinzhu/copier;branch=master;protocol=https \ 23
41 git://github.com/magiconair/properties;name=properties;destsuffix=build/vendor/src/github.com/magiconair/properties;branch=main;protocol=https \ 24SRCREV_text = "566b44fc931e2542778a18423c655ce99b4f1402"
42 git://github.com/golang/net;name=net;destsuffix=build/vendor/src/golang.org/x/net;branch=master;protocol=https \ 25SRC_URI += "git://go.googlesource.com/text;name=text;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/golang.org/x/text"
43 git://github.com/golang/text;name=text;destsuffix=build/vendor/src/golang.org/x/text;branch=master;protocol=https \ 26
44 git://github.com/pkg/diff;name=diff;destsuffix=build/vendor/src/github.com/pkg/diff;branch=main;protocol=https;apply=no \ 27SRCREV_diff = "20ebb0f2a09e612109b224b32f79370409108bcc"
45 file://run-ptest \ 28SRC_URI += "git://github.com/pkg/diff;name=diff;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/pkg/diff"
46 " 29
30SRCREV_color = "1c8d8706604ee5fb9a464e5097ba113101828a75"
31SRC_URI += "git://github.com/fatih/color;name=color;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/fatih/color"
32
33SRCREV_cobra = "e94f6d0dd9a5e5738dca6bce03c4b1207ffbc0ec"
34SRC_URI += "git://github.com/spf13/cobra;name=cobra;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/spf13/cobra"
35
36SRCREV_pflag = "5ca813443bd2a4d9f46a253ea0407d23b3790713"
37SRC_URI += "git://github.com/spf13/pflag;name=pflag;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/spf13/pflag"
38
39SRCREV_envsubst = "9df41d110e18f0ce5f7cd58f94d88d79dc441259"
40SRC_URI += "git://github.com/a8m/envsubst;name=envsubst;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/a8m/envsubst"
41
42SRCREV_go-json = "9872089c316cfe2d0f29b331b75d45bf6d522d96"
43SRC_URI += "git://github.com/goccy/go-json;name=go-json;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/goccy/go-json"
44
45SRCREV_go-yaml = "9b2c4569e2563d5cf2f16785b1fa2cab5e09882e"
46SRC_URI += "git://github.com/goccy/go-yaml;name=go-yaml;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/goccy/go-yaml"
47
48SRCREV_copier = "70b1d4e41a98ca3ef7f468ade5c515e4193405df"
49SRC_URI += "git://github.com/jinzhu/copier;name=copier;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/jinzhu/copier"
50
51SRCREV_go-logging.v1 = "b2cb9fa56473e98db8caba80237377e83fe44db5"
52SRC_URI += "git://github.com/op/go-logging;name=go-logging.v1;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/gopkg.in/op/go-logging.v1"
53
54SRCREV_repr = "3d05a4813c4bc97890471226ba1cf7f240a376ac"
55SRC_URI += "git://github.com/alecthomas/repr;name=repr;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/alecthomas/repr"
56
57SRCREV_gopher-lua = "1388221efeb4a239a053e5932c3d755699055684"
58SRC_URI += "git://github.com/yuin/gopher-lua;name=gopher-lua;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/yuin/gopher-lua"
59
60SRCREV_go-isatty = "a7c02353c47bc4ec6b30dc9628154ae4fe760c11"
61SRC_URI += "git://github.com/mattn/go-isatty;name=go-isatty;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/mattn/go-isatty"
62
63SRCREV_utfbom = "6ae8f945ca96f30defc7e8ab12ec5d10cf86ded4"
64SRC_URI += "git://github.com/dimchansky/utfbom;name=utfbom;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/dimchansky/utfbom"
65
66SRCREV_go-colorable = "11a925cff3d38c293ddc8c05a16b504e3e2c63be"
67SRC_URI += "git://github.com/mattn/go-colorable;name=go-colorable;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/mattn/go-colorable"
68
69SRCREV_go-toml-v2 = "b730b2be5d3ab7283067ddf61188f41cdf42ce06"
70SRC_URI += "git://github.com/pelletier/go-toml;name=go-toml-v2;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/pelletier/go-toml/v2"
71
72SRCREV_properties = "d8bdba35b511a72d4c00a47e801dc703328198e8"
73SRC_URI += "git://github.com/magiconair/properties;name=properties;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/magiconair/properties"
74
75SRCREV_orderedmap = "9d80274286972e4b495b38de2923a4d5f9758c8d"
76SRC_URI += "git://github.com/elliotchance/orderedmap;name=orderedmap;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/elliotchance/orderedmap"
77
78SRCREV_v2 = "bcbb39153e17f8018257f17aba8eac628d396b64"
79SRC_URI += "git://github.com/alecthomas/participle;name=v2;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/alecthomas/participle/v2"
80
81SRCREV_mousetrap = "4e8053ee7ef85a6bd26368364a6d27f1641c1d21"
82SRC_URI += "git://github.com/inconshreveable/mousetrap;name=mousetrap;protocol=https;nobranch=1;destsuffix=${GO_SRCURI_DESTSUFFIX}/vendor/github.com/inconshreveable/mousetrap"
47 83
48PV = "4.30.8+git${SRCREV_yq}" 84PV = "4.30.8+git${SRCREV_yq}"
85
49GO_IMPORT = "github.com/mikefarah/yq" 86GO_IMPORT = "github.com/mikefarah/yq"
50 87
51inherit go ptest 88inherit go ptest
@@ -65,14 +102,6 @@ do_compile:prepend() {
65 export GO111MODULE=off 102 export GO111MODULE=off
66} 103}
67 104
68do_install:append() {
69 # these bring in dependencies for the -dev package on bash, and we don't
70 # need them .. so we remove them to avoid needing that rdepends
71 rm -rf ${D}/${libdir}/go/src/${GO_IMPORT}/debian/rules
72 rm -rf ${D}/${libdir}/go/src/${GO_IMPORT}/scripts
73 rm -rf ${D}/${libdir}/go/src/${GO_IMPORT}/acceptance_tests
74}
75
76do_install_ptest() { 105do_install_ptest() {
77 install -d ${D}${PTEST_PATH}/tests 106 install -d ${D}${PTEST_PATH}/tests
78 cp -r ${S}/src/github.com/mikefarah/yq/scripts/* ${D}${PTEST_PATH}/tests 107 cp -r ${S}/src/github.com/mikefarah/yq/scripts/* ${D}${PTEST_PATH}/tests
@@ -84,4 +113,8 @@ RDEPENDS:${PN}-ptest += " \
84 bash \ 113 bash \
85" 114"
86 115
116RDEPENDS:${PN}-dev += " \
117 bash \
118"
119
87BBCLASSEXTEND = "native" 120BBCLASSEXTEND = "native"