summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker/docker-moby_git.bb10
-rw-r--r--recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch16
-rw-r--r--recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch22
3 files changed, 25 insertions, 23 deletions
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb
index 0aed206a..19f4763b 100644
--- a/recipes-containers/docker/docker-moby_git.bb
+++ b/recipes-containers/docker/docker-moby_git.bb
@@ -34,14 +34,14 @@ DESCRIPTION = "Linux container runtime \
34# - The common components of this recipe and docker-ce do need to be moved 34# - The common components of this recipe and docker-ce do need to be moved
35# to a docker.inc recipe 35# to a docker.inc recipe
36 36
37SRCREV_moby = "3fd34324a8abc7573fa3b06190a1338263ef1ee7" 37SRCREV_moby = "bc3805a0a0d3b5bd3f0e6c69f46ac08dd53377c7"
38SRCREV_libnetwork = "dcdf8f176d1e13ad719e913e796fb698d846de98" 38SRCREV_libnetwork = "05b93e0d3a95952f70c113b0bc5bdb538d7afdd7"
39SRCREV_cli = "83ca73f9aa7a1c442171ef2602af4d303d9de9c2" 39SRCREV_cli = "a5ee5b1dfc9b8f08ed9e020bb54fc18550173ef6"
40SRCREV_FORMAT = "moby_libnetwork" 40SRCREV_FORMAT = "moby_libnetwork"
41SRC_URI = "\ 41SRC_URI = "\
42 git://github.com/moby/moby.git;branch=23.0;name=moby;protocol=https \ 42 git://github.com/moby/moby.git;branch=23.0;name=moby;protocol=https \
43 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \ 43 git://github.com/docker/libnetwork.git;branch=master;name=libnetwork;destsuffix=git/libnetwork;protocol=https \
44 git://github.com/docker/cli;branch=master;name=cli;destsuffix=git/cli;protocol=https \ 44 git://github.com/docker/cli;branch=23.0;name=cli;destsuffix=git/cli;protocol=https \
45 file://docker.init \ 45 file://docker.init \
46 file://0001-libnetwork-use-GO-instead-of-go.patch \ 46 file://0001-libnetwork-use-GO-instead-of-go.patch \
47 file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ 47 file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \
@@ -56,7 +56,7 @@ require docker.inc
56LICENSE = "Apache-2.0" 56LICENSE = "Apache-2.0"
57LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28" 57LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=4859e97a9c7780e77972d989f0823f28"
58 58
59DOCKER_VERSION = "23.0-beta" 59DOCKER_VERSION = "23.0.1"
60PV = "${DOCKER_VERSION}+git${SRCREV_moby}" 60PV = "${DOCKER_VERSION}+git${SRCREV_moby}"
61 61
62CVE_PRODUCT = "docker mobyproject:moby" 62CVE_PRODUCT = "docker mobyproject:moby"
diff --git a/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch b/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch
index c19d9f50..c10e69d3 100644
--- a/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch
+++ b/recipes-containers/docker/files/0001-dynbinary-use-go-cross-compiler.patch
@@ -14,12 +14,12 @@ Index: git/src/import/hack/make/.binary
14=================================================================== 14===================================================================
15--- git.orig/src/import/hack/make/.binary 15--- git.orig/src/import/hack/make/.binary
16+++ git/src/import/hack/make/.binary 16+++ git/src/import/hack/make/.binary
17@@ -81,7 +81,7 @@ 17@@ -66,7 +66,7 @@
18 if [ -n "$DOCKER_DEBUG" ]; then
19 set -x
20 fi
21- go build -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" ${GO_PACKAGE}
22+ ${GO} build -trimpath -o "$DEST/$BINARY_FULLNAME" "${BUILDFLAGS[@]}" -ldflags "$LDFLAGS $LDFLAGS_STATIC $DOCKER_LDFLAGS" ${GO_PACKAGE}
23 )
18 24
19 echo "Building: $DEST/$BINARY_FULLNAME" 25 echo "Created binary: $DEST/$BINARY_FULLNAME"
20 echo "GOOS=\"${GOOS}\" GOARCH=\"${GOARCH}\" GOARM=\"${GOARM}\""
21- go build \
22+ ${GO} build -trimpath \
23 -o "$DEST/$BINARY_FULLNAME" \
24 "${BUILDFLAGS[@]}" \
25 -ldflags "
diff --git a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
index 10b180b6..f94f73e4 100644
--- a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
+++ b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch
@@ -17,27 +17,29 @@ Index: git/libnetwork/Makefile
17=================================================================== 17===================================================================
18--- git.orig/libnetwork/Makefile 18--- git.orig/libnetwork/Makefile
19+++ git/libnetwork/Makefile 19+++ git/libnetwork/Makefile
20@@ -45,9 +45,9 @@ 20@@ -45,10 +45,10 @@
21 build-local: 21 build-local:
22 @echo "🐳 $@" 22 @echo "🐳 $@"
23 @mkdir -p "bin" 23 @mkdir -p "bin"
24- go build -tags experimental -o "bin/dnet" ./cmd/dnet 24- GO111MODULE=off go build -tags experimental -o "bin/dnet" ./cmd/dnet
25- go build -o "bin/docker-proxy" ./cmd/proxy 25- GO111MODULE=off go build -o "bin/docker-proxy" ./cmd/proxy
26- CGO_ENABLED=0 go build -o "bin/diagnosticClient" ./cmd/diagnostic 26- CGO_ENABLED=0 go build -o "bin/diagnosticClient" ./cmd/diagnostic
27+ $(GO) build -trimpath -tags experimental -o "bin/dnet" ./cmd/dnet 27- CGO_ENABLED=0 go build -o "bin/testMain" ./cmd/networkdb-test/testMain.go
28+ $(GO) build -trimpath -o "bin/proxy" ./cmd/proxy 28+ GO111MODULE=off $(GO) build -trimpath -tags experimental -o "bin/dnet" ./cmd/dnet
29+ GO111MODULE=off $(GO) build -trimpath -o "bin/docker-proxy" ./cmd/proxy
29+ CGO_ENABLED=0 $(GO) build -trimpath -o "bin/diagnosticClient" ./cmd/diagnostic 30+ CGO_ENABLED=0 $(GO) build -trimpath -o "bin/diagnosticClient" ./cmd/diagnostic
30 CGO_ENABLED=0 go build -o "bin/testMain" ./cmd/networkdb-test/testMain.go 31+ CGO_ENABLED=0 $(GO) build -trimpath -o "bin/testMain" ./cmd/networkdb-test/testMain.go
31 32
32 build-images: 33 build-images:
34 @echo "🐳 $@"
33@@ -82,8 +82,8 @@ 35@@ -82,8 +82,8 @@
34 36
35 cross-local: 37 cross-local:
36 @echo "🐳 $@" 38 @echo "🐳 $@"
37- go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet 39- GO111MODULE=off go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet
38- go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy 40- GO111MODULE=off go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy
39+ @$(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy 41+ GO111MODULE=off $(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet
40+ @$(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet 42+ GO111MODULE=off $(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy
41 43
42 # Rebuild protocol buffers. 44 # Rebuild protocol buffers.
43 # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt. 45 # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt.