summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/go/go-distribution-digest_git.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/recipes-devtools/go/go-distribution-digest_git.bb b/recipes-devtools/go/go-distribution-digest_git.bb
index 31d724ce..2a803da5 100644
--- a/recipes-devtools/go/go-distribution-digest_git.bb
+++ b/recipes-devtools/go/go-distribution-digest_git.bb
@@ -13,15 +13,13 @@ SRCREV = "d957768537c5af40e4f4cd96871f7b2bde9e2923"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16do_unpackpost() { 16# NO-OP the do compile rule because this recipe is source only.
17 rm -rf ${S}/[A-KM-Za-ce-z]* ${S}/doc* 17do_compile() {
18} 18}
19 19
20addtask unpackpost after do_unpack before do_patch
21
22do_install() { 20do_install() {
23 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 21 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
24 cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ 22 cp -r ${S}/LICENSE ${S}/digest ${D}${prefix}/local/go/src/${PKG_NAME}/
25} 23}
26 24
27SYSROOT_PREPROCESS_FUNCS += "go_distribution_digeset_sysroot_preprocess" 25SYSROOT_PREPROCESS_FUNCS += "go_distribution_digeset_sysroot_preprocess"