summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/containerd/containerd_git.bb1
-rw-r--r--recipes-containers/runc/runc_git.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/recipes-containers/containerd/containerd_git.bb b/recipes-containers/containerd/containerd_git.bb
index ca99e558..096a164c 100644
--- a/recipes-containers/containerd/containerd_git.bb
+++ b/recipes-containers/containerd/containerd_git.bb
@@ -44,6 +44,7 @@ do_compile() {
44 mkdir -p .gopath/src/"$(dirname "${CONTAINERD_PKG}")" 44 mkdir -p .gopath/src/"$(dirname "${CONTAINERD_PKG}")"
45 ln -sf ../../../.. .gopath/src/"${CONTAINERD_PKG}" 45 ln -sf ../../../.. .gopath/src/"${CONTAINERD_PKG}"
46 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 46 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
47 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
47 cd - 48 cd -
48 49
49 # Pass the needed cflags/ldflags so that cgo 50 # Pass the needed cflags/ldflags so that cgo
diff --git a/recipes-containers/runc/runc_git.bb b/recipes-containers/runc/runc_git.bb
index 905a751b..ed9a32e4 100644
--- a/recipes-containers/runc/runc_git.bb
+++ b/recipes-containers/runc/runc_git.bb
@@ -43,6 +43,7 @@ do_compile() {
43 43
44 (cd .gopath/src/${dname}; ln -sf ../../../../../${bname} ${bname}) 44 (cd .gopath/src/${dname}; ln -sf ../../../../../${bname} ${bname})
45 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 45 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
46 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
46 cd - 47 cd -
47 48
48 # Pass the needed cflags/ldflags so that cgo 49 # Pass the needed cflags/ldflags so that cgo