summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/diod/diod_1.0.24.bb3
-rw-r--r--recipes-extended/diod/files/0001-drod-add-option-to-config-systemddir.patch51
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-extended/diod/diod_1.0.24.bb b/recipes-extended/diod/diod_1.0.24.bb
index bb5707e5..a4a85284 100644
--- a/recipes-extended/diod/diod_1.0.24.bb
+++ b/recipes-extended/diod/diod_1.0.24.bb
@@ -16,9 +16,12 @@ SRC_URI = "git://github.com/chaos/diod.git;protocol=git \
16 file://0001-build-allow-builds-to-work-with-separate-build-dir.patch \ 16 file://0001-build-allow-builds-to-work-with-separate-build-dir.patch \
17 file://0002-auto.diod.in-remove-bashisms.patch \ 17 file://0002-auto.diod.in-remove-bashisms.patch \
18 file://0001-diod-ops.c-add-header-file-for-makedev.patch \ 18 file://0001-diod-ops.c-add-header-file-for-makedev.patch \
19 file://0001-drod-add-option-to-config-systemddir.patch \
19 " 20 "
20DEPENDS = "libcap ncurses tcp-wrappers lua" 21DEPENDS = "libcap ncurses tcp-wrappers lua"
21 22
23EXTRA_OECONF = "--with-systemddir=${systemd_unitdir}/system"
24
22S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
23 26
24inherit autotools systemd 27inherit autotools systemd
diff --git a/recipes-extended/diod/files/0001-drod-add-option-to-config-systemddir.patch b/recipes-extended/diod/files/0001-drod-add-option-to-config-systemddir.patch
new file mode 100644
index 00000000..8b70d8fa
--- /dev/null
+++ b/recipes-extended/diod/files/0001-drod-add-option-to-config-systemddir.patch
@@ -0,0 +1,51 @@
1From 365159534b1981dfe291ecc05d2455f32652a166 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Mon, 26 Aug 2019 18:00:39 +0800
4Subject: [PATCH] drod: add option to config systemddir
5
6Upstream-Status: Pending
7
8Not need to send upstream, since upstream have refactor
9related code, but not released. and this version release
104 years ago, not proper to just backport one or more
11commits, this patch maybe could be dropped after upgrade.
12
13Signed-off-by: Changqing Li <changqing.li@windriver.com>
14---
15 configure.ac | 9 +++++++++
16 scripts/Makefile.am | 2 +-
17 2 files changed, 10 insertions(+), 1 deletion(-)
18
19diff --git a/configure.ac b/configure.ac
20index 1cb8579..3e4a5ec 100644
21--- a/configure.ac
22+++ b/configure.ac
23@@ -25,6 +25,15 @@ AC_DEFINE([_GNU_SOURCE], 1,
24 [Define _GNU_SOURCE so that we get all necessary prototypes])
25
26 ##
27+#Add option to config systemddir
28+##
29+AC_ARG_WITH([systemddir],
30+ [AS_HELP_STRING([--with-systemddir=DIR], [systemd dir])],
31+ [systemddir=$withval],
32+ [systemddir="/lib/systemd/system"])
33+AC_SUBST([systemddir], [$systemddir])
34+
35+##
36 # Checks for programs
37 ##
38 AC_PROG_CC
39diff --git a/scripts/Makefile.am b/scripts/Makefile.am
40index 2aba728..40822b7 100644
41--- a/scripts/Makefile.am
42+++ b/scripts/Makefile.am
43@@ -1,4 +1,4 @@
44-systemddir=/lib/systemd/system
45+systemddir=@systemddir@
46
47 install-data-local:
48 $(top_srcdir)/config/install-sh -m 755 ./auto.diod \
49--
502.7.4
51