summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/nerdctl/nerdctl_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-containers/nerdctl/nerdctl_git.bb b/recipes-containers/nerdctl/nerdctl_git.bb
index 892629fe..4e65405e 100644
--- a/recipes-containers/nerdctl/nerdctl_git.bb
+++ b/recipes-containers/nerdctl/nerdctl_git.bb
@@ -49,6 +49,8 @@ PACKAGECONFIG ?= ""
49# sets the "sites" variable. 49# sets the "sites" variable.
50include relocation.inc 50include relocation.inc
51 51
52PIEFLAG = "${@bb.utils.contains('GOBUILDFLAGS', '-buildmode=pie', '-buildmode=pie', '', d)}"
53
52do_compile() { 54do_compile() {
53 55
54 cd ${S}/src/import 56 cd ${S}/src/import
@@ -62,7 +64,7 @@ do_compile() {
62 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 64 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
63 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 65 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
64 66
65 export GOFLAGS="-mod=vendor -trimpath" 67 export GOFLAGS="-mod=vendor -trimpath ${PIEFLAG}"
66 68
67 # our copied .go files are to be used for the build 69 # our copied .go files are to be used for the build
68 ln -sf vendor.copy vendor 70 ln -sf vendor.copy vendor