diff options
-rw-r--r-- | recipes-containers/docker-distribution/docker-distribution_git.bb | 8 | ||||
-rw-r--r-- | recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch | 21 |
2 files changed, 13 insertions, 16 deletions
diff --git a/recipes-containers/docker-distribution/docker-distribution_git.bb b/recipes-containers/docker-distribution/docker-distribution_git.bb index 3ed91f12..08e5253e 100644 --- a/recipes-containers/docker-distribution/docker-distribution_git.bb +++ b/recipes-containers/docker-distribution/docker-distribution_git.bb | |||
@@ -3,16 +3,16 @@ SUMMARY = "The Docker toolset to pack, ship, store, and deliver content" | |||
3 | LICENSE = "Apache-2.0" | 3 | LICENSE = "Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" |
5 | 5 | ||
6 | SRCREV_distribution= "d607c6ccb9372e05556624f973119a23d3a42987" | 6 | SRCREV_distribution= "f22dd6186008ff9d35f92acc5bc5fd16ba7ef95a" |
7 | SRC_URI = "git://github.com/docker/distribution.git;branch=release/2.8;name=distribution;destsuffix=git/src/github.com/docker/distribution;protocol=https \ | 7 | SRC_URI = "git://github.com/docker/distribution.git;branch=main;name=distribution;destsuffix=git/src/github.com/distribution/distribution/v3;protocol=https \ |
8 | file://docker-registry.service \ | 8 | file://docker-registry.service \ |
9 | file://0001-build-use-to-use-cross-go-compiler.patch \ | 9 | file://0001-build-use-to-use-cross-go-compiler.patch \ |
10 | " | 10 | " |
11 | 11 | ||
12 | PACKAGES =+ "docker-registry" | 12 | PACKAGES =+ "docker-registry" |
13 | 13 | ||
14 | PV = "v2.8.3+git" | 14 | PV = "v3.0.0-beta.1" |
15 | S = "${WORKDIR}/git/src/github.com/docker/distribution" | 15 | S = "${WORKDIR}/git/src/github.com/distribution/distribution/v3" |
16 | 16 | ||
17 | GO_IMPORT = "import" | 17 | GO_IMPORT = "import" |
18 | 18 | ||
diff --git a/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch b/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch index f97a60ca..0f00b998 100644 --- a/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch +++ b/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch | |||
@@ -13,19 +13,16 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
13 | Makefile | 2 +- | 13 | Makefile | 2 +- |
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 14 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/Makefile b/Makefile | 16 | Index: distribution/Makefile |
17 | index 4635c6ec..a95e860e 100644 | 17 | =================================================================== |
18 | --- a/Makefile | 18 | --- distribution.orig/Makefile |
19 | +++ b/Makefile | 19 | +++ distribution/Makefile |
20 | @@ -88,7 +88,7 @@ FORCE: | 20 | @@ -60,7 +60,7 @@ version/version.go: |
21 | # Build a binary from a cmd. | 21 | |
22 | bin/%: cmd/% FORCE | 22 | bin/%: cmd/% FORCE ## build individual binary |
23 | @echo "$(WHALE) $@${BINARY_SUFFIX}" | 23 | @echo "$(WHALE) $@${BINARY_SUFFIX}" |
24 | - @go build ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$< | 24 | - @go build -buildmode=pie ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} --ldflags '-extldflags "-Wl,-z,now" -s' ${GO_TAGS} ./$< |
25 | + @${GO} build ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$< | 25 | + @${GO} build -buildmode=pie ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} --ldflags '-extldflags "-Wl,-z,now" -s' ${GO_TAGS} ./$< |
26 | 26 | ||
27 | binaries: $(BINARIES) ## build binaries | 27 | binaries: $(BINARIES) ## build binaries |
28 | @echo "$(WHALE) $@" | 28 | @echo "$(WHALE) $@" |
29 | -- | ||
30 | 2.19.1 | ||
31 | |||