diff options
26 files changed, 41 insertions, 41 deletions
diff --git a/recipes-containers/container-host-config/container-host-config.bb b/recipes-containers/container-host-config/container-host-config.bb index eb047da9..dc0ae201 100644 --- a/recipes-containers/container-host-config/container-host-config.bb +++ b/recipes-containers/container-host-config/container-host-config.bb | |||
@@ -11,7 +11,7 @@ SRC_URI = " \ | |||
11 | file://policy.json \ | 11 | file://policy.json \ |
12 | " | 12 | " |
13 | 13 | ||
14 | S="${UNPACKDIR}" | 14 | S = "${UNPACKDIR}" |
15 | 15 | ||
16 | do_install() { | 16 | do_install() { |
17 | install -d ${D}/${sysconfdir}/containers | 17 | install -d ${D}/${sysconfdir}/containers |
diff --git a/recipes-containers/cri-tools/cri-tools_git.bb b/recipes-containers/cri-tools/cri-tools_git.bb index d06e34c5..25f13702 100644 --- a/recipes-containers/cri-tools/cri-tools_git.bb +++ b/recipes-containers/cri-tools/cri-tools_git.bb | |||
@@ -36,7 +36,7 @@ inherit go | |||
36 | inherit goarch | 36 | inherit goarch |
37 | inherit pkgconfig | 37 | inherit pkgconfig |
38 | 38 | ||
39 | EXTRA_OEMAKE="BUILDTAGS=''" | 39 | EXTRA_OEMAKE = "BUILDTAGS = ''" |
40 | 40 | ||
41 | do_compile() { | 41 | do_compile() { |
42 | # link fixups for compilation | 42 | # link fixups for compilation |
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb index 8ecc1725..811eb7e3 100644 --- a/recipes-containers/criu/criu_git.bb +++ b/recipes-containers/criu/criu_git.bb | |||
@@ -49,8 +49,8 @@ CFLAGS += " -I${STAGING_INCDIR} -I${STAGING_INCDIR}/libnl3" | |||
49 | CFLAGS:append:arm = " -D__WORDSIZE" | 49 | CFLAGS:append:arm = " -D__WORDSIZE" |
50 | 50 | ||
51 | # overide LDFLAGS to allow criu to build without: "x86_64-poky-linux-ld: unrecognized option '-Wl,-O1'" | 51 | # overide LDFLAGS to allow criu to build without: "x86_64-poky-linux-ld: unrecognized option '-Wl,-O1'" |
52 | export LDFLAGS="" | 52 | export LDFLAGS = "" |
53 | export C_INCLUDE_PATH="${STAGING_INCDIR}/libnl3" | 53 | export C_INCLUDE_PATH = "${STAGING_INCDIR}/libnl3" |
54 | 54 | ||
55 | export BUILD_SYS | 55 | export BUILD_SYS |
56 | export HOST_SYS | 56 | export HOST_SYS |
diff --git a/recipes-containers/docker-compose/docker-compose_git.bb b/recipes-containers/docker-compose/docker-compose_git.bb index 575ee30e..e48ee9af 100644 --- a/recipes-containers/docker-compose/docker-compose_git.bb +++ b/recipes-containers/docker-compose/docker-compose_git.bb | |||
@@ -8,7 +8,7 @@ DEPENDS = " \ | |||
8 | " | 8 | " |
9 | 9 | ||
10 | # Specify the first two important SRCREVs as the format | 10 | # Specify the first two important SRCREVs as the format |
11 | SRCREV_FORMAT="compose_survey" | 11 | SRCREV_FORMAT = "compose_survey" |
12 | SRCREV_compose = "eaf9800948e022573997649656c040a19d4b15c2" | 12 | SRCREV_compose = "eaf9800948e022573997649656c040a19d4b15c2" |
13 | 13 | ||
14 | SRC_URI = "git://github.com/docker/compose;name=compose;branch=main;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX}" | 14 | SRC_URI = "git://github.com/docker/compose;name=compose;branch=main;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX}" |
diff --git a/recipes-containers/docker-distribution/docker-distribution_git.bb b/recipes-containers/docker-distribution/docker-distribution_git.bb index c6e887f1..22e19ef4 100644 --- a/recipes-containers/docker-distribution/docker-distribution_git.bb +++ b/recipes-containers/docker-distribution/docker-distribution_git.bb | |||
@@ -3,7 +3,7 @@ SUMMARY = "The Docker toolset to pack, ship, store, and deliver content" | |||
3 | LICENSE = "Apache-2.0" | 3 | LICENSE = "Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" |
5 | 5 | ||
6 | SRCREV_distribution= "f22dd6186008ff9d35f92acc5bc5fd16ba7ef95a" | 6 | SRCREV_distribution = "f22dd6186008ff9d35f92acc5bc5fd16ba7ef95a" |
7 | SRC_URI = "git://github.com/docker/distribution.git;branch=main;name=distribution;destsuffix=git/src/github.com/distribution/distribution/v3;protocol=https \ | 7 | SRC_URI = "git://github.com/docker/distribution.git;branch=main;name=distribution;destsuffix=git/src/github.com/distribution/distribution/v3;protocol=https \ |
8 | file://docker-registry.service \ | 8 | file://docker-registry.service \ |
9 | file://0001-build-use-to-use-cross-go-compiler.patch \ | 9 | file://0001-build-use-to-use-cross-go-compiler.patch \ |
@@ -20,7 +20,7 @@ inherit goarch go systemd | |||
20 | 20 | ||
21 | # This disables seccomp and apparmor, which are on by default in the | 21 | # This disables seccomp and apparmor, which are on by default in the |
22 | # go package. | 22 | # go package. |
23 | EXTRA_OEMAKE="BUILDTAGS=''" | 23 | EXTRA_OEMAKE = "BUILDTAGS = ''" |
24 | 24 | ||
25 | do_compile() { | 25 | do_compile() { |
26 | export GOARCH="${TARGET_GOARCH}" | 26 | export GOARCH="${TARGET_GOARCH}" |
diff --git a/recipes-containers/docker/docker.inc b/recipes-containers/docker/docker.inc index 3843f3b6..05a14f97 100644 --- a/recipes-containers/docker/docker.inc +++ b/recipes-containers/docker/docker.inc | |||
@@ -50,7 +50,7 @@ do_configure[noexec] = "1" | |||
50 | # Export for possible use in Makefiles, default value comes from go.bbclass | 50 | # Export for possible use in Makefiles, default value comes from go.bbclass |
51 | export GO_LINKSHARED | 51 | export GO_LINKSHARED |
52 | 52 | ||
53 | DOCKER_PKG="github.com/docker/docker" | 53 | DOCKER_PKG = "github.com/docker/docker" |
54 | # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056 | 54 | # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056 |
55 | BUILD_TAGS ?= "exclude_graphdriver_btrfs exclude_graphdriver_devicemapper" | 55 | BUILD_TAGS ?= "exclude_graphdriver_btrfs exclude_graphdriver_devicemapper" |
56 | 56 | ||
diff --git a/recipes-containers/lxc/lxc_git.bb b/recipes-containers/lxc/lxc_git.bb index fe713a0d..63123590 100644 --- a/recipes-containers/lxc/lxc_git.bb +++ b/recipes-containers/lxc/lxc_git.bb | |||
@@ -78,7 +78,7 @@ PACKAGECONFIG[doc] = "-Dman=true,-Dman=false,," | |||
78 | PACKAGECONFIG[apparmor] = "-Dapparmor=true,-Dapparmor=false,apparmor,apparmor" | 78 | PACKAGECONFIG[apparmor] = "-Dapparmor=true,-Dapparmor=false,apparmor,apparmor" |
79 | PACKAGECONFIG[templates] = ",,, ${PN}-templates" | 79 | PACKAGECONFIG[templates] = ",,, ${PN}-templates" |
80 | PACKAGECONFIG[selinux] = "-Dselinux=true,-Dselinux=false,libselinux,libselinux" | 80 | PACKAGECONFIG[selinux] = "-Dselinux=true,-Dselinux=false,libselinux,libselinux" |
81 | PACKAGECONFIG[seccomp] ="-Dseccomp=true,-Dseccomp=false,libseccomp,libseccomp" | 81 | PACKAGECONFIG[seccomp] = "-Dseccomp=true,-Dseccomp=false,libseccomp,libseccomp" |
82 | PACKAGECONFIG[systemd] = "-Dsystemd-unitdir=${sysconfdir}/systemd/system/, -Dsystemd-unitdir=, systemd," | 82 | PACKAGECONFIG[systemd] = "-Dsystemd-unitdir=${sysconfdir}/systemd/system/, -Dsystemd-unitdir=, systemd," |
83 | PACKAGECONFIG[systemd] = "-Dinit-script=systemd,-Dinit-script=sysvinit,systemd," | 83 | PACKAGECONFIG[systemd] = "-Dinit-script=systemd,-Dinit-script=sysvinit,systemd," |
84 | 84 | ||
diff --git a/recipes-containers/nerdctl/nerdctl_git.bb b/recipes-containers/nerdctl/nerdctl_git.bb index 45e17c27..536c470b 100644 --- a/recipes-containers/nerdctl/nerdctl_git.bb +++ b/recipes-containers/nerdctl/nerdctl_git.bb | |||
@@ -10,7 +10,7 @@ DEPENDS = " \ | |||
10 | " | 10 | " |
11 | 11 | ||
12 | # Specify the first two important SRCREVs as the format | 12 | # Specify the first two important SRCREVs as the format |
13 | SRCREV_FORMAT="nerdcli_cgroups" | 13 | SRCREV_FORMAT = "nerdcli_cgroups" |
14 | SRCREV_nerdcli = "497c7cf74d09bf1ddf2678382360ca61e6faebac" | 14 | SRCREV_nerdcli = "497c7cf74d09bf1ddf2678382360ca61e6faebac" |
15 | 15 | ||
16 | SRC_URI = "git://github.com/containerd/nerdctl.git;name=nerdcli;branch=main;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX}" | 16 | SRC_URI = "git://github.com/containerd/nerdctl.git;name=nerdcli;branch=main;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX}" |
diff --git a/recipes-containers/oci-image-tools/oci-image-tools_git.bb b/recipes-containers/oci-image-tools/oci-image-tools_git.bb index ade6534d..c2e07889 100644 --- a/recipes-containers/oci-image-tools/oci-image-tools_git.bb +++ b/recipes-containers/oci-image-tools/oci-image-tools_git.bb | |||
@@ -16,7 +16,7 @@ inherit go | |||
16 | 16 | ||
17 | # This disables seccomp and apparmor, which are on by default in the | 17 | # This disables seccomp and apparmor, which are on by default in the |
18 | # go package. | 18 | # go package. |
19 | EXTRA_OEMAKE="BUILDTAGS=''" | 19 | EXTRA_OEMAKE = "BUILDTAGS=''" |
20 | 20 | ||
21 | S = "${WORKDIR}/git/src/github.com/opencontainers/image-tools" | 21 | S = "${WORKDIR}/git/src/github.com/opencontainers/image-tools" |
22 | 22 | ||
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb index be85e512..dd3e78d9 100644 --- a/recipes-containers/podman/podman_git.bb +++ b/recipes-containers/podman/podman_git.bb | |||
@@ -45,13 +45,13 @@ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \ | |||
45 | exclude_graphdriver_btrfs exclude_graphdriver_devicemapper ${BUILDTAGS_EXTRA}" | 45 | exclude_graphdriver_btrfs exclude_graphdriver_devicemapper ${BUILDTAGS_EXTRA}" |
46 | 46 | ||
47 | # overide LDFLAGS to allow podman to build without: "flag provided but not # defined: -Wl,-O1 | 47 | # overide LDFLAGS to allow podman to build without: "flag provided but not # defined: -Wl,-O1 |
48 | export LDFLAGS="" | 48 | export LDFLAGS = "" |
49 | 49 | ||
50 | # https://github.com/llvm/llvm-project/issues/53999 | 50 | # https://github.com/llvm/llvm-project/issues/53999 |
51 | TOOLCHAIN = "gcc" | 51 | TOOLCHAIN = "gcc" |
52 | 52 | ||
53 | # podmans Makefile expects BUILDFLAGS to be set but go.bbclass defines them in GOBUILDFLAGS | 53 | # podmans Makefile expects BUILDFLAGS to be set but go.bbclass defines them in GOBUILDFLAGS |
54 | export BUILDFLAGS="${GOBUILDFLAGS}" | 54 | export BUILDFLAGS = "${GOBUILDFLAGS}" |
55 | 55 | ||
56 | inherit go goarch | 56 | inherit go goarch |
57 | inherit container-host | 57 | inherit container-host |
diff --git a/recipes-containers/riddler/riddler_git.bb b/recipes-containers/riddler/riddler_git.bb index 3d6581a1..52630563 100644 --- a/recipes-containers/riddler/riddler_git.bb +++ b/recipes-containers/riddler/riddler_git.bb | |||
@@ -22,7 +22,7 @@ COMPATIBLE_HOST:mipsarch = "null" | |||
22 | 22 | ||
23 | # This disables seccomp and apparmor, which are on by default in the | 23 | # This disables seccomp and apparmor, which are on by default in the |
24 | # go package. | 24 | # go package. |
25 | EXTRA_OEMAKE="BUILDTAGS=''" | 25 | EXTRA_OEMAKE = "BUILDTAGS=''" |
26 | 26 | ||
27 | do_compile() { | 27 | do_compile() { |
28 | export GOARCH="${TARGET_GOARCH}" | 28 | export GOARCH="${TARGET_GOARCH}" |
diff --git a/recipes-containers/runc/runc.inc b/recipes-containers/runc/runc.inc index a7c0f618..bcd7f791 100644 --- a/recipes-containers/runc/runc.inc +++ b/recipes-containers/runc/runc.inc | |||
@@ -30,7 +30,7 @@ RPROVIDES:${PN} = "virtual-runc" | |||
30 | 30 | ||
31 | GO_IMPORT = "import" | 31 | GO_IMPORT = "import" |
32 | 32 | ||
33 | LIBCONTAINER_PACKAGE="github.com/opencontainers/runc/libcontainer" | 33 | LIBCONTAINER_PACKAGE = "github.com/opencontainers/runc/libcontainer" |
34 | 34 | ||
35 | do_configure[noexec] = "1" | 35 | do_configure[noexec] = "1" |
36 | 36 | ||
@@ -38,7 +38,7 @@ do_configure[noexec] = "1" | |||
38 | DISTRO_BUILDTAGS ?= "${@bb.utils.contains('DISTRO_FEATURES', 'seccomp', 'seccomp', '', d)} \ | 38 | DISTRO_BUILDTAGS ?= "${@bb.utils.contains('DISTRO_FEATURES', 'seccomp', 'seccomp', '', d)} \ |
39 | ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}" | 39 | ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}" |
40 | 40 | ||
41 | EXTRA_OEMAKE="BUILDTAGS='${PACKAGECONFIG_CONFARGS} ${DISTRO_BUILDTAGS}' GO=${GO}" | 41 | EXTRA_OEMAKE = "BUILDTAGS='${PACKAGECONFIG_CONFARGS} ${DISTRO_BUILDTAGS}' GO=${GO}" |
42 | 42 | ||
43 | do_compile() { | 43 | do_compile() { |
44 | # Set GOPATH. See 'PACKAGERS.md'. Don't rely on | 44 | # Set GOPATH. See 'PACKAGERS.md'. Don't rely on |
diff --git a/recipes-containers/skopeo/skopeo_git.bb b/recipes-containers/skopeo/skopeo_git.bb index bc9abb90..fe8cfa16 100644 --- a/recipes-containers/skopeo/skopeo_git.bb +++ b/recipes-containers/skopeo/skopeo_git.bb | |||
@@ -43,7 +43,7 @@ CVE_STATUS[CVE-2019-10214] = "fixed-version: This CVE was fixed in the container | |||
43 | 43 | ||
44 | # This disables seccomp and apparmor, which are on by default in the | 44 | # This disables seccomp and apparmor, which are on by default in the |
45 | # go package. | 45 | # go package. |
46 | EXTRA_OEMAKE="BUILDTAGS=''" | 46 | EXTRA_OEMAKE = "BUILDTAGS=''" |
47 | 47 | ||
48 | do_compile() { | 48 | do_compile() { |
49 | export GOARCH="${TARGET_GOARCH}" | 49 | export GOARCH="${TARGET_GOARCH}" |
diff --git a/recipes-containers/umoci/umoci_git.bb b/recipes-containers/umoci/umoci_git.bb index 317e1137..84f7a40f 100644 --- a/recipes-containers/umoci/umoci_git.bb +++ b/recipes-containers/umoci/umoci_git.bb | |||
@@ -21,7 +21,7 @@ COMPATIBLE_HOST = "^(?!mips).*" | |||
21 | 21 | ||
22 | # This disables seccomp and apparmor, which are on by default in the | 22 | # This disables seccomp and apparmor, which are on by default in the |
23 | # go package. | 23 | # go package. |
24 | EXTRA_OEMAKE="BUILDTAGS=''" | 24 | EXTRA_OEMAKE = "BUILDTAGS=''" |
25 | 25 | ||
26 | 26 | ||
27 | do_compile:class-native () { | 27 | do_compile:class-native () { |
diff --git a/recipes-core/runx/runx_git.bb b/recipes-core/runx/runx_git.bb index 831360ba..b3250322 100644 --- a/recipes-core/runx/runx_git.bb +++ b/recipes-core/runx/runx_git.bb | |||
@@ -4,8 +4,8 @@ DESCRIPTION = "Xen Runtime for OCI" | |||
4 | 4 | ||
5 | SRCREV_runx = "edc9350a79ede0365066c9743080e3dc6430d602" | 5 | SRCREV_runx = "edc9350a79ede0365066c9743080e3dc6430d602" |
6 | 6 | ||
7 | KERNEL_SRC_VER="linux-5.4" | 7 | KERNEL_SRC_VER = "linux-5.4" |
8 | KERNEL_URL_VER="v5.x" | 8 | KERNEL_URL_VER = "v5.x" |
9 | 9 | ||
10 | SRC_URI = "\ | 10 | SRC_URI = "\ |
11 | git://github.com/lf-edge/runx;nobranch=1;name=runx;protocol=https \ | 11 | git://github.com/lf-edge/runx;nobranch=1;name=runx;protocol=https \ |
diff --git a/recipes-devtools/yq/yq_git.bb b/recipes-devtools/yq/yq_git.bb index a1adfc96..3d0714c7 100644 --- a/recipes-devtools/yq/yq_git.bb +++ b/recipes-devtools/yq/yq_git.bb | |||
@@ -11,7 +11,7 @@ SRCREV_cobra = "b43be995ebb4bee335a787bd44498b91aef7619c" | |||
11 | SRCREV_pflag = "2e9d26c8c37aae03e3f9d4e90b7116f5accb7cab" | 11 | SRCREV_pflag = "2e9d26c8c37aae03e3f9d4e90b7116f5accb7cab" |
12 | SRCREV_logging = "b2cb9fa56473e98db8caba80237377e83fe44db5" | 12 | SRCREV_logging = "b2cb9fa56473e98db8caba80237377e83fe44db5" |
13 | SRCREV_yaml = "f6f7691b1fdeb513f56608cd2c32c51f8194bf51" | 13 | SRCREV_yaml = "f6f7691b1fdeb513f56608cd2c32c51f8194bf51" |
14 | SRCREV_xerrors="65e65417b02f28de84b55f16b46a1e789149973a" | 14 | SRCREV_xerrors = "65e65417b02f28de84b55f16b46a1e789149973a" |
15 | SRCREV_envsubst = "16035fe3571ad42c7796bf554f978bb2df64231b" | 15 | SRCREV_envsubst = "16035fe3571ad42c7796bf554f978bb2df64231b" |
16 | SRCREV_participle = "49f4822ed012d9818c80ca4fcdeb7e2d55c04806" | 16 | SRCREV_participle = "49f4822ed012d9818c80ca4fcdeb7e2d55c04806" |
17 | SRCREV_utfbom = "6ae8f945ca96f30defc7e8ab12ec5d10cf86ded4" | 17 | SRCREV_utfbom = "6ae8f945ca96f30defc7e8ab12ec5d10cf86ded4" |
diff --git a/recipes-extended/ceph/ceph_git.bb b/recipes-extended/ceph/ceph_git.bb index 32da1052..2eaa335a 100644 --- a/recipes-extended/ceph/ceph_git.bb +++ b/recipes-extended/ceph/ceph_git.bb | |||
@@ -18,7 +18,7 @@ SRC_URI = "gitsm://github.com/ceph/ceph.git;protocol=https;branch=main \ | |||
18 | file://0001-rgw-setup.py-allow-incompatible-pointer-types.patch \ | 18 | file://0001-rgw-setup.py-allow-incompatible-pointer-types.patch \ |
19 | " | 19 | " |
20 | 20 | ||
21 | SRCREV= "a53e858fd7cc6fd8c04f37d503ce9ed7080f2da6" | 21 | SRCREV = "a53e858fd7cc6fd8c04f37d503ce9ed7080f2da6" |
22 | PV = "20.0.0+git" | 22 | PV = "20.0.0+git" |
23 | 23 | ||
24 | S = "${WORKDIR}/git" | 24 | S = "${WORKDIR}/git" |
diff --git a/recipes-extended/dev86/dev86_git.bb b/recipes-extended/dev86/dev86_git.bb index 5adf2826..6414ecfb 100644 --- a/recipes-extended/dev86/dev86_git.bb +++ b/recipes-extended/dev86/dev86_git.bb | |||
@@ -4,7 +4,7 @@ LICENSE = "GPL-2.0-only" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" |
5 | SECTION = "console/tools" | 5 | SECTION = "console/tools" |
6 | 6 | ||
7 | BASE_PV="0.16.21" | 7 | BASE_PV = "0.16.21" |
8 | PV = "${BASE_PV}+git" | 8 | PV = "${BASE_PV}+git" |
9 | SRCREV = "e254e0b19651d3b8a20225b40281c9974a95dec4" | 9 | SRCREV = "e254e0b19651d3b8a20225b40281c9974a95dec4" |
10 | SRC_URI = "git://github.com/jbruchon/${BPN}.git;protocol=https;branch=master \ | 10 | SRC_URI = "git://github.com/jbruchon/${BPN}.git;protocol=https;branch=master \ |
diff --git a/recipes-extended/images/container-devtools-base.bb b/recipes-extended/images/container-devtools-base.bb index 12e13fe6..63d40ab7 100644 --- a/recipes-extended/images/container-devtools-base.bb +++ b/recipes-extended/images/container-devtools-base.bb | |||
@@ -2,7 +2,7 @@ SUMMARY = "Basic container image with development tools" | |||
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
4 | 4 | ||
5 | CONTAINER_SHELL="bash" | 5 | CONTAINER_SHELL = "bash" |
6 | 6 | ||
7 | CORE_DEV_IMAGE_EXTRA_INSTALL ?= "" | 7 | CORE_DEV_IMAGE_EXTRA_INSTALL ?= "" |
8 | 8 | ||
diff --git a/recipes-extended/images/xtf-image.bb b/recipes-extended/images/xtf-image.bb index f9ecea91..7b6eadfd 100644 --- a/recipes-extended/images/xtf-image.bb +++ b/recipes-extended/images/xtf-image.bb | |||
@@ -25,7 +25,7 @@ DESCRIPTION = "A minimal Xen Test Framework (XTF) image for testing the Xen hype | |||
25 | # For testimage, see the qemu boot log: ${WORKDIR}/testimage/qemu_boot_log.* | 25 | # For testimage, see the qemu boot log: ${WORKDIR}/testimage/qemu_boot_log.* |
26 | # and the test log: ${WORKDIR}/temp/log.do_testimage | 26 | # and the test log: ${WORKDIR}/temp/log.do_testimage |
27 | 27 | ||
28 | IMAGE_NAME="xtf" | 28 | IMAGE_NAME = "xtf" |
29 | 29 | ||
30 | IMAGE_INSTALL:append = " xtf" | 30 | IMAGE_INSTALL:append = " xtf" |
31 | 31 | ||
diff --git a/recipes-extended/kvmtool/kvmtool_git.bb b/recipes-extended/kvmtool/kvmtool_git.bb index 10f06993..6597873d 100644 --- a/recipes-extended/kvmtool/kvmtool_git.bb +++ b/recipes-extended/kvmtool/kvmtool_git.bb | |||
@@ -21,7 +21,7 @@ PV = "5.10.0+git" | |||
21 | 21 | ||
22 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |
23 | 23 | ||
24 | EXTRA_OEMAKE='V=1 EXTRA_CFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated -I${STAGING_KERNEL_BUILDDIR}/arch/${ARCH}/include/generated"' | 24 | EXTRA_OEMAKE = 'V=1 EXTRA_CFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated -I${STAGING_KERNEL_BUILDDIR}/arch/${ARCH}/include/generated"' |
25 | 25 | ||
26 | do_install() { | 26 | do_install() { |
27 | install -d ${D}${bindir} | 27 | install -d ${D}${bindir} |
diff --git a/recipes-extended/libvirt/libvirt-python.inc b/recipes-extended/libvirt/libvirt-python.inc index 6bf0ddac..20c9f69b 100644 --- a/recipes-extended/libvirt/libvirt-python.inc +++ b/recipes-extended/libvirt/libvirt-python.inc | |||
@@ -25,7 +25,7 @@ SRC_URI[libvirt_python.sha256sum] = "00efb9a781087668512d6a002eb9cd136e44ff8701a | |||
25 | export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml" | 25 | export LIBVIRT_API_PATH = "${S}/docs/libvirt-api.xml" |
26 | export LIBVIRT_CFLAGS = "-I${S}/include" | 26 | export LIBVIRT_CFLAGS = "-I${S}/include" |
27 | export LIBVIRT_LIBS = "-L${B}/src/.libs -lvirt -ldl" | 27 | export LIBVIRT_LIBS = "-L${B}/src/.libs -lvirt -ldl" |
28 | export LDFLAGS="-L${B}/src/.libs" | 28 | export LDFLAGS = "-L${B}/src/.libs" |
29 | 29 | ||
30 | LIBVIRT_INSTALL_ARGS = "--root=${D} \ | 30 | LIBVIRT_INSTALL_ARGS = "--root=${D} \ |
31 | --prefix=${prefix} \ | 31 | --prefix=${prefix} \ |
diff --git a/recipes-extended/rootlesskit/rootlesskit_git.bb b/recipes-extended/rootlesskit/rootlesskit_git.bb index fcc38e7a..f8dd55af 100644 --- a/recipes-extended/rootlesskit/rootlesskit_git.bb +++ b/recipes-extended/rootlesskit/rootlesskit_git.bb | |||
@@ -13,7 +13,7 @@ DEPENDS = " \ | |||
13 | rsync-native \ | 13 | rsync-native \ |
14 | " | 14 | " |
15 | # Specify the first two important SRCREVs as the format | 15 | # Specify the first two important SRCREVs as the format |
16 | SRCREV_FORMAT="rootless" | 16 | SRCREV_FORMAT = "rootless" |
17 | SRCREV_rootless = "530859a92629689c0c17c96d9ab145f4d04b5b5a" | 17 | SRCREV_rootless = "530859a92629689c0c17c96d9ab145f4d04b5b5a" |
18 | 18 | ||
19 | SRC_URI = "git://github.com/rootless-containers/rootlesskit;name=rootless;branch=master;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX}" | 19 | SRC_URI = "git://github.com/rootless-containers/rootlesskit;name=rootless;branch=master;protocol=https;destsuffix=${GO_SRCURI_DESTSUFFIX}" |
diff --git a/recipes-extended/xen/xen-hypervisor.inc b/recipes-extended/xen/xen-hypervisor.inc index 6f3d24d0..347f98f7 100644 --- a/recipes-extended/xen/xen-hypervisor.inc +++ b/recipes-extended/xen/xen-hypervisor.inc | |||
@@ -114,4 +114,4 @@ KCONFIG_CONFIG_ROOTDIR = "${S}/xen" | |||
114 | 114 | ||
115 | # Xen is setting all CC flags on its own. Make sure that they are not modified | 115 | # Xen is setting all CC flags on its own. Make sure that they are not modified |
116 | # for aarch64, e.g. with architecture-specific optimizations. | 116 | # for aarch64, e.g. with architecture-specific optimizations. |
117 | TUNE_CCARGS:aarch64="" | 117 | TUNE_CCARGS:aarch64 = "" |
diff --git a/recipes-extended/xen/xen-tools.inc b/recipes-extended/xen/xen-tools.inc index ec727965..a034bc4c 100644 --- a/recipes-extended/xen/xen-tools.inc +++ b/recipes-extended/xen/xen-tools.inc | |||
@@ -721,14 +721,14 @@ FILES:${PN}-test += "\ | |||
721 | # test-cpu-policy and test-tsx only exist in 4.16 for x86 | 721 | # test-cpu-policy and test-tsx only exist in 4.16 for x86 |
722 | ALLOW_EMPTY:${PN}-test = "1" | 722 | ALLOW_EMPTY:${PN}-test = "1" |
723 | 723 | ||
724 | FILES:${PN}-xen-mceinj +="\ | 724 | FILES:${PN}-xen-mceinj += "\ |
725 | ${sbindir}/xen-mceinj \ | 725 | ${sbindir}/xen-mceinj \ |
726 | " | 726 | " |
727 | 727 | ||
728 | # xen-mceinj is only built for x86 4.16, so allow empty package | 728 | # xen-mceinj is only built for x86 4.16, so allow empty package |
729 | ALLOW_EMPTY:${PN}-xen-mceinj = "1" | 729 | ALLOW_EMPTY:${PN}-xen-mceinj = "1" |
730 | 730 | ||
731 | FILES:${PN}-xen-vmtrace +="\ | 731 | FILES:${PN}-xen-vmtrace += "\ |
732 | ${sbindir}/xen-vmtrace \ | 732 | ${sbindir}/xen-vmtrace \ |
733 | " | 733 | " |
734 | 734 | ||
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc index 63790f73..f8c1e266 100644 --- a/recipes-extended/xen/xen.inc +++ b/recipes-extended/xen/xen.inc | |||
@@ -73,20 +73,20 @@ libexecdir = "${libdir}" | |||
73 | export XEN_OS = "Linux" | 73 | export XEN_OS = "Linux" |
74 | 74 | ||
75 | # this is used for the header (#!${bindir}/python) of the install python scripts | 75 | # this is used for the header (#!${bindir}/python) of the install python scripts |
76 | export PYTHONPATH="${bindir}/env python3" | 76 | export PYTHONPATH = "${bindir}/env python3" |
77 | export ac_cv_path_PYTHONPATH="${bindir}/env python3" | 77 | export ac_cv_path_PYTHONPATH = "${bindir}/env python3" |
78 | export DISTUTILS_BUILD_ARGS | 78 | export DISTUTILS_BUILD_ARGS |
79 | export DISTUTILS_INSTALL_ARGS | 79 | export DISTUTILS_INSTALL_ARGS |
80 | 80 | ||
81 | # xen and seabios require HOSTCC and HOSTCXX set to cross-compile | 81 | # xen and seabios require HOSTCC and HOSTCXX set to cross-compile |
82 | export HOSTCC="${BUILD_CC}" | 82 | export HOSTCC = "${BUILD_CC}" |
83 | export HOSTCXX="${BUILD_CXX}" | 83 | export HOSTCXX = "${BUILD_CXX}" |
84 | 84 | ||
85 | # make xen requires CROSS_COMPILE set by hand as it does not abide by ./configure | 85 | # make xen requires CROSS_COMPILE set by hand as it does not abide by ./configure |
86 | export CROSS_COMPILE="${TARGET_PREFIX}" | 86 | export CROSS_COMPILE = "${TARGET_PREFIX}" |
87 | 87 | ||
88 | # overide LDFLAGS to allow xen to build without: "x86_64-oe-linux-ld: unrecognized option '-Wl,-O1'" | 88 | # overide LDFLAGS to allow xen to build without: "x86_64-oe-linux-ld: unrecognized option '-Wl,-O1'" |
89 | export LDFLAGS="" | 89 | export LDFLAGS = "" |
90 | 90 | ||
91 | # No additional C flags for the main hypervisor build | 91 | # No additional C flags for the main hypervisor build |
92 | EXTRA_CFLAGS_XEN_CORE ?= "" | 92 | EXTRA_CFLAGS_XEN_CORE ?= "" |
@@ -99,7 +99,7 @@ DEBUG_PREFIX_MAP:append = " \ | |||
99 | # - The Xen tools build for x86 systems with HVM-mode enabled includes hvmloader | 99 | # - The Xen tools build for x86 systems with HVM-mode enabled includes hvmloader |
100 | # which fails to build when "-m64" is included in flags set via the | 100 | # which fails to build when "-m64" is included in flags set via the |
101 | # EXTRA_CFLAGS_XEN_TOOLS: so clear TUNE_CCARGS on x86 to prevent that. | 101 | # EXTRA_CFLAGS_XEN_TOOLS: so clear TUNE_CCARGS on x86 to prevent that. |
102 | TUNE_CCARGS:x86-64="" | 102 | TUNE_CCARGS:x86-64 = "" |
103 | 103 | ||
104 | # - Yocto supplies the _FORTIFY_SOURCE flag via CC/CPP/CXX but then passes the | 104 | # - Yocto supplies the _FORTIFY_SOURCE flag via CC/CPP/CXX but then passes the |
105 | # optimization -O via C*FLAGS which is problematic when the CFLAGS are cleared | 105 | # optimization -O via C*FLAGS which is problematic when the CFLAGS are cleared |
@@ -110,11 +110,11 @@ TUNE_CCARGS:x86-64="" | |||
110 | # It must not be compiled with SSE compiler options enabled and the Xen build | 110 | # It must not be compiled with SSE compiler options enabled and the Xen build |
111 | # explicitly clears CFLAGS to ensure that, so such options must not be passed | 111 | # explicitly clears CFLAGS to ensure that, so such options must not be passed |
112 | # in via the tool variable. hvmloader is required to run HVM-mode guest VMs. | 112 | # in via the tool variable. hvmloader is required to run HVM-mode guest VMs. |
113 | CC="${CCACHE}${HOST_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${DEBUG_PREFIX_MAP} ${CC_REPRODUCIBLE_OPTIONS}" | 113 | CC = "${CCACHE}${HOST_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${DEBUG_PREFIX_MAP} ${CC_REPRODUCIBLE_OPTIONS}" |
114 | EXTRA_CFLAGS_XEN_TOOLS="${HOST_CC_ARCH} ${CFLAGS}" | 114 | EXTRA_CFLAGS_XEN_TOOLS = "${HOST_CC_ARCH} ${CFLAGS}" |
115 | # 32-bit ARM needs the TUNE_CCARGS component of HOST_CC_ARCH to be passed | 115 | # 32-bit ARM needs the TUNE_CCARGS component of HOST_CC_ARCH to be passed |
116 | # in CC to ensure that configure can compile binaries for the right arch. | 116 | # in CC to ensure that configure can compile binaries for the right arch. |
117 | CC:arm="${CCACHE}${HOST_PREFIX}gcc ${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS} ${DEBUG_PREFIX_MAP} ${CC_REPRODUCIBLE_OPTIONS}" | 117 | CC:arm = "${CCACHE}${HOST_PREFIX}gcc ${TUNE_CCARGS} ${TOOLCHAIN_OPTIONS} ${DEBUG_PREFIX_MAP} ${CC_REPRODUCIBLE_OPTIONS}" |
118 | 118 | ||
119 | # There are no Xen-provided variables for C++, so append to the tool variables: | 119 | # There are no Xen-provided variables for C++, so append to the tool variables: |
120 | CPP:append = " ${CPPFLAGS}" | 120 | CPP:append = " ${CPPFLAGS}" |