summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/cri-o/cri-o_git.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb
index c178395f..2d971bd7 100644
--- a/recipes-containers/cri-o/cri-o_git.bb
+++ b/recipes-containers/cri-o/cri-o_git.bb
@@ -117,6 +117,16 @@ do_install_ptest() {
117 install -d ${D}${PTEST_PATH}/bin 117 install -d ${D}${PTEST_PATH}/bin
118 cp -rf ${S}/src/import/test ${D}${PTEST_PATH} 118 cp -rf ${S}/src/import/test ${D}${PTEST_PATH}
119 cp -rf ${S}/src/import/bin ${D}${PTEST_PATH} 119 cp -rf ${S}/src/import/bin ${D}${PTEST_PATH}
120 # CRI-O testing changed the default container runtime from runc to crun in version 1.31+.
121 # To maintain compatibility with older tests expecting runc, and to allow for other custom runtimes,
122 # this section explicitly sets CONTAINER_DEFAULT_RUNTIME in the run-ptest script.
123 # The value is determined by the VIRTUAL-RUNTIME_container_runtime variable.
124 if [ "${VIRTUAL-RUNTIME_container_runtime}" = "virtual-runc" ]; then
125 sed -i '/^.\/test\/test_runner/iexport CONTAINER_DEFAULT_RUNTIME=runc' ${D}${PTEST_PATH}/run-ptest
126 else
127 sed -i '/^.\/test\/test_runner/iexport CONTAINER_DEFAULT_RUNTIME=${VIRTUAL-RUNTIME_container_runtime}' ${D}${PTEST_PATH}/run-ptest
128 fi
129
120} 130}
121 131
122FILES:${PN}-config = "${sysconfdir}/crio/config/*" 132FILES:${PN}-config = "${sysconfdir}/crio/config/*"