summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/cri-tools/cri-tools/0001-build-allow-environmental-CGO-settings-and-pass-dont.patch25
-rw-r--r--recipes-containers/cri-tools/cri-tools_git.bb4
2 files changed, 16 insertions, 13 deletions
diff --git a/recipes-containers/cri-tools/cri-tools/0001-build-allow-environmental-CGO-settings-and-pass-dont.patch b/recipes-containers/cri-tools/cri-tools/0001-build-allow-environmental-CGO-settings-and-pass-dont.patch
index 189d905a..2cad7645 100644
--- a/recipes-containers/cri-tools/cri-tools/0001-build-allow-environmental-CGO-settings-and-pass-dont.patch
+++ b/recipes-containers/cri-tools/cri-tools/0001-build-allow-environmental-CGO-settings-and-pass-dont.patch
@@ -1,6 +1,6 @@
1From 28ee02687339b657a7aa93570015a6751c824e2d Mon Sep 17 00:00:00 2001 1From 567b618f2ab9bb722826688d84f328773e4f37ce Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com> 2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Wed, 10 Feb 2021 09:58:24 -0500 3Date: Wed, 17 Aug 2022 11:03:09 -0400
4Subject: [PATCH] build: allow environmental CGO settings and pass 4Subject: [PATCH] build: allow environmental CGO settings and pass
5 dontusecurrentpkgs 5 dontusecurrentpkgs
6 6
@@ -13,9 +13,9 @@ builds (for the most part), and that is not recommended by many
13packages, we end up with errors like: 13packages, we end up with errors like:
14 14
15 1.20.0+gitec9e336fd8c21c4bab89a6aed2c4a138c8cfae75/src/import/_output/crictl \ 15 1.20.0+gitec9e336fd8c21c4bab89a6aed2c4a138c8cfae75/src/import/_output/crictl \
16 -ldflags '-X github.com/kubernetes-sigs/cri-tools/pkg/version.Version=1.20.0' \ 16 -ldflags '-X github.com/kubernetes-sigs/cri-tools/pkg/version.Version=1.20.0' \
17 -tags '' \ 17 -tags '' \
18 github.com/kubernetes-sigs/cri-tools/cmd/crictl 18 github.com/kubernetes-sigs/cri-tools/cmd/crictl
19 # github.com/kubernetes-sigs/cri-tools/cmd/crictl 19 # github.com/kubernetes-sigs/cri-tools/cmd/crictl
20 cannot find package runtime/cgo (using -importcfg) 20 cannot find package runtime/cgo (using -importcfg)
21 /work/cortexa72-poky-linux/cri-tools/1.20.0+gitec9e336fd8c21c4bab89a6aed2c4a138c8cfae75-r0/recipe-sysroot-native/usr/lib/aarch64-poky-linux/go/pkg/tool/linux_amd64/link: 21 /work/cortexa72-poky-linux/cri-tools/1.20.0+gitec9e336fd8c21c4bab89a6aed2c4a138c8cfae75-r0/recipe-sysroot-native/usr/lib/aarch64-poky-linux/go/pkg/tool/linux_amd64/link:
@@ -33,11 +33,11 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
33 src/import/Makefile | 3 ++- 33 src/import/Makefile | 3 ++-
34 1 file changed, 2 insertions(+), 1 deletion(-) 34 1 file changed, 2 insertions(+), 1 deletion(-)
35 35
36Index: cri-tools-1.21.0+gitde32df077e6b0e9e31ce367dfc34c1b6b46e30fa/src/import/Makefile 36diff --git a/src/import/Makefile b/src/import/Makefile
37=================================================================== 37index 7c5b30ec..9b0dfeaf 100644
38--- cri-tools-1.21.0+gitde32df077e6b0e9e31ce367dfc34c1b6b46e30fa.orig/src/import/Makefile 38--- a/src/import/Makefile
39+++ cri-tools-1.21.0+gitde32df077e6b0e9e31ce367dfc34c1b6b46e30fa/src/import/Makefile 39+++ b/src/import/Makefile
40@@ -74,7 +74,8 @@ 40@@ -72,7 +72,8 @@ crictl:
41 @$(MAKE) -B $(CRICTL) 41 @$(MAKE) -B $(CRICTL)
42 42
43 $(CRICTL): 43 $(CRICTL):
@@ -46,4 +46,7 @@ Index: cri-tools-1.21.0+gitde32df077e6b0e9e31ce367dfc34c1b6b46e30fa/src/import/M
46+ -a -pkgdir dontusecurrentpkgs \ 46+ -a -pkgdir dontusecurrentpkgs \
47 -ldflags '$(GO_LDFLAGS)' \ 47 -ldflags '$(GO_LDFLAGS)' \
48 -trimpath \ 48 -trimpath \
49 -tags '$(BUILDTAGS)' \ 49 $(PROJECT)/cmd/crictl
50--
512.19.1
52
diff --git a/recipes-containers/cri-tools/cri-tools_git.bb b/recipes-containers/cri-tools/cri-tools_git.bb
index b789179b..51ecc205 100644
--- a/recipes-containers/cri-tools/cri-tools_git.bb
+++ b/recipes-containers/cri-tools/cri-tools_git.bb
@@ -16,7 +16,7 @@ What is not in scope for this project? \
16 non-exist on the kube-apiserver. \ 16 non-exist on the kube-apiserver. \
17 " 17 "
18 18
19SRCREV_cri-tools = "23f44eaa489ecd8931ee64de08baa7be9dbdb394" 19SRCREV_cri-tools = "77d02a0356e9e1dca58d44e54dd0799e89856387"
20SRC_URI = "\ 20SRC_URI = "\
21 git://github.com/kubernetes-sigs/cri-tools.git;branch=master;name=cri-tools;protocol=https \ 21 git://github.com/kubernetes-sigs/cri-tools.git;branch=master;name=cri-tools;protocol=https \
22 file://0001-build-allow-environmental-CGO-settings-and-pass-dont.patch \ 22 file://0001-build-allow-environmental-CGO-settings-and-pass-dont.patch \
@@ -27,7 +27,7 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c2
27 27
28GO_IMPORT = "import" 28GO_IMPORT = "import"
29 29
30PV = "1.23.0+git${SRCREV_cri-tools}" 30PV = "1.24.2+git${SRCREV_cri-tools}"
31 31
32RPROVIDES:${PN} += "crictl" 32RPROVIDES:${PN} += "crictl"
33PACKAGES =+ "${PN}-critest" 33PACKAGES =+ "${PN}-critest"