summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/docker/docker-ce_git.bb2
-rw-r--r--recipes-containers/docker/docker-moby_git.bb2
-rw-r--r--recipes-containers/docker/docker.inc4
3 files changed, 6 insertions, 2 deletions
diff --git a/recipes-containers/docker/docker-ce_git.bb b/recipes-containers/docker/docker-ce_git.bb
index bfe4f909..0e34bb61 100644
--- a/recipes-containers/docker/docker-ce_git.bb
+++ b/recipes-containers/docker/docker-ce_git.bb
@@ -45,6 +45,8 @@ SRC_URI = "\
45 file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \ 45 file://0001-cli-use-external-GO111MODULE-and-cross-compiler.patch \
46 " 46 "
47 47
48DOCKER_COMMIT = "${SRCREV_docker}"
49
48require docker.inc 50require docker.inc
49 51
50# Apache-2.0 for docker 52# Apache-2.0 for docker
diff --git a/recipes-containers/docker/docker-moby_git.bb b/recipes-containers/docker/docker-moby_git.bb
index 2bd930c6..f2599cf3 100644
--- a/recipes-containers/docker/docker-moby_git.bb
+++ b/recipes-containers/docker/docker-moby_git.bb
@@ -48,6 +48,8 @@ SRC_URI = "\
48 file://0001-dynbinary-use-go-cross-compiler.patch \ 48 file://0001-dynbinary-use-go-cross-compiler.patch \
49 " 49 "
50 50
51DOCKER_COMMIT = "${SRCREV_moby}"
52
51require docker.inc 53require docker.inc
52 54
53# Apache-2.0 for docker 55# Apache-2.0 for docker
diff --git a/recipes-containers/docker/docker.inc b/recipes-containers/docker/docker.inc
index b74b4123..2487456e 100644
--- a/recipes-containers/docker/docker.inc
+++ b/recipes-containers/docker/docker.inc
@@ -97,14 +97,14 @@ do_compile() {
97 # this is the unsupported built structure 97 # this is the unsupported built structure
98 # that doesn't rely on an existing docker 98 # that doesn't rely on an existing docker
99 # to build this: 99 # to build this:
100 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_moby}" ./hack/make.sh dynbinary 100 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${DOCKER_COMMIT}" ./hack/make.sh dynbinary
101 101
102 # build the cli 102 # build the cli
103 cd ${S}/src/import/.gopath/src/github.com/docker/cli 103 cd ${S}/src/import/.gopath/src/github.com/docker/cli
104 export CFLAGS="" 104 export CFLAGS=""
105 export LDFLAGS="" 105 export LDFLAGS=""
106 export DOCKER_VERSION=${DOCKER_VERSION} 106 export DOCKER_VERSION=${DOCKER_VERSION}
107 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${SRCREV_moby}" make dynbinary 107 VERSION="${DOCKER_VERSION}" DOCKER_GITCOMMIT="${DOCKER_COMMIT}" make dynbinary
108 108
109 # build the proxy 109 # build the proxy
110 cd ${S}/src/import/.gopath/src/github.com/docker/libnetwork 110 cd ${S}/src/import/.gopath/src/github.com/docker/libnetwork