summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-containers/lxc/lxc_2.0.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-containers/lxc/lxc_2.0.0.bb b/recipes-containers/lxc/lxc_2.0.0.bb
index 250ac4d9..c98d1a7f 100644
--- a/recipes-containers/lxc/lxc_2.0.0.bb
+++ b/recipes-containers/lxc/lxc_2.0.0.bb
@@ -65,6 +65,7 @@ PACKAGECONFIG[templates] = ",,, ${PN}-templates"
65PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux" 65PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
66PACKAGECONFIG[seccomp] ="--enable-seccomp,--disable-seccomp,libseccomp,libseccomp" 66PACKAGECONFIG[seccomp] ="--enable-seccomp,--disable-seccomp,libseccomp,libseccomp"
67PACKAGECONFIG[python] = "--enable-python,--disable-python,python3,python3-core" 67PACKAGECONFIG[python] = "--enable-python,--disable-python,python3,python3-core"
68PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua,lua"
68 69
69# required by python3 to run setup.py 70# required by python3 to run setup.py
70export BUILD_SYS 71export BUILD_SYS
@@ -86,6 +87,9 @@ FILES_${PN}-doc = "${mandir} ${infodir}"
86# For LXC the docdir only contains example configuration files and should be included in the lxc package 87# For LXC the docdir only contains example configuration files and should be included in the lxc package
87FILES_${PN} += "${docdir}" 88FILES_${PN} += "${docdir}"
88FILES_${PN} += "${libdir}/python3*" 89FILES_${PN} += "${libdir}/python3*"
90FILES_${PN} += "${datadir}/lua/*"
91FILES_${PN} += "${libdir}/lua/lxc/*"
92FILES_${PN}-dbg += "${libdir}/lua/lxc/.debug"
89FILES_${PN}-dbg += "${libexecdir}/lxc/.debug ${libexecdir}/lxc/hooks/.debug" 93FILES_${PN}-dbg += "${libexecdir}/lxc/.debug ${libexecdir}/lxc/hooks/.debug"
90PACKAGES =+ "${PN}-templates ${PN}-setup ${PN}-networking" 94PACKAGES =+ "${PN}-templates ${PN}-setup ${PN}-networking"
91FILES_${PN}-templates += "${datadir}/lxc/templates" 95FILES_${PN}-templates += "${datadir}/lxc/templates"