diff options
8 files changed, 16 insertions, 223 deletions
diff --git a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch deleted file mode 100644 index 96e907d5..00000000 --- a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch +++ /dev/null | |||
@@ -1,64 +0,0 @@ | |||
1 | From d79dcc2002008c58683de82f06c168d6eea57991 Mon Sep 17 00:00:00 2001 | ||
2 | From: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> | ||
3 | Date: Fri, 19 Oct 2018 11:01:37 +0200 | ||
4 | Subject: [PATCH] python,pygrub: pass DISTUTILS env vars as setup.py args | ||
5 | |||
6 | Allow to respect the target install dir (PYTHON_SITEPACKAGES_DIR) | ||
7 | as well as other parameters set by the OpenEmbedded build system. | ||
8 | This is especially useful when the target libdir is not the default one | ||
9 | (/usr/lib), but for example /usr/lib64. | ||
10 | |||
11 | Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> | ||
12 | |||
13 | Forward-ported to Xen 4.12.0 | ||
14 | Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> | ||
15 | |||
16 | Modified to support pygrub installation with python 3 | ||
17 | Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> | ||
18 | |||
19 | diff --git a/tools/pygrub/Makefile b/tools/pygrub/Makefile | ||
20 | index 3063c49..513314b 100644 | ||
21 | --- a/tools/pygrub/Makefile | ||
22 | +++ b/tools/pygrub/Makefile | ||
23 | @@ -10,14 +10,17 @@ INSTALL_LOG = build/installed_files.txt | ||
24 | all: build | ||
25 | .PHONY: build | ||
26 | build: | ||
27 | - CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) setup.py build | ||
28 | + CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) setup.py build $(DISTUTILS_BUILD_ARGS) | ||
29 | |||
30 | .PHONY: install | ||
31 | install: all | ||
32 | $(INSTALL_DIR) $(DESTDIR)/$(bindir) | ||
33 | CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) \ | ||
34 | setup.py install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \ | ||
35 | - --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force | ||
36 | + --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force \ | ||
37 | + $(DISTUTILS_INSTALL_ARGS) | ||
38 | + rm -f $(DESTDIR)/$(LIBEXEC_BIN)/pygrub | ||
39 | + $(INSTALL_PYTHON_PROG) src/pygrub $(DESTDIR)/$(LIBEXEC_BIN)/pygrub | ||
40 | set -e; if [ $(bindir) != $(LIBEXEC_BIN) -a \ | ||
41 | "`readlink -f $(DESTDIR)/$(bindir)`" != \ | ||
42 | "`readlink -f $(LIBEXEC_BIN)`" ]; then \ | ||
43 | diff --git a/tools/python/Makefile b/tools/python/Makefile | ||
44 | index 541858e..4d4a344 100644 | ||
45 | --- a/tools/python/Makefile | ||
46 | +++ b/tools/python/Makefile | ||
47 | @@ -10,7 +10,7 @@ INSTALL_LOG = build/installed_files.txt | ||
48 | |||
49 | .PHONY: build | ||
50 | build: | ||
51 | - CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build | ||
52 | + CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build $(DISTUTILS_BUILD_ARGS) | ||
53 | |||
54 | .PHONY: install | ||
55 | install: | ||
56 | @@ -18,7 +18,7 @@ install: | ||
57 | |||
58 | CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) \ | ||
59 | setup.py install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \ | ||
60 | - --root="$(DESTDIR)" --force | ||
61 | + --root="$(DESTDIR)" --force $(DISTUTILS_INSTALL_ARGS) | ||
62 | |||
63 | $(INSTALL_PROG) scripts/convert-legacy-stream $(DESTDIR)$(LIBEXEC_BIN) | ||
64 | $(INSTALL_PROG) scripts/verify-stream-v2 $(DESTDIR)$(LIBEXEC_BIN) | ||
diff --git a/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch b/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch deleted file mode 100644 index ba97c4bc..00000000 --- a/recipes-extended/xen/files/0001-xen-build-temporarily-inhibit-Werror.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | From 9cff3bf8425ccc593825fcde8ca5eaa32a43d04d Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Thu, 18 Jun 2020 09:05:22 -0400 | ||
4 | Subject: [PATCH] xen/build: temporarily inhibit Werror | ||
5 | |||
6 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
7 | Rebased on Xen 4.13: | ||
8 | Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> | ||
9 | --- | ||
10 | tools/libxl/Makefile | 2 +- | ||
11 | xen/Rules.mk | 2 +- | ||
12 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/tools/libxl/Makefile b/tools/libxl/Makefile | ||
15 | index 6da342ed61..c67560e269 100644 | ||
16 | --- a/tools/libxl/Makefile | ||
17 | +++ b/tools/libxl/Makefile | ||
18 | @@ -14,7 +14,7 @@ MINOR = 0 | ||
19 | XLUMAJOR = 4.13 | ||
20 | XLUMINOR = 0 | ||
21 | |||
22 | -CFLAGS += -Werror -Wno-format-zero-length -Wmissing-declarations \ | ||
23 | +CFLAGS += -Wno-format-zero-length -Wmissing-declarations \ | ||
24 | -Wno-declaration-after-statement -Wformat-nonliteral | ||
25 | CFLAGS += -I. -fPIC | ||
26 | |||
27 | diff --git a/xen/Rules.mk b/xen/Rules.mk | ||
28 | index a151b3f625..a05ceec1e5 100644 | ||
29 | --- a/xen/Rules.mk | ||
30 | +++ b/xen/Rules.mk | ||
31 | @@ -54,7 +54,7 @@ CFLAGS += -fomit-frame-pointer | ||
32 | endif | ||
33 | |||
34 | CFLAGS += -nostdinc -fno-builtin -fno-common | ||
35 | -CFLAGS += -Werror -Wredundant-decls -Wno-pointer-arith | ||
36 | +CFLAGS += -Wredundant-decls -Wno-pointer-arith | ||
37 | $(call cc-option-add,CFLAGS,CC,-Wvla) | ||
38 | CFLAGS += -pipe -D__XEN__ -include $(BASEDIR)/include/xen/config.h | ||
39 | CFLAGS-$(CONFIG_DEBUG_INFO) += -g | ||
40 | -- | ||
41 | 2.19.1 | ||
42 | |||
diff --git a/recipes-extended/xen/files/xen-tools-kdd-fix-build-again.patch b/recipes-extended/xen/files/xen-tools-kdd-fix-build-again.patch deleted file mode 100644 index 61229997..00000000 --- a/recipes-extended/xen/files/xen-tools-kdd-fix-build-again.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | From d44cbbe0f3243afcc56e47dcfa97bbfe23e46fbb Mon Sep 17 00:00:00 2001 | ||
2 | From: Wei Liu <wl@xen.org> | ||
3 | Date: Fri, 3 Jul 2020 20:10:01 +0000 | ||
4 | Subject: [PATCH] kdd: fix build again | ||
5 | |||
6 | Restore Tim's patch. The one that was committed was recreated by me | ||
7 | because git didn't accept my saved copy. I made some mistakes while | ||
8 | recreating that patch and here we are. | ||
9 | |||
10 | Fixes: 3471cafbdda3 ("kdd: stop using [0] arrays to access packet contents") | ||
11 | Reported-by: Michael Young <m.a.young@durham.ac.uk> | ||
12 | Signed-off-by: Wei Liu <wl@xen.org> | ||
13 | Reviewed-by: Tim Deegan <tim@xen.org> | ||
14 | Release-acked-by: Paul Durrant <paul@xen.org> | ||
15 | --- | ||
16 | tools/debugger/kdd/kdd.c | 4 ++-- | ||
17 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
18 | |||
19 | diff --git a/tools/debugger/kdd/kdd.c b/tools/debugger/kdd/kdd.c | ||
20 | index 866532f0c7..a7d0976ea4 100644 | ||
21 | --- a/tools/debugger/kdd/kdd.c | ||
22 | +++ b/tools/debugger/kdd/kdd.c | ||
23 | @@ -79,11 +79,11 @@ typedef struct { | ||
24 | /* State of the debugger stub */ | ||
25 | typedef struct { | ||
26 | union { | ||
27 | - uint8_t txb[sizeof (kdd_hdr)]; /* Marshalling area for tx */ | ||
28 | + uint8_t txb[sizeof (kdd_pkt)]; /* Marshalling area for tx */ | ||
29 | kdd_pkt txp; /* Also readable as a packet structure */ | ||
30 | }; | ||
31 | union { | ||
32 | - uint8_t rxb[sizeof (kdd_hdr)]; /* Marshalling area for rx */ | ||
33 | + uint8_t rxb[sizeof (kdd_pkt)]; /* Marshalling area for rx */ | ||
34 | kdd_pkt rxp; /* Also readable as a packet structure */ | ||
35 | }; | ||
36 | unsigned int cur; /* Offset into rx where we'll put the next byte */ | ||
37 | -- | ||
38 | 2.17.1 | ||
39 | |||
diff --git a/recipes-extended/xen/files/xen-tools-kdd-stop-using-0-arrays-to-access-packet-contents.patch b/recipes-extended/xen/files/xen-tools-kdd-stop-using-0-arrays-to-access-packet-contents.patch deleted file mode 100644 index c1b110df..00000000 --- a/recipes-extended/xen/files/xen-tools-kdd-stop-using-0-arrays-to-access-packet-contents.patch +++ /dev/null | |||
@@ -1,60 +0,0 @@ | |||
1 | From 3471cafbdda35eacf04670881dd2aee2558b4f08 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Deegan <tim@xen.org> | ||
3 | Date: Fri, 26 Jun 2020 10:40:44 +0000 | ||
4 | Subject: [PATCH] kdd: stop using [0] arrays to access packet contents | ||
5 | |||
6 | GCC 10 is unhappy about this, and we already use 64k buffers | ||
7 | in the only places where packets are allocated, so move the | ||
8 | 64k size into the packet definition. | ||
9 | |||
10 | Reported-by: Olaf Hering <olaf@aepfle.de> | ||
11 | Signed-off-by: Tim Deegan <tim@xen.org> | ||
12 | Acked-by: Wei Liu <wl@xen.org> | ||
13 | Release-acked-by: Paul Durrant <paul@xen.org> | ||
14 | --- | ||
15 | tools/debugger/kdd/kdd.c | 4 ++-- | ||
16 | tools/debugger/kdd/kdd.h | 3 +-- | ||
17 | 2 files changed, 3 insertions(+), 4 deletions(-) | ||
18 | |||
19 | diff --git a/tools/debugger/kdd/kdd.c b/tools/debugger/kdd/kdd.c | ||
20 | index 3ebda9b12c..866532f0c7 100644 | ||
21 | --- a/tools/debugger/kdd/kdd.c | ||
22 | +++ b/tools/debugger/kdd/kdd.c | ||
23 | @@ -79,11 +79,11 @@ typedef struct { | ||
24 | /* State of the debugger stub */ | ||
25 | typedef struct { | ||
26 | union { | ||
27 | - uint8_t txb[sizeof (kdd_hdr) + 65536]; /* Marshalling area for tx */ | ||
28 | + uint8_t txb[sizeof (kdd_hdr)]; /* Marshalling area for tx */ | ||
29 | kdd_pkt txp; /* Also readable as a packet structure */ | ||
30 | }; | ||
31 | union { | ||
32 | - uint8_t rxb[sizeof (kdd_hdr) + 65536]; /* Marshalling area for rx */ | ||
33 | + uint8_t rxb[sizeof (kdd_hdr)]; /* Marshalling area for rx */ | ||
34 | kdd_pkt rxp; /* Also readable as a packet structure */ | ||
35 | }; | ||
36 | unsigned int cur; /* Offset into rx where we'll put the next byte */ | ||
37 | diff --git a/tools/debugger/kdd/kdd.h b/tools/debugger/kdd/kdd.h | ||
38 | index bfb00ba5c5..b9a17440df 100644 | ||
39 | --- a/tools/debugger/kdd/kdd.h | ||
40 | +++ b/tools/debugger/kdd/kdd.h | ||
41 | @@ -68,7 +68,6 @@ typedef struct { | ||
42 | uint16_t len; /* Payload length, excl. header and trailing byte */ | ||
43 | uint32_t id; /* Echoed in responses */ | ||
44 | uint32_t sum; /* Unsigned sum of all payload bytes */ | ||
45 | - uint8_t payload[0]; | ||
46 | } PACKED kdd_hdr; | ||
47 | |||
48 | #define KDD_PKT_CMD 0x0002 /* Debugger commands (and replies to them) */ | ||
49 | @@ -323,7 +322,7 @@ typedef struct { | ||
50 | kdd_msg msg; | ||
51 | kdd_reg reg; | ||
52 | kdd_stc stc; | ||
53 | - uint8_t payload[0]; | ||
54 | + uint8_t payload[65536]; | ||
55 | }; | ||
56 | } PACKED kdd_pkt; | ||
57 | |||
58 | -- | ||
59 | 2.17.1 | ||
60 | |||
diff --git a/recipes-extended/xen/xen-tools_4.14.bb b/recipes-extended/xen/xen-tools_4.14.bb index ef40c850..4119190d 100644 --- a/recipes-extended/xen/xen-tools_4.14.bb +++ b/recipes-extended/xen/xen-tools_4.14.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | SRCREV ?= "02d69864b51a4302a148c28d6d391238a6778b4b" | 1 | SRCREV ?= "456957aaa1391e0dfa969e2dd97b87c51a79444e" |
2 | 2 | ||
3 | XEN_REL ?= "4.14" | 3 | XEN_REL ?= "4.14" |
4 | XEN_BRANCH ?= "stable-${XEN_REL}" | 4 | XEN_BRANCH ?= "stable-${XEN_REL}" |
@@ -15,7 +15,5 @@ PV = "${XEN_REL}+stable${SRCPV}" | |||
15 | 15 | ||
16 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
17 | 17 | ||
18 | DEFAULT_PREFERENCE ??= "-1" | ||
19 | |||
20 | require xen.inc | 18 | require xen.inc |
21 | require xen-tools.inc | 19 | require xen-tools.inc |
diff --git a/recipes-extended/xen/xen-tools_git.bb b/recipes-extended/xen/xen-tools_git.bb index 679feb11..71aeeed8 100644 --- a/recipes-extended/xen/xen-tools_git.bb +++ b/recipes-extended/xen/xen-tools_git.bb | |||
@@ -1,21 +1,21 @@ | |||
1 | SRCREV ?= "9f7e8bac4ca279b3bfccb5f3730fb2e5398c95ab" | 1 | SRCREV ?= "8c4532f19d6925538fb0c938f7de9a97da8c5c3b" |
2 | 2 | ||
3 | XEN_REL ?= "4.13" | 3 | XEN_REL ?= "4.15" |
4 | XEN_BRANCH ?= "stable-${XEN_REL}" | 4 | XEN_BRANCH ?= "master" |
5 | 5 | ||
6 | SRC_URI = " \ | 6 | SRC_URI = " \ |
7 | git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ | 7 | git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ |
8 | file://0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch \ | 8 | file://0001-python-pygrub-pass-DISTUTILS-xen-4.14.patch \ |
9 | file://0001-xen-build-temporarily-inhibit-Werror.patch \ | 9 | file://0001-xen-build-temporarily-inhibit-Werror-4.14.patch \ |
10 | file://xen-tools-kdd-stop-using-0-arrays-to-access-packet-contents.patch \ | ||
11 | file://xen-tools-kdd-fix-build-again.patch \ | ||
12 | " | 10 | " |
13 | 11 | ||
14 | LIC_FILES_CHKSUM ?= "file://COPYING;md5=4295d895d4b5ce9d070263d52f030e49" | 12 | LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5" |
15 | 13 | ||
16 | PV = "${XEN_REL}+git${SRCPV}" | 14 | PV = "${XEN_REL}+git${SRCPV}" |
17 | 15 | ||
18 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
19 | 17 | ||
18 | DEFAULT_PREFERENCE ??= "-1" | ||
19 | |||
20 | require xen.inc | 20 | require xen.inc |
21 | require xen-tools.inc | 21 | require xen-tools.inc |
diff --git a/recipes-extended/xen/xen_4.14.bb b/recipes-extended/xen/xen_4.14.bb index 02af2a7f..0413bee1 100644 --- a/recipes-extended/xen/xen_4.14.bb +++ b/recipes-extended/xen/xen_4.14.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | SRCREV ?= "02d69864b51a4302a148c28d6d391238a6778b4b" | 1 | SRCREV ?= "456957aaa1391e0dfa969e2dd97b87c51a79444e" |
2 | 2 | ||
3 | XEN_REL ?= "4.14" | 3 | XEN_REL ?= "4.14" |
4 | XEN_BRANCH ?= "stable-${XEN_REL}" | 4 | XEN_BRANCH ?= "stable-${XEN_REL}" |
@@ -14,7 +14,5 @@ PV = "${XEN_REL}+stable${SRCPV}" | |||
14 | 14 | ||
15 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
16 | 16 | ||
17 | DEFAULT_PREFERENCE ??= "-1" | ||
18 | |||
19 | require xen.inc | 17 | require xen.inc |
20 | require xen-hypervisor.inc | 18 | require xen-hypervisor.inc |
diff --git a/recipes-extended/xen/xen_git.bb b/recipes-extended/xen/xen_git.bb index 7765ed74..408bc3b3 100644 --- a/recipes-extended/xen/xen_git.bb +++ b/recipes-extended/xen/xen_git.bb | |||
@@ -1,18 +1,20 @@ | |||
1 | SRCREV ?= "9f7e8bac4ca279b3bfccb5f3730fb2e5398c95ab" | 1 | SRCREV ?= "8c4532f19d6925538fb0c938f7de9a97da8c5c3b" |
2 | 2 | ||
3 | XEN_REL ?= "4.13" | 3 | XEN_REL ?= "4.15" |
4 | XEN_BRANCH ?= "stable-${XEN_REL}" | 4 | XEN_BRANCH ?= "master" |
5 | 5 | ||
6 | SRC_URI = " \ | 6 | SRC_URI = " \ |
7 | git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ | 7 | git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ |
8 | file://xen-arm64-implement-atomic-fetch-add.patch \ | 8 | file://xen-arm64-implement-atomic-fetch-add.patch \ |
9 | " | 9 | " |
10 | 10 | ||
11 | LIC_FILES_CHKSUM ?= "file://COPYING;md5=4295d895d4b5ce9d070263d52f030e49" | 11 | LIC_FILES_CHKSUM ?= "file://COPYING;md5=419739e325a50f3d7b4501338e44a4e5" |
12 | 12 | ||
13 | PV = "${XEN_REL}+git${SRCPV}" | 13 | PV = "${XEN_REL}+git${SRCPV}" |
14 | 14 | ||
15 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
16 | 16 | ||
17 | DEFAULT_PREFERENCE ??= "-1" | ||
18 | |||
17 | require xen.inc | 19 | require xen.inc |
18 | require xen-hypervisor.inc | 20 | require xen-hypervisor.inc |