summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/raspberrypi
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/raspberrypi')
-rw-r--r--dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend
new file mode 100644
index 00000000..85d6febe
--- /dev/null
+++ b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -0,0 +1,10 @@
1# For a Xen-enabled distro on the Raspberry Pi, override the contents of cmdline.txt
2# with Xen-on-ARM-specific command line options
3
4DEFAULT_CMDLINE := "${CMDLINE}"
5XEN_LINUX_CMDLINE ?= "console=hvc0 clk_ignore_unused earlycon=xenboot debug root=/dev/mmcblk0p2 rootwait"
6CMDLINE = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', '${XEN_LINUX_CMDLINE}', '${DEFAULT_CMDLINE}', d)}"
7
8KBRANCH_raspberrypi4-64 = "standard/bcm-2xxx-rpi"
9KMACHINE_raspberrypi4-64 = "bcm-2xxx-rpi4"
10COMPATIBLE_MACHINE_raspberrypi4-64 = "(raspberrypi4-64)"