summaryrefslogtreecommitdiffstats
path: root/recipes-containers/containerd/containerd-opencontainers/0001-Add-build-option-GODEBUG-1.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/containerd/containerd-opencontainers/0001-Add-build-option-GODEBUG-1.patch')
-rw-r--r--recipes-containers/containerd/containerd-opencontainers/0001-Add-build-option-GODEBUG-1.patch28
1 files changed, 9 insertions, 19 deletions
diff --git a/recipes-containers/containerd/containerd-opencontainers/0001-Add-build-option-GODEBUG-1.patch b/recipes-containers/containerd/containerd-opencontainers/0001-Add-build-option-GODEBUG-1.patch
index 05c4f153..8b43c8a0 100644
--- a/recipes-containers/containerd/containerd-opencontainers/0001-Add-build-option-GODEBUG-1.patch
+++ b/recipes-containers/containerd/containerd-opencontainers/0001-Add-build-option-GODEBUG-1.patch
@@ -15,28 +15,18 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
15 src/import/Makefile | 8 ++++++-- 15 src/import/Makefile | 8 ++++++--
16 1 file changed, 6 insertions(+), 2 deletions(-) 16 1 file changed, 6 insertions(+), 2 deletions(-)
17 17
18diff --git a/src/import/Makefile b/src/import/Makefile 18Index: git/src/import/Makefile
19index 4355395..4fb5d3b 100644 19===================================================================
20--- a/src/import/Makefile 20--- git.orig/src/import/Makefile 2020-10-12 08:09:41.638977052 -0700
21+++ b/src/import/Makefile 21+++ git/src/import/Makefile 2020-10-12 08:10:49.783074373 -0700
22@@ -75,11 +75,15 @@ TEST_REQUIRES_ROOT_PACKAGES=$(filter \ 22@@ -72,6 +72,10 @@
23 COMMANDS=ctr containerd containerd-stress 23 COMMANDS=ctr containerd containerd-stress
24 MANPAGES=ctr.1 containerd.1 containerd-config.1 containerd-config.toml.5 24 MANPAGES=ctr.8 containerd.8 containerd-config.8 containerd-config.toml.5
25 25
26+ifndef GODEBUG 26+ifndef GODEBUG
27+ EXTRA_LDFLAGS += -s -w 27+ EXTRA_LDFLAGS += -s -w
28+endif 28+endif
29+ 29+
30 # Build tags seccomp and apparmor are needed by CRI plugin. 30 ifdef BUILDTAGS
31 BUILDTAGS ?= seccomp apparmor 31 GO_BUILDTAGS = ${BUILDTAGS}
32 GO_TAGS=$(if $(BUILDTAGS),-tags "$(BUILDTAGS)",) 32 endif
33-GO_LDFLAGS=-ldflags '-s -w -X $(PKG)/version.Version=$(VERSION) -X $(PKG)/version.Revision=$(REVISION) -X $(PKG)/version.Package=$(PACKAGE) $(EXTRA_LDFLAGS)'
34-SHIM_GO_LDFLAGS=-ldflags '-s -w -X $(PKG)/version.Version=$(VERSION) -X $(PKG)/version.Revision=$(REVISION) -X $(PKG)/version.Package=$(PACKAGE) -extldflags "-static"'
35+GO_LDFLAGS=-ldflags '-X $(PKG)/version.Version=$(VERSION) -X $(PKG)/version.Revision=$(REVISION) -X $(PKG)/version.Package=$(PACKAGE) $(EXTRA_LDFLAGS)'
36+SHIM_GO_LDFLAGS=-ldflags '-X $(PKG)/version.Version=$(VERSION) -X $(PKG)/version.Revision=$(REVISION) -X $(PKG)/version.Package=$(PACKAGE) -extldflags "-static" $(EXTRA_LDFLAGS)'
37
38 #Replaces ":" (*nix), ";" (windows) with newline for easy parsing
39 GOPATHS=$(shell echo ${GOPATH} | tr ":" "\n" | tr ";" "\n")
40--
412.7.4
42