diff options
Diffstat (limited to 'recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch')
-rw-r--r-- | recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | 58 |
1 files changed, 58 insertions, 0 deletions
diff --git a/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch new file mode 100644 index 00000000..54835ff1 --- /dev/null +++ b/recipes-containers/docker-compose/files/0001-setup.py-remove-maximum-version-requirements.patch | |||
@@ -0,0 +1,58 @@ | |||
1 | From 2685716409c560cdf94aee6262ed8c32ad137133 Mon Sep 17 00:00:00 2001 | ||
2 | From: Chen Qi <Qi.Chen@windriver.com> | ||
3 | Date: Fri, 22 Nov 2019 09:24:58 +0800 | ||
4 | Subject: [PATCH] setup.py: remove maximum version requirements | ||
5 | |||
6 | Remove maximum version requirements so that docker-compose will not | ||
7 | require old version recipes. | ||
8 | |||
9 | Upstream-Status: Inappropriate [OE Specific] | ||
10 | |||
11 | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> | ||
12 | --- | ||
13 | setup.py | 22 +++++++++++----------- | ||
14 | 1 file changed, 11 insertions(+), 11 deletions(-) | ||
15 | |||
16 | diff --git a/setup.py b/setup.py | ||
17 | index 422ba54..c2b4556 100644 | ||
18 | --- a/setup.py | ||
19 | +++ b/setup.py | ||
20 | @@ -30,16 +30,16 @@ def find_version(*file_paths): | ||
21 | |||
22 | |||
23 | install_requires = [ | ||
24 | - 'cached-property >= 1.2.0, < 2', | ||
25 | - 'docopt >= 0.6.1, < 0.7', | ||
26 | - 'PyYAML >= 3.10, < 4', | ||
27 | - 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.19', | ||
28 | - 'texttable >= 0.9.0, < 0.10', | ||
29 | - 'websocket-client >= 0.32.0, < 1.0', | ||
30 | - 'docker >= 3.3.0, < 4.0', | ||
31 | - 'dockerpty >= 0.4.1, < 0.5', | ||
32 | - 'six >= 1.3.0, < 2', | ||
33 | - 'jsonschema >= 2.5.1, < 3', | ||
34 | + 'cached-property >= 1.2.0', | ||
35 | + 'docopt >= 0.6.1', | ||
36 | + 'PyYAML >= 3.10', | ||
37 | + 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0', | ||
38 | + 'texttable >= 0.9.0', | ||
39 | + 'websocket-client >= 0.32.0', | ||
40 | + 'docker >= 3.3.0', | ||
41 | + 'dockerpty >= 0.4.1', | ||
42 | + 'six >= 1.3.0', | ||
43 | + 'jsonschema >= 2.5.1', | ||
44 | ] | ||
45 | |||
46 | |||
47 | @@ -56,7 +56,7 @@ extras_require = { | ||
48 | ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'], | ||
49 | ':python_version < "3.3"': ['ipaddress >= 1.0.16'], | ||
50 | ':sys_platform == "win32"': ['colorama >= 0.3.9, < 0.4'], | ||
51 | - 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'], | ||
52 | + 'socks': ['PySocks >= 1.5.6, != 1.5.7'], | ||
53 | } | ||
54 | |||
55 | |||
56 | -- | ||
57 | 2.17.1 | ||
58 | |||