summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb')
-rw-r--r--recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb b/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb
new file mode 100644
index 00000000..36e24171
--- /dev/null
+++ b/recipes-containers/docker-compose/python3-docker-compose_1.25.0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Multi-container orchestration for Docker"
2HOMEPAGE = "https://www.docker.com/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
5
6inherit pypi setuptools3
7
8SRC_URI[md5sum] = "275b32cffdad6b9816dc8b4c7e55600a"
9SRC_URI[sha256sum] = "2c5fcbfd3ff445b6f3eebb549cb167ef1d8f70c5806aab8f309fc8fa74cd977e"
10
11SRC_URI += "file://0001-setup.py-remove-maximum-version-requirements.patch"
12
13RDEPENDS_${PN} = "\
14 ${PYTHON_PN}-cached-property \
15 ${PYTHON_PN}-certifi \
16 ${PYTHON_PN}-chardet \
17 ${PYTHON_PN}-colorama \
18 ${PYTHON_PN}-docker \
19 ${PYTHON_PN}-docker-pycreds \
20 ${PYTHON_PN}-dockerpty \
21 ${PYTHON_PN}-docopt \
22 ${PYTHON_PN}-fcntl \
23 ${PYTHON_PN}-idna \
24 ${PYTHON_PN}-jsonschema \
25 ${PYTHON_PN}-misc \
26 ${PYTHON_PN}-paramiko \
27 ${PYTHON_PN}-pyyaml \
28 ${PYTHON_PN}-requests \
29 ${PYTHON_PN}-six \
30 ${PYTHON_PN}-terminal \
31 ${PYTHON_PN}-texttable \
32 ${PYTHON_PN}-urllib3 \
33 ${PYTHON_PN}-websocket-client \
34"