diff options
Diffstat (limited to 'recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch')
-rw-r--r-- | recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch | 21 |
1 files changed, 9 insertions, 12 deletions
diff --git a/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch b/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch index f97a60ca..0f00b998 100644 --- a/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch +++ b/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch | |||
@@ -13,19 +13,16 @@ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | |||
13 | Makefile | 2 +- | 13 | Makefile | 2 +- |
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 14 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/Makefile b/Makefile | 16 | Index: distribution/Makefile |
17 | index 4635c6ec..a95e860e 100644 | 17 | =================================================================== |
18 | --- a/Makefile | 18 | --- distribution.orig/Makefile |
19 | +++ b/Makefile | 19 | +++ distribution/Makefile |
20 | @@ -88,7 +88,7 @@ FORCE: | 20 | @@ -60,7 +60,7 @@ version/version.go: |
21 | # Build a binary from a cmd. | 21 | |
22 | bin/%: cmd/% FORCE | 22 | bin/%: cmd/% FORCE ## build individual binary |
23 | @echo "$(WHALE) $@${BINARY_SUFFIX}" | 23 | @echo "$(WHALE) $@${BINARY_SUFFIX}" |
24 | - @go build ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$< | 24 | - @go build -buildmode=pie ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} --ldflags '-extldflags "-Wl,-z,now" -s' ${GO_TAGS} ./$< |
25 | + @${GO} build ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$< | 25 | + @${GO} build -buildmode=pie ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} --ldflags '-extldflags "-Wl,-z,now" -s' ${GO_TAGS} ./$< |
26 | 26 | ||
27 | binaries: $(BINARIES) ## build binaries | 27 | binaries: $(BINARIES) ## build binaries |
28 | @echo "$(WHALE) $@" | 28 | @echo "$(WHALE) $@" |
29 | -- | ||
30 | 2.19.1 | ||
31 | |||