diff options
Diffstat (limited to 'recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch')
-rw-r--r-- | recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch index d4f84e30..b9b41de5 100644 --- a/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch +++ b/recipes-containers/docker/files/0001-libnetwork-use-GO-instead-of-go.patch | |||
@@ -34,8 +34,8 @@ Index: git/libnetwork/Makefile | |||
34 | @echo "🐳 $@" | 34 | @echo "🐳 $@" |
35 | - go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet | 35 | - go build -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet |
36 | - go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy | 36 | - go build -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy |
37 | + @$(GO) build -trimpath -linkshared $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy | 37 | + @$(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/docker-proxy-$$GOOS-$$GOARCH" ./cmd/proxy |
38 | + @$(GO) build -trimpath -linkshared $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet | 38 | + @$(GO) build -trimpath $(GO_LINKSHARED) $(GOBUILDFLAGS) -o "bin/dnet-$$GOOS-$$GOARCH" ./cmd/dnet |
39 | 39 | ||
40 | # Rebuild protocol buffers. | 40 | # Rebuild protocol buffers. |
41 | # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt. | 41 | # These may need to be rebuilt after vendoring updates, so .proto files are declared .PHONY so they are always rebuilt. |