summaryrefslogtreecommitdiffstats
path: root/recipes-containers/lxcfs/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-containers/lxcfs/files')
-rw-r--r--recipes-containers/lxcfs/files/systemd-allow-for-distinct-build-directory.patch49
-rw-r--r--recipes-containers/lxcfs/files/systemd-ensure-var-lib-lxcfs-exists.patch26
2 files changed, 0 insertions, 75 deletions
diff --git a/recipes-containers/lxcfs/files/systemd-allow-for-distinct-build-directory.patch b/recipes-containers/lxcfs/files/systemd-allow-for-distinct-build-directory.patch
deleted file mode 100644
index 4d93cc3e..00000000
--- a/recipes-containers/lxcfs/files/systemd-allow-for-distinct-build-directory.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1From 66a71fbf94020651880f1dbb6e4663d93391b47c Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Mon, 10 Sep 2018 13:14:07 -0400
4Subject: [PATCH] systemd: allow for distinct build directory
5
6The Makefile.am is currently written in a way that doesn't allow for a
7distinct build directory. As such we get the error:
8
9 install: cannot stat 'lxcfs.service': No such file or directory
10
11Make use of $(srcdir) to correct this.
12
13Upstream-Status: Inappropriate [embedded specific]
14
15Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
16---
17 config/init/systemd/Makefile.am | 2 +-
18 config/init/systemd/Makefile.in | 2 +-
19 2 files changed, 2 insertions(+), 2 deletions(-)
20
21diff --git a/config/init/systemd/Makefile.am b/config/init/systemd/Makefile.am
22index 79e96f5..d6933f9 100644
23--- a/config/init/systemd/Makefile.am
24+++ b/config/init/systemd/Makefile.am
25@@ -5,7 +5,7 @@ SYSTEMD_UNIT_DIR = /lib/systemd/system
26
27 install-systemd: lxcfs.service
28 $(MKDIR_P) $(DESTDIR)$(SYSTEMD_UNIT_DIR)
29- $(INSTALL_DATA) lxcfs.service $(DESTDIR)$(SYSTEMD_UNIT_DIR)/
30+ $(INSTALL_DATA) $(srcdir)/lxcfs.service $(DESTDIR)$(SYSTEMD_UNIT_DIR)/
31
32 uninstall-systemd:
33 rm -f $(DESTDIR)$(SYSTEMD_UNIT_DIR)/lxcfs.service
34diff --git a/config/init/systemd/Makefile.in b/config/init/systemd/Makefile.in
35index d433e8a..430190c 100644
36--- a/config/init/systemd/Makefile.in
37+++ b/config/init/systemd/Makefile.in
38@@ -450,7 +450,7 @@ uninstall-am: uninstall-local
39
40 @INIT_SCRIPT_SYSTEMD_TRUE@install-systemd: lxcfs.service
41 @INIT_SCRIPT_SYSTEMD_TRUE@ $(MKDIR_P) $(DESTDIR)$(SYSTEMD_UNIT_DIR)
42-@INIT_SCRIPT_SYSTEMD_TRUE@ $(INSTALL_DATA) lxcfs.service $(DESTDIR)$(SYSTEMD_UNIT_DIR)/
43+@INIT_SCRIPT_SYSTEMD_TRUE@ $(INSTALL_DATA) $(srcdir)/lxcfs.service $(DESTDIR)$(SYSTEMD_UNIT_DIR)/
44
45 @INIT_SCRIPT_SYSTEMD_TRUE@uninstall-systemd:
46 @INIT_SCRIPT_SYSTEMD_TRUE@ rm -f $(DESTDIR)$(SYSTEMD_UNIT_DIR)/lxcfs.service
47--
482.7.4
49
diff --git a/recipes-containers/lxcfs/files/systemd-ensure-var-lib-lxcfs-exists.patch b/recipes-containers/lxcfs/files/systemd-ensure-var-lib-lxcfs-exists.patch
deleted file mode 100644
index 9f6f338d..00000000
--- a/recipes-containers/lxcfs/files/systemd-ensure-var-lib-lxcfs-exists.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1From 89bf4b64e810e174068e7861490e6d6ab2d14854 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Mon, 10 Sep 2018 15:01:54 -0400
4Subject: [PATCH] systemd: ensure /var/lib/lxcfs exists
5
6If the directory doesn't exist the service will fail to start.
7
8Upstream-Status: Inappropriate [embedded specific]
9
10Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
11---
12 config/init/systemd/lxcfs.service | 1 +
13 1 file changed, 1 insertion(+)
14
15Index: lxcfs-4.0.7/config/init/systemd/lxcfs.service
16===================================================================
17--- lxcfs-4.0.7.orig/config/init/systemd/lxcfs.service
18+++ lxcfs-4.0.7/config/init/systemd/lxcfs.service
19@@ -5,6 +5,7 @@
20 Documentation=man:lxcfs(1)
21
22 [Service]
23+ExecStartPre=-/bin/mkdir /var/lib/lxcfs
24 ExecStart=/usr/bin/lxcfs /usr/local/var/lib/lxcfs
25 KillMode=process
26 Restart=on-failure