diff options
Diffstat (limited to 'recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch')
-rw-r--r-- | recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch | 53 |
1 files changed, 0 insertions, 53 deletions
diff --git a/recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch b/recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch deleted file mode 100644 index 9c6c124c..00000000 --- a/recipes-containers/riddler/files/0001-build-use-to-select-cross-compiler.patch +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | From 8ca4391a5954db168d513ba64c3791f63b044fbf Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Tue, 30 Jun 2020 23:58:22 -0400 | ||
4 | Subject: [PATCH] build: use to select cross compiler | ||
5 | |||
6 | Upstream-Status: Inappropriate [embedded specific] | ||
7 | |||
8 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
9 | --- | ||
10 | git/Makefile | 10 +++++----- | ||
11 | 1 file changed, 5 insertions(+), 5 deletions(-) | ||
12 | |||
13 | diff --git git/Makefile git/Makefile | ||
14 | index c6976af..f3c8d17 100644 | ||
15 | --- git/Makefile | ||
16 | +++ git/Makefile | ||
17 | @@ -10,11 +10,11 @@ all: clean build static fmt lint test vet | ||
18 | |||
19 | build: | ||
20 | @echo "+ $@" | ||
21 | - @go build -tags "$(BUILDTAGS) cgo" . | ||
22 | + @${GO} build ${GOBUILDFLAGS} -tags "$(BUILDTAGS) cgo" . | ||
23 | |||
24 | static: | ||
25 | @echo "+ $@" | ||
26 | - CGO_ENABLED=1 go build -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static" -o riddler . | ||
27 | + CGO_ENABLED=1 ${GO} build ${GOBUILDFLAGS} -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static" -o riddler . | ||
28 | |||
29 | fmt: | ||
30 | @echo "+ $@" | ||
31 | @@ -26,11 +26,11 @@ lint: | ||
32 | |||
33 | test: fmt lint vet | ||
34 | @echo "+ $@" | ||
35 | - @go test -v -tags "$(BUILDTAGS) cgo" $(shell go list ./... | grep -v vendor) | ||
36 | + @${GO} test -v -tags "$(BUILDTAGS) cgo" $(shell go list ./... | grep -v vendor) | ||
37 | |||
38 | vet: | ||
39 | @echo "+ $@" | ||
40 | - @go vet $(shell go list ./... | grep -v vendor) | ||
41 | + @${GO} vet $(shell go list ./... | grep -v vendor) | ||
42 | |||
43 | clean: | ||
44 | @echo "+ $@" | ||
45 | @@ -38,4 +38,4 @@ clean: | ||
46 | |||
47 | install: | ||
48 | @echo "+ $@" | ||
49 | - @go install -v . | ||
50 | + @${GO} install -v . | ||
51 | -- | ||
52 | 2.19.1 | ||
53 | |||