diff options
Diffstat (limited to 'recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch')
-rw-r--r-- | recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch b/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch new file mode 100644 index 00000000..36d45b57 --- /dev/null +++ b/recipes-devtools/go/go-build/0001-build-use-instead-of-go.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 4db28c98481056c41097f808335c37e8517fe485 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Fri, 7 Aug 2020 23:39:18 -0400 | ||
4 | Subject: [PATCH] build: use instead of 'go' | ||
5 | |||
6 | While we can get away with 'go' if the host/target arch match, the | ||
7 | new go-binary toolchain blows up in a cross compile situation. | ||
8 | |||
9 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
10 | --- | ||
11 | gobuild/Makefile | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/src/import/gobuild/Makefile b/src/import/gobuild/Makefile | ||
15 | index 694d9ce..149d573 100644 | ||
16 | --- a/src/import/gobuild/Makefile | ||
17 | +++ b/src/import/gobuild/Makefile | ||
18 | @@ -19,10 +19,10 @@ dep: ${GODEPPATHS} | ||
19 | |||
20 | ${GODEPPATHS}: | ||
21 | mkdir -p ${GOSRC} | ||
22 | - GOPATH=${GOPATH} go get $(subst ${GOSRC}/,,$@) | ||
23 | + GOPATH=${GOPATH} ${GO} get $(subst ${GOSRC}/,,$@) | ||
24 | |||
25 | ${BIN}: ${GODEPPATHS} $(filter %/$@.go, ${MAIN}) | ||
26 | - GOPATH=${GOPATH} ${ARCH} go build $(filter %/$@.go, ${MAIN}) | ||
27 | + GOPATH=${GOPATH} ${ARCH} ${GO} build $(filter %/$@.go, ${MAIN}) | ||
28 | |||
29 | clean: | ||
30 | rm -f ${BIN} | ||
31 | -- | ||
32 | 2.19.1 | ||
33 | |||