diff options
Diffstat (limited to 'recipes-devtools/go/go-cli_git.bb')
-rw-r--r-- | recipes-devtools/go/go-cli_git.bb | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-devtools/go/go-cli_git.bb b/recipes-devtools/go/go-cli_git.bb new file mode 100644 index 00000000..ef37357b --- /dev/null +++ b/recipes-devtools/go/go-cli_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "A small package for building command line apps in Go" | ||
2 | HOMEPAGE = "https://github.com/codegangsta/cli" | ||
3 | SECTION = "devel/go" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ed9b539ed65d73926f30ff1f1587dc44" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "cli" | ||
9 | |||
10 | PKG_NAME = "github.com/codegangsta/${SRCNAME}" | ||
11 | SRC_URI = "git://${PKG_NAME}.git" | ||
12 | |||
13 | SRCREV = "27ecc97192df1bf053a22b04463f2b51b8b8373e" | ||
14 | PV = "1.1.0+git${SRCREV}" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} | ||
20 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ | ||
21 | } | ||
22 | |||
23 | SYSROOT_PREPROCESS_FUNCS += "go_cli_sysroot_preprocess" | ||
24 | |||
25 | go_cli_sysroot_preprocess () { | ||
26 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} | ||
27 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) | ||
28 | } | ||
29 | |||
30 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" | ||