summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-requests_2.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-requests_2.3.0.bb')
-rw-r--r--recipes-devtools/python/python-requests_2.3.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-requests_2.3.0.bb b/recipes-devtools/python/python-requests_2.3.0.bb
new file mode 100644
index 00000000..6f38bf1c
--- /dev/null
+++ b/recipes-devtools/python/python-requests_2.3.0.bb
@@ -0,0 +1,29 @@
1HOMEPAGE = "http://python-requests.org"
2SUMMARY = "Python HTTP for Humans."
3DESCRIPTION = "\
4 Requests is an Apache2 Licensed HTTP library, written in Python, \
5 for human beings. \
6 . \
7 Most existing Python modules for sending HTTP requests are extremely \
8 verbose and cumbersome. Python's builtin urllib2 module provides most \
9 of the HTTP capabilities you should need, but the api is thoroughly \
10 broken. It requires an enormous amount of work (even method overrides) \
11 to perform the simplest of tasks. \
12 . \
13 Things shouldn't be this way. Not in Python \
14 "
15SECTION = "devel/python"
16LICENSE = "Apache-2.0"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=c7869e52c8275537186de35e3cd5f9ec"
18
19PR = "r0"
20SRCNAME = "requests"
21
22SRC_URI = "http://pypi.python.org/packages/source/r/requests/${SRCNAME}-${PV}.tar.gz"
23
24SRC_URI[md5sum] = "7449ffdc8ec9ac37bbcd286003c80f00"
25SRC_URI[sha256sum] = "1c1473875d846fe563d70868acf05b1953a4472f4695b7b3566d1d978957b8fc"
26
27S = "${WORKDIR}/${SRCNAME}-${PV}"
28
29inherit setuptools