summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-docker_4.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-docker_4.4.1.bb')
-rw-r--r--recipes-devtools/python/python3-docker_4.4.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-docker_4.4.1.bb b/recipes-devtools/python/python3-docker_4.4.1.bb
new file mode 100644
index 00000000..3ab01823
--- /dev/null
+++ b/recipes-devtools/python/python3-docker_4.4.1.bb
@@ -0,0 +1,19 @@
1SUMMARY = "A Python library for the Docker Engine API."
2HOMEPAGE = "https://github.com/docker/docker-py"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
5
6SRC_URI[md5sum] = "0a4aa9efd059a65d58fefa37e5ad84c3"
7SRC_URI[sha256sum] = "0604a74719d5d2de438753934b755bfcda6f62f49b8e4b30969a4b0a2a8a1220"
8
9DEPENDS += "${PYTHON_PN}-pip-native"
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-misc \
13 ${PYTHON_PN}-six \
14 ${PYTHON_PN}-docker-pycreds \
15 ${PYTHON_PN}-requests \
16 ${PYTHON_PN}-websocket-client \
17"
18
19inherit pypi setuptools3