summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-docker_7.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python3-docker_7.0.0.bb')
-rw-r--r--recipes-devtools/python/python3-docker_7.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-docker_7.0.0.bb b/recipes-devtools/python/python3-docker_7.0.0.bb
new file mode 100644
index 00000000..ada94876
--- /dev/null
+++ b/recipes-devtools/python/python3-docker_7.0.0.bb
@@ -0,0 +1,20 @@
1SUMMARY = "A Python library for the Docker Engine API."
2HOMEPAGE = "https://github.com/docker/docker-py"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
5
6SRC_URI[md5sum] = "b08eeccf6a5efd11c316c08207edfeef"
7SRC_URI[sha256sum] = "323736fb92cd9418fc5e7133bc953e11a9da04f4483f828b527db553f1e7e5a3"
8
9DEPENDS += "${PYTHON_PN}-pip-native"
10DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-misc \
14 ${PYTHON_PN}-six \
15 ${PYTHON_PN}-docker-pycreds \
16 ${PYTHON_PN}-requests \
17 ${PYTHON_PN}-websocket-client \
18 ${PYTHON_PN}-packaging \
19"
20inherit pypi python_setuptools_build_meta