diff options
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r-- | recipes-devtools/python/python-twisted.inc | 244 | ||||
-rw-r--r-- | recipes-devtools/python/python3-twisted_13.2.0.bb | 67 |
2 files changed, 0 insertions, 311 deletions
diff --git a/recipes-devtools/python/python-twisted.inc b/recipes-devtools/python/python-twisted.inc deleted file mode 100644 index d734e03b..00000000 --- a/recipes-devtools/python/python-twisted.inc +++ /dev/null | |||
@@ -1,244 +0,0 @@ | |||
1 | DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \ | ||
2 | Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \ | ||
3 | (including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more." | ||
4 | HOMEPAGE = "http://www.twistedmatrix.com" | ||
5 | |||
6 | #twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL. | ||
7 | LICENSE = "MIT" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5602d7228daf59a16f0f1b2640c46bca" | ||
9 | |||
10 | SRC_URI[md5sum] = "83fe6c0c911cc1602dbffb036be0ba79" | ||
11 | SRC_URI[sha256sum] = "095175638c019ac7c0604f4c291724a16ff1acd062e181b01293bf4dcbc62cf3" | ||
12 | |||
13 | PYPI_PACKAGE = "Twisted" | ||
14 | PYPI_PACKAGE_EXT = "tar.bz2" | ||
15 | |||
16 | do_install_append() { | ||
17 | # remove some useless files before packaging | ||
18 | find ${D} \( -name "*.bat" -o -name "*.c" -o -name "*.h" \) -exec rm -f {} \; | ||
19 | } | ||
20 | |||
21 | PACKAGES += "\ | ||
22 | ${PN}-zsh \ | ||
23 | ${PN}-test \ | ||
24 | ${PN}-protocols \ | ||
25 | ${PN}-conch \ | ||
26 | ${PN}-lore \ | ||
27 | ${PN}-mail \ | ||
28 | ${PN}-names \ | ||
29 | ${PN}-news \ | ||
30 | ${PN}-runner \ | ||
31 | ${PN}-web \ | ||
32 | ${PN}-words \ | ||
33 | ${PN}-flow \ | ||
34 | ${PN}-pair \ | ||
35 | ${PN}-core \ | ||
36 | " | ||
37 | |||
38 | PACKAGES =+ "\ | ||
39 | ${PN}-src \ | ||
40 | ${PN}-bin \ | ||
41 | " | ||
42 | |||
43 | RDEPENDS_${PN} = "\ | ||
44 | ${PN}-bin \ | ||
45 | ${PN}-conch \ | ||
46 | ${PN}-lore \ | ||
47 | ${PN}-mail \ | ||
48 | ${PN}-names \ | ||
49 | ${PN}-news \ | ||
50 | ${PN}-runner \ | ||
51 | ${PN}-web \ | ||
52 | ${PN}-words \ | ||
53 | " | ||
54 | |||
55 | RDEPENDS_${PN}-core = "python-core python-zopeinterface python-contextlib" | ||
56 | RDEPENDS_${PN}-test = "${PN}" | ||
57 | RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols" | ||
58 | RDEPENDS_${PN}-lore = "${PN}-core" | ||
59 | RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols" | ||
60 | RDEPENDS_${PN}-names = "${PN}-core" | ||
61 | RDEPENDS_${PN}-news = "${PN}-core ${PN}-protocols" | ||
62 | RDEPENDS_${PN}-runner = "${PN}-core ${PN}-protocols" | ||
63 | RDEPENDS_${PN}-web += "${PN}-core ${PN}-protocols" | ||
64 | RDEPENDS_${PN}-words += "${PN}-core" | ||
65 | RDEPENDS_${PN}-flow += "${PN}-core" | ||
66 | RDEPENDS_${PN}-pair += "${PN}-core" | ||
67 | RDEPENDS_${PN}-dbg = "${PN}" | ||
68 | |||
69 | ALLOW_EMPTY_${PN} = "1" | ||
70 | FILES_${PN} = "" | ||
71 | |||
72 | FILES_${PN}-test = " \ | ||
73 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \ | ||
74 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \ | ||
75 | " | ||
76 | |||
77 | FILES_${PN}-protocols = " \ | ||
78 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/*.py* \ | ||
79 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/gps/ \ | ||
80 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/mice/ \ | ||
81 | " | ||
82 | |||
83 | FILES_${PN}-zsh = " \ | ||
84 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \ | ||
85 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \ | ||
86 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/twisted-completion.zsh \ | ||
87 | " | ||
88 | |||
89 | FILES_${PN}-conch = " \ | ||
90 | ${bindir}/ckeygen \ | ||
91 | ${bindir}/tkconch \ | ||
92 | ${bindir}/conch \ | ||
93 | ${bindir}/conchftp \ | ||
94 | ${bindir}/cftp \ | ||
95 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \ | ||
96 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \ | ||
97 | " | ||
98 | |||
99 | FILES_${PN}-core = " \ | ||
100 | ${bindir}/manhole \ | ||
101 | ${bindir}/mktap \ | ||
102 | ${bindir}/twistd \ | ||
103 | ${bindir}/tap2deb \ | ||
104 | ${bindir}/tap2rpm \ | ||
105 | ${bindir}/tapconvert \ | ||
106 | ${bindir}/tkmktap \ | ||
107 | ${bindir}/trial \ | ||
108 | ${bindir}/easy_install* \ | ||
109 | ${bindir}/pyhtmlizer \ | ||
110 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.so \ | ||
111 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \ | ||
112 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \ | ||
113 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \ | ||
114 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \ | ||
115 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \ | ||
116 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \ | ||
117 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \ | ||
118 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \ | ||
119 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \ | ||
120 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \ | ||
121 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \ | ||
122 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \ | ||
123 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/application \ | ||
124 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \ | ||
125 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \ | ||
126 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \ | ||
127 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \ | ||
128 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \ | ||
129 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \ | ||
130 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\ | ||
131 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python\ | ||
132 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \ | ||
133 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \ | ||
134 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \ | ||
135 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \ | ||
136 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \ | ||
137 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \ | ||
138 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \ | ||
139 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \ | ||
140 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \ | ||
141 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \ | ||
142 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \ | ||
143 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \ | ||
144 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \ | ||
145 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \ | ||
146 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \ | ||
147 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \ | ||
148 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \ | ||
149 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \ | ||
150 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \ | ||
151 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \ | ||
152 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \ | ||
153 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \ | ||
154 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \ | ||
155 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \ | ||
156 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \ | ||
157 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \ | ||
158 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \ | ||
159 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \ | ||
160 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \ | ||
161 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \ | ||
162 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \ | ||
163 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \ | ||
164 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \ | ||
165 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \ | ||
166 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \ | ||
167 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \ | ||
168 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \ | ||
169 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \ | ||
170 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \ | ||
171 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \ | ||
172 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \ | ||
173 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \ | ||
174 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \ | ||
175 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \ | ||
176 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \ | ||
177 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \ | ||
178 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \ | ||
179 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \ | ||
180 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \ | ||
181 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/topfiles \ | ||
182 | ${libdir}/${PYTHON_DIR}/site-packages/Twisted*egg-info \ | ||
183 | " | ||
184 | |||
185 | FILES_${PN}-lore = " \ | ||
186 | ${bindir}/bookify \ | ||
187 | ${bindir}/lore \ | ||
188 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_lore.py* \ | ||
189 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/lore \ | ||
190 | " | ||
191 | |||
192 | FILES_${PN}-mail = " \ | ||
193 | ${bindir}/mailmail \ | ||
194 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \ | ||
195 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \ | ||
196 | " | ||
197 | |||
198 | FILES_${PN}-names = " \ | ||
199 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \ | ||
200 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/names \ | ||
201 | " | ||
202 | |||
203 | FILES_${PN}-news = " \ | ||
204 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \ | ||
205 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/news \ | ||
206 | " | ||
207 | |||
208 | FILES_${PN}-runner = " \ | ||
209 | ${libdir}/site-packages/twisted/runner/portmap.so \ | ||
210 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\ | ||
211 | " | ||
212 | |||
213 | FILES_${PN}-web = " \ | ||
214 | ${bindir}/websetroot \ | ||
215 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \ | ||
216 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/web\ | ||
217 | " | ||
218 | |||
219 | FILES_${PN}-words = " \ | ||
220 | ${bindir}/im \ | ||
221 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \ | ||
222 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/words\ | ||
223 | " | ||
224 | |||
225 | FILES_${PN}-flow = " \ | ||
226 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \ | ||
227 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \" | ||
228 | |||
229 | FILES_${PN}-pair = " \ | ||
230 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \ | ||
231 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \ | ||
232 | " | ||
233 | |||
234 | FILES_${PN}-dbg += " \ | ||
235 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \ | ||
236 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \ | ||
237 | " | ||
238 | |||
239 | RDEPENDS_{PN}-src = "${PN}" | ||
240 | FILES_${PN}-src = " \ | ||
241 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \ | ||
242 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*.py \ | ||
243 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/*.py \ | ||
244 | " | ||
diff --git a/recipes-devtools/python/python3-twisted_13.2.0.bb b/recipes-devtools/python/python3-twisted_13.2.0.bb deleted file mode 100644 index 98016cca..00000000 --- a/recipes-devtools/python/python3-twisted_13.2.0.bb +++ /dev/null | |||
@@ -1,67 +0,0 @@ | |||
1 | inherit pypi setuptools3 | ||
2 | require python-twisted.inc | ||
3 | |||
4 | RDEPENDS_${PN}-core = "python3-core python3-zopeinterface python3-lang" | ||
5 | |||
6 | FILES_${PN}-core_append += " \ | ||
7 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \ | ||
8 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__pycache__/*pyc \ | ||
9 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/__init__*.pyc \ | ||
10 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/notestplugin*.pyc \ | ||
11 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/testplugin*.pyc \ | ||
12 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_ftp*.pyc \ | ||
13 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_inet*.pyc \ | ||
14 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_manhole*.pyc \ | ||
15 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_portforward*.pyc \ | ||
16 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_socks*.pyc \ | ||
17 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_telnet*.pyc \ | ||
18 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_trial*.pyc \ | ||
19 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_core*.pyc \ | ||
20 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_qtstub*.pyc \ | ||
21 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_reactors*.pyc \ | ||
22 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/cred*.pyc \ | ||
23 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/dropin*.cache \ | ||
24 | " | ||
25 | |||
26 | FILES_${PN}-names_append = " \ | ||
27 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_names*.pyc \ | ||
28 | " | ||
29 | |||
30 | FILES_${PN}-news_append = " \ | ||
31 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_news*.pyc \ | ||
32 | " | ||
33 | |||
34 | FILES_${PN}-protocols_append += " \ | ||
35 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/__pycache__/*pyc \ | ||
36 | " | ||
37 | |||
38 | FILES_${PN}-conch_append = " \ | ||
39 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_conch*.pyc \ | ||
40 | " | ||
41 | |||
42 | FILES_${PN}-lore_append = " \ | ||
43 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_lore*.pyc \ | ||
44 | " | ||
45 | FILES_${PN}-mail_append = " \ | ||
46 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_mail*.pyc \ | ||
47 | " | ||
48 | |||
49 | FILES_${PN}-web_append = " \ | ||
50 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_web*.pyc \ | ||
51 | " | ||
52 | |||
53 | FILES_${PN}-words_append = " \ | ||
54 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_words*.pyc \ | ||
55 | " | ||
56 | |||
57 | FILES_${PN}-flow_append = " \ | ||
58 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_flow*.pyc \ | ||
59 | " | ||
60 | |||
61 | FILES_${PN}-pair_append = " \ | ||
62 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_pair*.pyc \ | ||
63 | " | ||
64 | |||
65 | FILES_${PN}-runner_append = " \ | ||
66 | ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__pycache__/twisted_runner*.pyc \ | ||
67 | " | ||