diff options
Diffstat (limited to 'recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch')
-rw-r--r-- | recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch | 64 |
1 files changed, 0 insertions, 64 deletions
diff --git a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch b/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch deleted file mode 100644 index 96e907d5..00000000 --- a/recipes-extended/xen/files/0001-python-pygrub-pass-DISTUTILS-xen.4.12.patch +++ /dev/null | |||
@@ -1,64 +0,0 @@ | |||
1 | From d79dcc2002008c58683de82f06c168d6eea57991 Mon Sep 17 00:00:00 2001 | ||
2 | From: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> | ||
3 | Date: Fri, 19 Oct 2018 11:01:37 +0200 | ||
4 | Subject: [PATCH] python,pygrub: pass DISTUTILS env vars as setup.py args | ||
5 | |||
6 | Allow to respect the target install dir (PYTHON_SITEPACKAGES_DIR) | ||
7 | as well as other parameters set by the OpenEmbedded build system. | ||
8 | This is especially useful when the target libdir is not the default one | ||
9 | (/usr/lib), but for example /usr/lib64. | ||
10 | |||
11 | Signed-off-by: Maciej Pijanowski <maciej.pijanowski@3mdeb.com> | ||
12 | |||
13 | Forward-ported to Xen 4.12.0 | ||
14 | Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> | ||
15 | |||
16 | Modified to support pygrub installation with python 3 | ||
17 | Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> | ||
18 | |||
19 | diff --git a/tools/pygrub/Makefile b/tools/pygrub/Makefile | ||
20 | index 3063c49..513314b 100644 | ||
21 | --- a/tools/pygrub/Makefile | ||
22 | +++ b/tools/pygrub/Makefile | ||
23 | @@ -10,14 +10,17 @@ INSTALL_LOG = build/installed_files.txt | ||
24 | all: build | ||
25 | .PHONY: build | ||
26 | build: | ||
27 | - CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) setup.py build | ||
28 | + CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) setup.py build $(DISTUTILS_BUILD_ARGS) | ||
29 | |||
30 | .PHONY: install | ||
31 | install: all | ||
32 | $(INSTALL_DIR) $(DESTDIR)/$(bindir) | ||
33 | CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) \ | ||
34 | setup.py install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \ | ||
35 | - --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force | ||
36 | + --root="$(DESTDIR)" --install-scripts=$(LIBEXEC_BIN) --force \ | ||
37 | + $(DISTUTILS_INSTALL_ARGS) | ||
38 | + rm -f $(DESTDIR)/$(LIBEXEC_BIN)/pygrub | ||
39 | + $(INSTALL_PYTHON_PROG) src/pygrub $(DESTDIR)/$(LIBEXEC_BIN)/pygrub | ||
40 | set -e; if [ $(bindir) != $(LIBEXEC_BIN) -a \ | ||
41 | "`readlink -f $(DESTDIR)/$(bindir)`" != \ | ||
42 | "`readlink -f $(LIBEXEC_BIN)`" ]; then \ | ||
43 | diff --git a/tools/python/Makefile b/tools/python/Makefile | ||
44 | index 541858e..4d4a344 100644 | ||
45 | --- a/tools/python/Makefile | ||
46 | +++ b/tools/python/Makefile | ||
47 | @@ -10,7 +10,7 @@ INSTALL_LOG = build/installed_files.txt | ||
48 | |||
49 | .PHONY: build | ||
50 | build: | ||
51 | - CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build | ||
52 | + CC="$(CC)" CFLAGS="$(PY_CFLAGS)" $(PYTHON) setup.py build $(DISTUTILS_BUILD_ARGS) | ||
53 | |||
54 | .PHONY: install | ||
55 | install: | ||
56 | @@ -18,7 +18,7 @@ install: | ||
57 | |||
58 | CC="$(CC)" CFLAGS="$(PY_CFLAGS)" LDFLAGS="$(PY_LDFLAGS)" $(PYTHON) \ | ||
59 | setup.py install --record $(INSTALL_LOG) $(PYTHON_PREFIX_ARG) \ | ||
60 | - --root="$(DESTDIR)" --force | ||
61 | + --root="$(DESTDIR)" --force $(DISTUTILS_INSTALL_ARGS) | ||
62 | |||
63 | $(INSTALL_PROG) scripts/convert-legacy-stream $(DESTDIR)$(LIBEXEC_BIN) | ||
64 | $(INSTALL_PROG) scripts/verify-stream-v2 $(DESTDIR)$(LIBEXEC_BIN) | ||