summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch')
-rw-r--r--recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch33
1 files changed, 10 insertions, 23 deletions
diff --git a/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch b/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch
index 35a3d5b3..98224b42 100644
--- a/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch
+++ b/recipes-networking/openvswitch/files/openvswitch-add-target-perl-handling.patch
@@ -16,11 +16,11 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
16 utilities/ovs-parse-leaks.in | 2 +- 16 utilities/ovs-parse-leaks.in | 2 +-
17 3 files changed, 9 insertions(+), 1 deletion(-) 17 3 files changed, 9 insertions(+), 1 deletion(-)
18 18
19diff --git a/Makefile.am b/Makefile.am 19Index: openvswitch-2.0.0/Makefile.am
20index c4f8341..45488f2 100644 20===================================================================
21--- a/Makefile.am 21--- openvswitch-2.0.0.orig/Makefile.am
22+++ b/Makefile.am 22+++ openvswitch-2.0.0/Makefile.am
23@@ -111,6 +111,7 @@ SUFFIXES += .in 23@@ -114,6 +114,7 @@
24 -e 's,[@]LOGDIR[@],$(LOGDIR),g' \ 24 -e 's,[@]LOGDIR[@],$(LOGDIR),g' \
25 -e 's,[@]DBDIR[@],$(DBDIR),g' \ 25 -e 's,[@]DBDIR[@],$(DBDIR),g' \
26 -e 's,[@]PERL[@],$(PERL),g' \ 26 -e 's,[@]PERL[@],$(PERL),g' \
@@ -28,11 +28,11 @@ index c4f8341..45488f2 100644
28 -e 's,[@]PYTHON[@],$(PYTHON),g' \ 28 -e 's,[@]PYTHON[@],$(PYTHON),g' \
29 -e 's,[@]TARGET_PYTHON[@],$(TARGET_PYTHON),g' \ 29 -e 's,[@]TARGET_PYTHON[@],$(TARGET_PYTHON),g' \
30 -e 's,[@]RUNDIR[@],$(RUNDIR),g' \ 30 -e 's,[@]RUNDIR[@],$(RUNDIR),g' \
31diff --git a/configure.ac b/configure.ac 31Index: openvswitch-2.0.0/configure.ac
32index 74cb691..5e39893 100644 32===================================================================
33--- a/configure.ac 33--- openvswitch-2.0.0.orig/configure.ac
34+++ b/configure.ac 34+++ openvswitch-2.0.0/configure.ac
35@@ -101,6 +101,13 @@ AC_ARG_VAR(KARCH, [Kernel Architecture String]) 35@@ -115,6 +115,13 @@
36 AC_SUBST(KARCH) 36 AC_SUBST(KARCH)
37 OVS_CHECK_LINUX 37 OVS_CHECK_LINUX
38 38
@@ -46,16 +46,3 @@ index 74cb691..5e39893 100644
46 if test "$TARGET_PYTHON"; then 46 if test "$TARGET_PYTHON"; then
47 TARGET_PYTHON=$TARGET_PYTHON 47 TARGET_PYTHON=$TARGET_PYTHON
48 else 48 else
49diff --git a/utilities/ovs-parse-leaks.in b/utilities/ovs-parse-leaks.in
50index 72417e5..7c9436c 100755
51--- a/utilities/ovs-parse-leaks.in
52+++ b/utilities/ovs-parse-leaks.in
53@@ -1,4 +1,4 @@
54-#! @PERL@
55+#! @TARGET_PERL@
56
57 # Copyright (c) 2009, 2010 Nicira, Inc.
58 #
59--
601.8.1.2
61