summaryrefslogtreecommitdiffstats
path: root/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch')
-rw-r--r--recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch136
1 files changed, 0 insertions, 136 deletions
diff --git a/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch b/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch
deleted file mode 100644
index 97b352cb..00000000
--- a/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch
+++ /dev/null
@@ -1,136 +0,0 @@
1From e8a5d34885c5fdba7d951fb1bb85131cbafca432 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Wed, 19 Jun 2013 17:25:56 -0400
4Subject: [PATCH] openvswitch: add target python handling
5
6Allow the build to specify a path for the python instead of reusing
7the PYTHON variable which can lead to inconsistencies if we are cross
8compiling. The TARGET_PYTHON variable will be used for script
9substitutions to ensure the scripts will be able to properly execute
10if the target system has a different path for the python.
11
12Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
13---
14 Makefile.am | 1 +
15 configure.ac | 7 +++++++
16 ovsdb/ovsdbmonitor/ovsdbmonitor.in | 2 +-
17 utilities/bugtool/ovs-bugtool.in | 2 +-
18 utilities/ovs-check-dead-ifs.in | 2 +-
19 utilities/ovs-l3ping.in | 2 +-
20 utilities/ovs-parse-backtrace.in | 2 +-
21 utilities/ovs-pcap.in | 2 +-
22 utilities/ovs-tcpundump.in | 2 +-
23 utilities/ovs-test.in | 2 +-
24 utilities/ovs-vlan-test.in | 2 +-
25 11 files changed, 17 insertions(+), 9 deletions(-)
26
27Index: openvswitch-2.1.2/Makefile.am
28===================================================================
29--- openvswitch-2.1.2.orig/Makefile.am
30+++ openvswitch-2.1.2/Makefile.am
31@@ -125,6 +125,7 @@
32 -e 's,[@]DBDIR[@],$(DBDIR),g' \
33 -e 's,[@]PERL[@],$(PERL),g' \
34 -e 's,[@]PYTHON[@],$(PYTHON),g' \
35+ -e 's,[@]TARGET_PYTHON[@],$(TARGET_PYTHON),g' \
36 -e 's,[@]RUNDIR[@],$(RUNDIR),g' \
37 -e 's,[@]VERSION[@],$(VERSION),g' \
38 -e 's,[@]localstatedir[@],$(localstatedir),g' \
39Index: openvswitch-2.1.2/configure.ac
40===================================================================
41--- openvswitch-2.1.2.orig/configure.ac
42+++ openvswitch-2.1.2/configure.ac
43@@ -118,6 +118,13 @@
44 AC_SUBST(KARCH)
45 OVS_CHECK_LINUX
46
47+if test "$TARGET_PYTHON"; then
48+ TARGET_PYTHON=$TARGET_PYTHON
49+else
50+ TARGET_PYTHON=$PYTHON
51+fi
52+AC_SUBST(TARGET_PYTHON)
53+
54 AC_CONFIG_FILES(Makefile)
55 AC_CONFIG_FILES(datapath/Makefile)
56 AC_CONFIG_FILES(datapath/linux/Kbuild)
57Index: openvswitch-2.1.2/utilities/bugtool/ovs-bugtool.in
58===================================================================
59--- openvswitch-2.1.2.orig/utilities/bugtool/ovs-bugtool.in
60+++ openvswitch-2.1.2/utilities/bugtool/ovs-bugtool.in
61@@ -1,4 +1,4 @@
62-#! @PYTHON@
63+#! @TARGET_PYTHON@
64
65 # This library is free software; you can redistribute it and/or
66 # modify it under the terms of version 2.1 of the GNU Lesser General Public
67Index: openvswitch-2.1.2/utilities/ovs-check-dead-ifs.in
68===================================================================
69--- openvswitch-2.1.2.orig/utilities/ovs-check-dead-ifs.in
70+++ openvswitch-2.1.2/utilities/ovs-check-dead-ifs.in
71@@ -1,4 +1,4 @@
72-#! @PYTHON@
73+#! @TARGET_PYTHON@
74
75 import os
76 import re
77Index: openvswitch-2.1.2/utilities/ovs-l3ping.in
78===================================================================
79--- openvswitch-2.1.2.orig/utilities/ovs-l3ping.in
80+++ openvswitch-2.1.2/utilities/ovs-l3ping.in
81@@ -1,4 +1,4 @@
82-#! @PYTHON@
83+#! @TARGET_PYTHON@
84 #
85 # Licensed under the Apache License, Version 2.0 (the "License");
86 # you may not use this file except in compliance with the License.
87Index: openvswitch-2.1.2/utilities/ovs-parse-backtrace.in
88===================================================================
89--- openvswitch-2.1.2.orig/utilities/ovs-parse-backtrace.in
90+++ openvswitch-2.1.2/utilities/ovs-parse-backtrace.in
91@@ -1,4 +1,4 @@
92-#! @PYTHON@
93+#! @TARGET_PYTHON@
94 #
95 # Copyright (c) 2012 Nicira, Inc.
96 #
97Index: openvswitch-2.1.2/utilities/ovs-pcap.in
98===================================================================
99--- openvswitch-2.1.2.orig/utilities/ovs-pcap.in
100+++ openvswitch-2.1.2/utilities/ovs-pcap.in
101@@ -1,4 +1,4 @@
102-#! @PYTHON@
103+#! @TARGET_PYTHON@
104 #
105 # Copyright (c) 2010 Nicira, Inc.
106 #
107Index: openvswitch-2.1.2/utilities/ovs-tcpundump.in
108===================================================================
109--- openvswitch-2.1.2.orig/utilities/ovs-tcpundump.in
110+++ openvswitch-2.1.2/utilities/ovs-tcpundump.in
111@@ -1,4 +1,4 @@
112-#! @PYTHON@
113+#! @TARGET_PYTHON@
114 #
115 # Copyright (c) 2010 Nicira, Inc.
116 #
117Index: openvswitch-2.1.2/utilities/ovs-test.in
118===================================================================
119--- openvswitch-2.1.2.orig/utilities/ovs-test.in
120+++ openvswitch-2.1.2/utilities/ovs-test.in
121@@ -1,4 +1,4 @@
122-#! @PYTHON@
123+#! @TARGET_PYTHON@
124 #
125 # Licensed under the Apache License, Version 2.0 (the "License");
126 # you may not use this file except in compliance with the License.
127Index: openvswitch-2.1.2/utilities/ovs-vlan-test.in
128===================================================================
129--- openvswitch-2.1.2.orig/utilities/ovs-vlan-test.in
130+++ openvswitch-2.1.2/utilities/ovs-vlan-test.in
131@@ -1,4 +1,4 @@
132-#! @PYTHON@
133+#! @TARGET_PYTHON@
134 #
135 # Copyright (c) 2010 Nicira, Inc.
136 #