diff options
Diffstat (limited to 'recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch')
-rw-r--r-- | recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch | 103 |
1 files changed, 45 insertions, 58 deletions
diff --git a/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch b/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch index 59607dad..97b352cb 100644 --- a/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch +++ b/recipes-networking/openvswitch/files/openvswitch-add-target-python-handling.patch | |||
@@ -24,11 +24,11 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | |||
24 | utilities/ovs-vlan-test.in | 2 +- | 24 | utilities/ovs-vlan-test.in | 2 +- |
25 | 11 files changed, 17 insertions(+), 9 deletions(-) | 25 | 11 files changed, 17 insertions(+), 9 deletions(-) |
26 | 26 | ||
27 | diff --git a/Makefile.am b/Makefile.am | 27 | Index: openvswitch-2.1.2/Makefile.am |
28 | index b71ca1f..c4f8341 100644 | 28 | =================================================================== |
29 | --- a/Makefile.am | 29 | --- openvswitch-2.1.2.orig/Makefile.am |
30 | +++ b/Makefile.am | 30 | +++ openvswitch-2.1.2/Makefile.am |
31 | @@ -112,6 +112,7 @@ SUFFIXES += .in | 31 | @@ -125,6 +125,7 @@ |
32 | -e 's,[@]DBDIR[@],$(DBDIR),g' \ | 32 | -e 's,[@]DBDIR[@],$(DBDIR),g' \ |
33 | -e 's,[@]PERL[@],$(PERL),g' \ | 33 | -e 's,[@]PERL[@],$(PERL),g' \ |
34 | -e 's,[@]PYTHON[@],$(PYTHON),g' \ | 34 | -e 's,[@]PYTHON[@],$(PYTHON),g' \ |
@@ -36,11 +36,11 @@ index b71ca1f..c4f8341 100644 | |||
36 | -e 's,[@]RUNDIR[@],$(RUNDIR),g' \ | 36 | -e 's,[@]RUNDIR[@],$(RUNDIR),g' \ |
37 | -e 's,[@]VERSION[@],$(VERSION),g' \ | 37 | -e 's,[@]VERSION[@],$(VERSION),g' \ |
38 | -e 's,[@]localstatedir[@],$(localstatedir),g' \ | 38 | -e 's,[@]localstatedir[@],$(localstatedir),g' \ |
39 | diff --git a/configure.ac b/configure.ac | 39 | Index: openvswitch-2.1.2/configure.ac |
40 | index 060b53f..74cb691 100644 | 40 | =================================================================== |
41 | --- a/configure.ac | 41 | --- openvswitch-2.1.2.orig/configure.ac |
42 | +++ b/configure.ac | 42 | +++ openvswitch-2.1.2/configure.ac |
43 | @@ -101,6 +101,13 @@ AC_ARG_VAR(KARCH, [Kernel Architecture String]) | 43 | @@ -118,6 +118,13 @@ |
44 | AC_SUBST(KARCH) | 44 | AC_SUBST(KARCH) |
45 | OVS_CHECK_LINUX | 45 | OVS_CHECK_LINUX |
46 | 46 | ||
@@ -51,99 +51,86 @@ index 060b53f..74cb691 100644 | |||
51 | +fi | 51 | +fi |
52 | +AC_SUBST(TARGET_PYTHON) | 52 | +AC_SUBST(TARGET_PYTHON) |
53 | + | 53 | + |
54 | AC_CONFIG_FILES([Makefile | 54 | AC_CONFIG_FILES(Makefile) |
55 | datapath/Makefile | 55 | AC_CONFIG_FILES(datapath/Makefile) |
56 | datapath/linux/Kbuild | 56 | AC_CONFIG_FILES(datapath/linux/Kbuild) |
57 | diff --git a/ovsdb/ovsdbmonitor/ovsdbmonitor.in b/ovsdb/ovsdbmonitor/ovsdbmonitor.in | 57 | Index: openvswitch-2.1.2/utilities/bugtool/ovs-bugtool.in |
58 | index e26130a..aaf1aff 100755 | 58 | =================================================================== |
59 | --- a/ovsdb/ovsdbmonitor/ovsdbmonitor.in | 59 | --- openvswitch-2.1.2.orig/utilities/bugtool/ovs-bugtool.in |
60 | +++ b/ovsdb/ovsdbmonitor/ovsdbmonitor.in | 60 | +++ openvswitch-2.1.2/utilities/bugtool/ovs-bugtool.in |
61 | @@ -1,4 +1,4 @@ | ||
62 | -#! @PYTHON@ | ||
63 | +#! @TARGET_PYTHON@ | ||
64 | # Copyright (c) 2010 Citrix Systems, Inc. | ||
65 | # | ||
66 | # Licensed under the Apache License, Version 2.0 (the "License"); | ||
67 | diff --git a/utilities/bugtool/ovs-bugtool.in b/utilities/bugtool/ovs-bugtool.in | ||
68 | index 2074e23..525939e 100755 | ||
69 | --- a/utilities/bugtool/ovs-bugtool.in | ||
70 | +++ b/utilities/bugtool/ovs-bugtool.in | ||
71 | @@ -1,4 +1,4 @@ | 61 | @@ -1,4 +1,4 @@ |
72 | -#! @PYTHON@ | 62 | -#! @PYTHON@ |
73 | +#! @TARGET_PYTHON@ | 63 | +#! @TARGET_PYTHON@ |
74 | 64 | ||
75 | # This library is free software; you can redistribute it and/or | 65 | # This library is free software; you can redistribute it and/or |
76 | # modify it under the terms of version 2.1 of the GNU Lesser General Public | 66 | # modify it under the terms of version 2.1 of the GNU Lesser General Public |
77 | diff --git a/utilities/ovs-check-dead-ifs.in b/utilities/ovs-check-dead-ifs.in | 67 | Index: openvswitch-2.1.2/utilities/ovs-check-dead-ifs.in |
78 | index 9b806ed..b6f6fcb 100755 | 68 | =================================================================== |
79 | --- a/utilities/ovs-check-dead-ifs.in | 69 | --- openvswitch-2.1.2.orig/utilities/ovs-check-dead-ifs.in |
80 | +++ b/utilities/ovs-check-dead-ifs.in | 70 | +++ openvswitch-2.1.2/utilities/ovs-check-dead-ifs.in |
81 | @@ -1,4 +1,4 @@ | 71 | @@ -1,4 +1,4 @@ |
82 | -#! @PYTHON@ | 72 | -#! @PYTHON@ |
83 | +#! @TARGET_PYTHON@ | 73 | +#! @TARGET_PYTHON@ |
84 | 74 | ||
85 | import os | 75 | import os |
86 | import re | 76 | import re |
87 | diff --git a/utilities/ovs-l3ping.in b/utilities/ovs-l3ping.in | 77 | Index: openvswitch-2.1.2/utilities/ovs-l3ping.in |
88 | index 1b07972..4fedb6f 100644 | 78 | =================================================================== |
89 | --- a/utilities/ovs-l3ping.in | 79 | --- openvswitch-2.1.2.orig/utilities/ovs-l3ping.in |
90 | +++ b/utilities/ovs-l3ping.in | 80 | +++ openvswitch-2.1.2/utilities/ovs-l3ping.in |
91 | @@ -1,4 +1,4 @@ | 81 | @@ -1,4 +1,4 @@ |
92 | -#! @PYTHON@ | 82 | -#! @PYTHON@ |
93 | +#! @TARGET_PYTHON@ | 83 | +#! @TARGET_PYTHON@ |
94 | # | 84 | # |
95 | # Licensed under the Apache License, Version 2.0 (the "License"); | 85 | # Licensed under the Apache License, Version 2.0 (the "License"); |
96 | # you may not use this file except in compliance with the License. | 86 | # you may not use this file except in compliance with the License. |
97 | diff --git a/utilities/ovs-parse-backtrace.in b/utilities/ovs-parse-backtrace.in | 87 | Index: openvswitch-2.1.2/utilities/ovs-parse-backtrace.in |
98 | index 4f793be..4a07f47 100755 | 88 | =================================================================== |
99 | --- a/utilities/ovs-parse-backtrace.in | 89 | --- openvswitch-2.1.2.orig/utilities/ovs-parse-backtrace.in |
100 | +++ b/utilities/ovs-parse-backtrace.in | 90 | +++ openvswitch-2.1.2/utilities/ovs-parse-backtrace.in |
101 | @@ -1,4 +1,4 @@ | 91 | @@ -1,4 +1,4 @@ |
102 | -#! @PYTHON@ | 92 | -#! @PYTHON@ |
103 | +#! @TARGET_PYTHON@ | 93 | +#! @TARGET_PYTHON@ |
104 | # | 94 | # |
105 | # Copyright (c) 2012 Nicira, Inc. | 95 | # Copyright (c) 2012 Nicira, Inc. |
106 | # | 96 | # |
107 | diff --git a/utilities/ovs-pcap.in b/utilities/ovs-pcap.in | 97 | Index: openvswitch-2.1.2/utilities/ovs-pcap.in |
108 | index 5306480..3221c7c 100755 | 98 | =================================================================== |
109 | --- a/utilities/ovs-pcap.in | 99 | --- openvswitch-2.1.2.orig/utilities/ovs-pcap.in |
110 | +++ b/utilities/ovs-pcap.in | 100 | +++ openvswitch-2.1.2/utilities/ovs-pcap.in |
111 | @@ -1,4 +1,4 @@ | 101 | @@ -1,4 +1,4 @@ |
112 | -#! @PYTHON@ | 102 | -#! @PYTHON@ |
113 | +#! @TARGET_PYTHON@ | 103 | +#! @TARGET_PYTHON@ |
114 | # | 104 | # |
115 | # Copyright (c) 2010 Nicira, Inc. | 105 | # Copyright (c) 2010 Nicira, Inc. |
116 | # | 106 | # |
117 | diff --git a/utilities/ovs-tcpundump.in b/utilities/ovs-tcpundump.in | 107 | Index: openvswitch-2.1.2/utilities/ovs-tcpundump.in |
118 | index 0268c50..dad0bb5 100755 | 108 | =================================================================== |
119 | --- a/utilities/ovs-tcpundump.in | 109 | --- openvswitch-2.1.2.orig/utilities/ovs-tcpundump.in |
120 | +++ b/utilities/ovs-tcpundump.in | 110 | +++ openvswitch-2.1.2/utilities/ovs-tcpundump.in |
121 | @@ -1,4 +1,4 @@ | 111 | @@ -1,4 +1,4 @@ |
122 | -#! @PYTHON@ | 112 | -#! @PYTHON@ |
123 | +#! @TARGET_PYTHON@ | 113 | +#! @TARGET_PYTHON@ |
124 | # | 114 | # |
125 | # Copyright (c) 2010 Nicira, Inc. | 115 | # Copyright (c) 2010 Nicira, Inc. |
126 | # | 116 | # |
127 | diff --git a/utilities/ovs-test.in b/utilities/ovs-test.in | 117 | Index: openvswitch-2.1.2/utilities/ovs-test.in |
128 | index fb1f9ad..bddd327 100644 | 118 | =================================================================== |
129 | --- a/utilities/ovs-test.in | 119 | --- openvswitch-2.1.2.orig/utilities/ovs-test.in |
130 | +++ b/utilities/ovs-test.in | 120 | +++ openvswitch-2.1.2/utilities/ovs-test.in |
131 | @@ -1,4 +1,4 @@ | 121 | @@ -1,4 +1,4 @@ |
132 | -#! @PYTHON@ | 122 | -#! @PYTHON@ |
133 | +#! @TARGET_PYTHON@ | 123 | +#! @TARGET_PYTHON@ |
134 | # | 124 | # |
135 | # Licensed under the Apache License, Version 2.0 (the "License"); | 125 | # Licensed under the Apache License, Version 2.0 (the "License"); |
136 | # you may not use this file except in compliance with the License. | 126 | # you may not use this file except in compliance with the License. |
137 | diff --git a/utilities/ovs-vlan-test.in b/utilities/ovs-vlan-test.in | 127 | Index: openvswitch-2.1.2/utilities/ovs-vlan-test.in |
138 | index e229498..da64040 100755 | 128 | =================================================================== |
139 | --- a/utilities/ovs-vlan-test.in | 129 | --- openvswitch-2.1.2.orig/utilities/ovs-vlan-test.in |
140 | +++ b/utilities/ovs-vlan-test.in | 130 | +++ openvswitch-2.1.2/utilities/ovs-vlan-test.in |
141 | @@ -1,4 +1,4 @@ | 131 | @@ -1,4 +1,4 @@ |
142 | -#! @PYTHON@ | 132 | -#! @PYTHON@ |
143 | +#! @TARGET_PYTHON@ | 133 | +#! @TARGET_PYTHON@ |
144 | # | 134 | # |
145 | # Copyright (c) 2010 Nicira, Inc. | 135 | # Copyright (c) 2010 Nicira, Inc. |
146 | # | 136 | # |
147 | -- | ||
148 | 1.8.1.2 | ||
149 | |||